forum.coppermine-gallery.net

Support => cpg1.5.x Support => cpg1.5 upgrading => Topic started by: Manutjee on July 16, 2018, 04:51:42 pm

Title: Can't upgrade CPG; can't even login
Post by: Manutjee on July 16, 2018, 04:51:42 pm
Hey everyone,

I've been told that there's been a security release for Coppermine recently in terms of getting it to work with PHP 7.0.
However... I've been having these issues.

I can't login to Coppermine so I'm not even able to upgrade it and switch from PHP 5.6 to PHP 7.0
I keep getting the error: "Warning your browser does not accept script's cookies" and with the new EU-law (GDPR etc) I need things to work properly.

I've also been reading about getting into phpMyAdmin and what not, but I have no clue how this works.

Is someone able to help me out and get things up and running without errors?
Title: Re: Can't upgrade CPG; can't even login
Post by: ron4mac on July 16, 2018, 09:46:47 pm
Uninstall Cookie Consent Plugin
Title: Re: Re: Can't upgrade CPG; can't even login
Post by: Manutjee on July 16, 2018, 10:23:39 pm
Uninstall Cookie Consent Plugin

That's already done. Still having issues.
Title: Re: Can't upgrade CPG; can't even login
Post by: Phill Luckhurst on July 16, 2018, 11:21:15 pm
Now try a different browser
Title: Re: Can't upgrade CPG; can't even login
Post by: Manutjee on July 17, 2018, 12:46:03 pm
It wasn't a browser issue.
It was a wrong value in the Coppermine database.

Fixed by changing 1 to 0 in cookies_need_consent in cpg_config table in Coppermine's database