forum.coppermine-gallery.net

Support => cpg1.5.x Support => cpg1.5 upgrading => Topic started by: anhonestman on February 10, 2012, 07:29:18 pm

Title: Missing mandatory files
Post by: anhonestman on February 10, 2012, 07:29:18 pm
I was advised by my hosting company that my installation of Coppermine had been hacked and that they had deleted several files as a consequence.  I upgraded from 1.5.16 to 1.5.18, not including the albums directory as instructed, which appeared to run acceptably. On doing a version check, I got a missing mandatory file error for the following three files

albums/edit/index.php
albums/edit/no_FTP-uploads_into_this_folder!.txt
albums/userpics/no_FTP-uploads_into_this_folder!.txt

Do I need to take any action on this?

 
Title: Re: Missing mandatory files
Post by: phill104 on February 10, 2012, 08:02:15 pm
It would be a good ideat to restore those files from the download. If I were you I would also run a check on all your image files as if a hacker has got in then they can add their own jpeg files with code embedded.
Title: Re: Missing mandatory files
Post by: anhonestman on February 10, 2012, 08:39:46 pm
Thanks. Will do both.
Title: Re: Missing mandatory files
Post by: Loek037 on February 11, 2012, 03:14:10 pm
I have the same problem. I used cpanel to install. Same files are missing.
Title: Re: Missing mandatory files
Post by: phill104 on February 12, 2012, 03:05:42 am
Unfortunately, we cannot support versions installed via cpanel or fantastico. You are not stuffed though, simply download a copy from our downloads section then follow the normal upgrade procedure outlined in the docs and you should be good to go.

Just one last thing, please always start your own thread in future. We prefer to keep each individuals issues in separate threads.