forum.coppermine-gallery.net

Support => Older/other versions => cpg1.2 Standalone Support => Topic started by: lqo27 on October 18, 2003, 12:47:46 am

Title: XP Publisher, how to use it?
Post by: lqo27 on October 18, 2003, 12:47:46 am
Where did the docimentation of how to use the XP Publisher go? I remeber that there was a documentation of how to use the XP Publisher. Can someone please tell me how to use XP Publisher?
Title: XP Publisher, how to use it?
Post by: intranet on October 18, 2003, 01:05:11 am
Goto xp_publish.php in your root folder , it is the documentation
Title: XP Publisher, how to use it?
Post by: jasendorf on October 18, 2003, 02:06:21 am
If you go to docs/README.html the instructions are there.

Quote
If you are using Windows XP, you can use its built-in web publishing wizard to upload your photos to your gallery.

Once you have properly installed the script on your server, call the xp_publish.php file from your web browser (http://your_site.com/coppermine_dir/xp_publish.php).

The script displays some information on how to do the installation on the client side and how to use the Wizard. Basically you will need to download a small file created by the script that needs to be loaded into your Windows registry.
Title: XP Publisher, how to use it?
Post by: Sogeri on October 31, 2003, 09:45:32 pm
I have tried this several times, followed the instructions implicitly but I cannot see this:

In Windows Explorer, select some files and click on Publish xxx on the web  in the left pane

Where exactly in the 'left pane' can I find 'Publish xxx on the web'? :roll:

The file cpg_pub_wizard.reg has been installed several times in the registry.

Thanks!
Title: XP Publisher, how to use it?
Post by: jasendorf on October 31, 2003, 10:44:53 pm
Can you post a screen shot?  Are you using Windows XP as a client?
Title: XP Publisher, how to use it?
Post by: jasendorf on October 31, 2003, 10:49:50 pm
Should look like this:

(http://www.lcounty.com/asendorf/xp_publish.jpg)
Title: XP Publisher, how to use it?
Post by: Sogeri on October 31, 2003, 11:32:33 pm
Here is the screenshot:

(http://www.orchidspng.com/xp_publish.JPG)

I am using Win XP. Now that I have seen your screenshot I obviously need to open a different kind of Windows Explorer.
Title: XP Publisher, how to use it?
Post by: Zarsky on November 01, 2003, 12:02:34 am
sogeri,

You are using the classic view of windows explorer....you need to enable the sidebar or the luna based template for windows.
Title: XP Publisher, how to use it?
Post by: wormie_dk on November 01, 2003, 04:54:44 pm
Or close the folder list...
Title: images broken
Post by: jpnaja on January 27, 2004, 01:57:35 pm
when using the xp publisher, images that are displayed in FTP control panel are broken and i can't move them to an album.

can you help me please?
Title: XP Publisher, how to use it?
Post by: Satyr on March 11, 2004, 09:25:07 pm
This client worked properly some weeks, but since today it doesn't work! When i login into the gallery the client says that i shall login. But i am logged in, using also the function "remember me".

Why it does not work anymore? I changed nothing!
Title: web service error when trying to upload with xp publisher
Post by: easydoesit on March 11, 2004, 10:15:08 pm
I get a web service error when trying to connect to my photo gallery using xp publisher.

Quote
the wizard could not connect to the internet, or the web service returned a wizard page that is not valid.


The download and installation of the Windows Registry File went fine.  After I select my photo gallery from the list it outputs the web service error message above.

xp publisher was working a week ago when i first tried it out, but today i have tried on 2 different computers and it hasn't worked.
Title: XP Publisher, how to use it?
Post by: Satyr on March 11, 2004, 10:18:38 pm
Do you have your firewall on? Maybe it does block... ^^
Title: XP Publisher, how to use it?
Post by: easydoesit on March 11, 2004, 10:19:19 pm
:(    Nope.
Title: XP Publisher, how to use it?
Post by: easydoesit on March 11, 2004, 10:19:39 pm
Quote from: "Satyr"
This client worked properly some weeks, but since today it doesn't work! When i login into the gallery the client says that i shall login. But i am logged in, using also the function "remember me".

Why it does not work anymore? I changed nothing!


That happened to me once I cleared my cookies and it was recognizing me again.  :wink:  I don't use the remember me option anymore.
Title: XP Publisher, how to use it?
Post by: Satyr on March 11, 2004, 10:34:07 pm
I tried this and it worked!  :)  The problem occured after i logged into this board. Maybe a conflict of the cookies? I have the same board, but another cookiename... ^^
Title: XP Publisher, how to use it?
Post by: Joachim Müller on March 12, 2004, 07:15:06 am
And what is the actual problem? :?

GauGau
Title: XP Publisher, how to use it?
Post by: Satyr on March 12, 2004, 10:36:46 am
http://www.gothicmodels.net/gothicmodels/gallery

The actual and only problem is on top right, the button "logout: anonymous". It should be: "Login".
I can only login over PhpBB....
Title: Incomplete transfer of files using XP Publisher
Post by: fhyre on March 17, 2004, 12:35:50 pm
I have just set up Coppermine on my server and I'm very impressed. It has been working really well but it would be ideal if I could use the Windows XP publisher.

The publisher works - I installed it, the icon appears, and it uploads images. However it seems to only upload half of the pictures selected. I'm not sure why this is. I turned on debug mode and couldn't find any xp_publish.log to tell me what had gone wrong. It just seems that once I have about 16 images in an album, it conks out, if not before.

This may be to do with the permissions on my server, as they tend to be a bit fussy... or to do with space. But I checked the permissions which seemed to be ok, and there seems to be ample space left. Has anyone had this problem, and do they know of a solution?

Cheers,

Joe Braidwood
Title: XP Publisher, how to use it?
Post by: Joachim Müller on March 17, 2004, 09:13:21 pm
Quote from: "Satyr"
The actual and only problem is on top right, the button "logout: anonymous". It should be: "Login".
I can only login over PhpBB....
And how is this related to the XP-publisher? This thread deals with the publisher only, in no way related to login/logout/integration. Next time, reply to the appropriate thread. :evil:

GauGau

P.S. When visiting your page, login displays just fine for me...
Title: XP Publisher, how to use it?
Post by: fhyre on March 17, 2004, 09:31:03 pm
so GauGau, have any idea about my problem?
Title: XP Publisher, how to use it?
Post by: Joachim Müller on March 17, 2004, 09:44:55 pm
This is not a hotline :x ! If I don't answer your question there may be a reason. Allow some times for supporters to answer (days, not hours).

In your special case, the reasonwhy I didn't reply is: I don't have Windows XP, so I've never looked at the XP publisher, and probably never will. Should I have posted "I don't know"? Would you have been happier then?

GauGau
Title: XP Publisher, how to use it?
Post by: fhyre on March 18, 2004, 04:41:41 am
Quote from: "gaugau"
And how is this related to the XP-publisher? This thread deals with the publisher only, in no way related to login/logout/integration. Next time, reply to the appropriate thread. :evil:


Quote from: "gaugau"
I don't have Windows XP, so I've never looked at the XP publisher, and probably never will.


And how was that related to XP-Publisher?
Title: XP Publisher, how to use it?
Post by: Joachim Müller on March 18, 2004, 07:57:05 am
flame off, back to the subject of the thread please.

GauGau
Title: XP Publisher, how to use it?
Post by: knik on April 08, 2004, 04:33:41 pm
so I found out how it works..

I pushed the button " publish on the web"

And then I got the wizard.. seems fine.

But then I got the message that there's no internet connection or a false webdirection. In dutch because I'm dutch but I tried to translate.

I also have a problem with regularly uploading. But as far as I know that hasn't got something to do with it. Because the error I got with "regularly uploading"  is :

Error
Only files with the following extensions are accepted :

.
Title: XP Publisher, how to use it?
Post by: Casper on April 08, 2004, 06:00:51 pm
Nikki, did you follow all the instructions of xp_publish.php.

I asked on another thread, which version of coppermine are you using, I get the impression it's 1.3beta.  We need to know this, as the upload procedures are different for this newer version.

Also, please do not keep repeating the same problem on different threads.  This is the third thread were I've read about your file extension problem.
Title: Re: XP Publisher, how to use it?
Post by: gijs_schouten on April 26, 2004, 04:53:27 pm
Hello there,
I've just started using coppermine and really like it alot.... I would like to make the xp publish method available for my users, because that makes it a lot easier for them. I've tried it myself and it works perfectly! The only problem i have with it, is that i want my users to be able to upload in certain specific public albums i've created. But only admins have the option of uploading in public albums as far as i've found out... can anyone help me to give regular user  the option of uploading in public albums and not just their own?

thanx

www.gijs-design.com
Title: Re: XP Publisher, how to use it?
Post by: Joachim Müller on April 26, 2004, 05:38:13 pm
your question is not related to xp_publisher, but should have been posted with a subject like "how can users upload to public albums". If you would have searched the board, you would have found out that there are plenty of threads dealing with this question.
To create a public album everybody is allowed to, refer to http://coppermine.sourceforge.net/faq.php?q=createPublicAlbum#createPublicAlbum
It's the same for a special user group, just set the permissions for this special group instead of the unregistered/anonymous group.

GauGau
Title: Re: XP Publisher, how to use it?
Post by: gijs_schouten on April 26, 2004, 05:55:54 pm
thank you for such a fast response.. i have read the forum some more and indeed have found some answers to my question. sorry for not reading enough first...

my problem was/is however indeed related to xp_publish... I have found a topic inwhich an alteration was made to the xp_publish.php to give registered members the option of uploading to public albums... I had given them the right to do so but the albums never apeared in the wizard... Now i've made the alterations, the albums apear in the list, but when a member tries to upload to one of those albums the files are not uploaded at all.. no error or anything, not in the wizard or in the log file...

so it is still a bit of a mystery to me...

Title: Re: XP Publisher, how to use it?
Post by: Joachim Müller on April 26, 2004, 06:21:54 pm
post a link to th thread you're refering to.

GauGau
Title: Re: XP Publisher, how to use it?
Post by: gijs_schouten on April 26, 2004, 07:33:30 pm
Here U go:
http://forum.coppermine-gallery.net/index.php?topic=2584

that was the topic i was talking about...

i have made the changes that are suggested here, but i still can't upload to the public albums as a registered user whilst this works fine trough the webinterface...

i would love to offer this functionality to my users...
thanx for helping out
Title: Re: XP Publisher, how to use it?
Post by: Joachim Müller on April 27, 2004, 06:53:56 am
can't tell, since I don't run Windows XP. Casper, care to take this over?

GauGau
Title: Re: XP Publisher, how to use it?
Post by: Casper on April 27, 2004, 04:17:24 pm
OK,
I have discovered that my xp_publish has reverted to only allowing uploads to the users private albums, regardless of wether the mod is applied or not ???. My uploads do appear.

I don't know the cause of this change as yet, but will look into it, with my limited understanding.

My best advice though, is wait for version 1.3, where multiple uploads are available to all users.

[ps, off topic.  can anyone tell me how to get rid of all the test entries from my xp_publisher_wizard.  I now get loads of icons for each gallery  ??? /off topic]
Title: Re: XP Publisher, how to use it?
Post by: gijs_schouten on April 27, 2004, 05:53:15 pm
Not to push anyone.. but any idea when v1.3 could become stable?

in the mean time i think i'll just have to give every user his own album.... i don't really feel like it but this is not working...

thanx for the effort!
Title: Re: XP Publisher, how to use it?
Post by: Casper on April 27, 2004, 06:58:12 pm
I find it to be very usable now, and have no problems myself.  Have a look at the test/bugs board, to see whats going on.
It is difficult to say exactly when it will be ready for full release, but imo the only things that need to be sorted are a couple of problems with bridging to a bb. 
So if you don't want that, You could do it now. 
But remember there is no support yet, so make sure you back-up so you can revert to 1.2.1 if necessary.  Also read the stckies at the top of the 1.3 board.
Title: Re: XP Publisher, how to use it?
Post by: gijs_schouten on April 27, 2004, 07:52:26 pm
Ok then... thanx for the tip casper, i'll give it a try right away!
Title: Re: XP Publisher, how to use it?
Post by: sharkey on May 20, 2004, 09:50:00 am
[ps, off topic.  can anyone tell me how to get rid of all the test entries from my xp_publisher_wizard.  I now get loads of icons for each gallery  ??? /off topic]

Is this what you're talking about?

If so you just need to delete the registry entries under this line.

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\PublishingWizard\PublishingWizard\Providers\

<off topic> I couldn't upload and then found it was a imagemagick issue! </off topic>

[attachment deleted by admin]