forum.coppermine-gallery.net

Support => cpg1.5.x Support => cpg1.5 upgrading => Topic started by: matthewcard on July 12, 2010, 03:53:12 am

Title: admin control issue
Post by: matthewcard on July 12, 2010, 03:53:12 am
I need help I also having the problem when I upgraded coppermine with the admin controls not rendering / working correctly.  Thanks for the help in advance
Title: Re: admin control issue
Post by: matthewcard on July 12, 2010, 03:56:07 am
It doesn't matter which theme I set it too -- it doesn't work in any theme and gets worse in some themes like the curve or igame
Title: Re: admin control issue
Post by: onthepike on July 12, 2010, 04:35:44 am
You are using the classic theme which is no longer supported with cpg1.5.x; please remove old themes (as well as old language files) from your web space.

Try logging in here: http://www.matthewcard.com/gallery/index.php?theme=curve

You are also required to post a link to your gallery with every support request.
Title: Re: admin control issue
Post by: matthewcard on July 12, 2010, 06:06:10 am
sorry - http://www.matthewcard.com/gallery/index.php  none of the themes seems to work when I try them .  the one you mention-- where is the admin controls  because I don't see them
Title: Re: admin control issue
Post by: onthepike on July 12, 2010, 06:14:32 am
You haven't done anything I've suggested.

http://www.matthewcard.com/gallery/lang/
http://www.matthewcard.com/gallery/themes/

Get rid of the 1.4.26 files.
Title: Re: admin control issue
Post by: matthewcard on July 12, 2010, 06:25:58 am
but I use like the igames theme  - I like that one   - if I remove all the themes I won't have any themes to use  ?
Title: Re: admin control issue
Post by: onthepike on July 12, 2010, 06:35:30 am
I suggest you set your gallery aside for a moment and take some time to read the documentation that came as part of your download package.

http://www.matthewcard.com/gallery/docs/en/upgrading.htm#upgrade_any
http://www.matthewcard.com/gallery/docs/en/upgrading.htm#upgrade_14
http://www.matthewcard.com/gallery/docs/en/upgrading.htm#upgrade_14_language_files
http://www.matthewcard.com/gallery/docs/en/upgrading.htm#upgrade_14_outdated_files
http://www.matthewcard.com/gallery/docs/en/theme.htm#theme_builtin
http://www.matthewcard.com/gallery/docs/en/theme.htm#theme_upgrading
http://www.matthewcard.com/gallery/docs/en/theme_upgrade_14x-15x.htm

Title: Re: admin control issue
Post by: onthepike on July 12, 2010, 06:44:18 am
but I use like the igames theme  - I like that one   - if I remove all the themes I won't have any themes to use  ?

I did not say (or mean) remove all of your themes (or language files). I said remove all 1.4.26 themes/files that are not compatible with cpg1.5.6. You might have a failed upgrade which means you have a combination of old and new files and folders. This is most-likely due to misusing or misunderstanding the use of your FTP app.

I suggest you use the versioncheck tool to identify which files and folders need upgrading, replacing and/or removal.

Had you followed the upgrade instructions carefully, and configured your FTP app accordingly, you wouldn't have these issues.

Title: Re: admin control issue
Post by: matthewcard on July 12, 2010, 07:26:14 am
thanks will look into tomorrow -- this is how it looks right now  after going thru the one upgrade theme list of what to edit
Title: Re: admin control issue
Post by: Joachim Müller on July 12, 2010, 07:49:47 am
That's the output generated by the cpg1.4.x theme igames. Are you playing stupid on purpose? You need to use the cpg1.5.x-theme "igames" or any other theme that comes with cpg1.5.x. As long as you don't do as suggested, we won't be able to help you. Read the instructions that onthepike refered to and do exactly as suggested there. If you don't, we will not be able to help you.