forum.coppermine-gallery.net

Support => cpg1.5.x Support => cpg1.5 language => Topic started by: Nakis on January 18, 2010, 08:59:06 am

Title: [Invalid]: Can not change language
Post by: Nakis on January 18, 2010, 08:59:06 am
I have finished translating and I started testing it installing v1.5.2 with using the new language file.
It worked fine during installation but when it finished and I tried to change the default language to Greek, I got an error indicating that I cannot change the default language.
Also, I cannot find the options to have the language selector enabled in order to choose another language.

How am I supposed to test the translation if I cannot change the language?
Is there a workaround for this or am I missing something here?

Also, I would like some clarifications please:

Line 306
Code: [Select]
$lang_rate_pic['rollover_to_rate'] = 'Rollover to rate this picture'; // cpg1.5
What exactly does the user rolls over (image, text link)?


Line 500
Code: [Select]
$lang_bridgemgr_php['[b]relative[/b]_path_of_forum_from_webroot'] = '[b]Absolute[/b] bridging app path';Is this relative or absolute?


Lines 825, 826
Code: [Select]
$lang_admin_php['default_file_mode'] = 'Default mode for files'; // cpg1.5What kind of mode?


Line 839
Code: [Select]
$lang_admin_php['global_registration_pw'] = 'Global password for registration'; // cpg1.5What does this mean? Is there any documentation about it so that I can understand what exactly is does?


Thanks,
Nakis
Title: Re: Can not change language
Post by: Nakis on January 24, 2010, 01:13:05 pm
...anyone?
Title: Re: Can not change language
Post by: Nibbler on January 24, 2010, 01:27:29 pm
I got an error indicating that I cannot change the default language.

Post the exact error message.

Also, I cannot find the options to have the language selector enabled in order to choose another language.

http://documentation.coppermine-gallery.net/en/theme_template.htm#theme_template_language_select_list

Line 306
Code: [Select]
$lang_rate_pic['rollover_to_rate'] = 'Rollover to rate this picture'; // cpg1.5
What exactly does the user rolls over (image, text link)?

Images (of stars).

Line 500
Code: [Select]
$lang_bridgemgr_php['[b]relative[/b]_path_of_forum_from_webroot'] = '[b]Absolute[/b] bridging app path';Is this relative or absolute?

Relative.

Lines 825, 826
Code: [Select]
$lang_admin_php['default_file_mode'] = 'Default mode for files'; // cpg1.5What kind of mode?

Unix file permissions - http://en.wikipedia.org/wiki/File_system_permissions#Octal_notation
Title: Re: Can not change language
Post by: Joachim Müller on January 24, 2010, 09:44:50 pm
Code: [Select]
$lang_admin_php['default_file_mode'] = 'Default mode for files'; // cpg1.5What kind of mode?
There is a reason why we provide a documentation that has been very much improved (compared to the docs for cpg1.4.x): Documentation for cpg1.5.x → Administration → Configuration → Picture and thumbnail settings → Default mode for files (http://documentation.coppermine-gallery.net/en/configuration.htm#admin_picture_thumb_advanced_chmod_files)

Code: [Select]
$lang_admin_php['global_registration_pw'] = 'Global password for registration'; // cpg1.5What does this mean? Is there any documentation about it so that I can understand what exactly is does?
Documentation for cpg1.5.x → Administration → Configuration → Registration → Set global password for registration (http://documentation.coppermine-gallery.net/en/configuration.htm#admin_global_registration_pw)

There is no support for cpg1.5.x yet. We have a strict "one issue per thread". I understand that you want to figure out details to be able to translate, but please take a look at the docs first.
Title: Re: Can not change language
Post by: Nakis on January 25, 2010, 11:23:44 pm
Thank you both for your answers.

I will stick to the language issue here...

The error I got (more like a warning as I see it now) is this:

Quote
Setting the default language doesn't work as expected yet. This file is still work in progress.
Joachim

After a more careful look, it happens only when I change the language to English (both US and UK).
(I am not sure if this was the case since the beginning. I will make a fresh, online, installation and I will let you know.)

Normally I wouldn't pay attention to this, but the language file that I created really doesn't work, at all.
I have installed it properly, I get it in the list of available languages, I enabled it, I am able to select it and set it as default, but it just doesn't work.
I click on every link in the admin menu but everything is in English. I don't know if I'm missing something here...
(Note that it worked fine during the installation and that I haven't added any content)

As for the language selection option that I mentioned in my first post, previously it was located among the Language & Charset settings. Now it's not there and I looked to find it but I was able to do so.
Has it been relocated or id I get blind? :)


Thanks again,
Nakis
Title: Re: Can not change language
Post by: Phill Luckhurst on January 25, 2010, 11:48:26 pm
Clear your cookies - http://documentation.coppermine-gallery.net/en/languages.htm#how
Title: Re: Can not change language
Post by: Nakis on January 28, 2010, 03:45:44 pm
Clearing the cookies did the trick.
Thank you all for your replies.
GauGau thanks for your replies, you must be a very patient man ;)

I have already started checking the translation and I hope that I will soon come up with the final version...
Title: Re: [Invalid]: Can not change language
Post by: Joachim Müller on January 28, 2010, 05:08:50 pm
This thread was originally posted on the cpg1.5.x testing/bugs board (http://forum.coppermine-gallery.net/index.php/board,85.0.html). As it turned out not to be a bug, but an issue on the side of the end user I'm moving it to the support board. Please note that there is still no support so far - this thread was only moved there for the benefit of users with similar issues. Marking accordingly and locking.