forum.coppermine-gallery.net

Support => cpg1.4.x Support => Older/other versions => cpg1.4 modpack by Stramm => Topic started by: rozitcha on July 07, 2009, 03:25:34 am

Title: Modpack 1.4.24 isn't working
Post by: rozitcha on July 07, 2009, 03:25:34 am
I've installed 1.4.25 version of Coppermine and 1.4.24 version of Stramm's Modpack, but it's totally messed up. I would like to know if the two work together and if it takes a while for it to be solved.

BTW, I've started another thread with the same name, but they marked it as "solved" and it's not solved, I simply downgraded both Coppermine and Stramm's.

My site is http://katewinsletphotos.com (http://katewinsletphotos.com) (you have to be registered to view the pics), but it's currently with version 1.4.21 of Coppermine.
Title: Re: Modpack 1.4.24 isn't working
Post by: Stramm on July 07, 2009, 01:55:59 pm
Should work... there's just a little bug fix in the 1.4.25 release
Title: Re: Modpack 1.4.24 isn't working
Post by: rozitcha on July 07, 2009, 04:39:49 pm
Should work... there's just a little bug fix in the 1.4.25 release

Should I or should I not upgrade to 1.4.25, then?
Title: Re: Modpack 1.4.24 isn't working
Post by: Stramm on July 07, 2009, 05:45:18 pm
1.4.24 is the latest security fix and it's mandatory to upgrade.
Title: Re: Modpack 1.4.24 isn't working
Post by: rozitcha on July 07, 2009, 06:02:52 pm
1.4.24 is the latest security fix and it's mandatory to upgrade.

Alright. Thank you! How long does it take for all the thumbs to be fixed with the modpack?
Title: Re: Modpack 1.4.24 isn't working
Post by: Stramm on July 07, 2009, 06:30:49 pm
Recreating thumbs you mean? That's a question of server power.
Title: Re: Modpack 1.4.24 isn't working
Post by: marcies on July 07, 2009, 06:54:18 pm
I've installed 1.4.25 version of Coppermine and 1.4.24 version of Stramm's Modpack, but it's totally messed up. I would like to know if the two work together and if it takes a while for it to be solved.

BTW, I've started another thread with the same name, but they marked it as "solved" and it's not solved, I simply downgraded both Coppermine and Stramm's.

My site is http://katewinsletphotos.com (http://katewinsletphotos.com) (you have to be registered to view the pics), but it's currently with version 1.4.21 of Coppermine.

Did you check your thumbnails settings? I noticed that it reverted to the regular coppermine settings when I did this so i had to reset the settings for the Stramm modpack to work.
Also you can do that 1.4.25 fix manually. So everything will be upgraded to 1.4.25.

Manual patch:
For those who want to apply the fix manually to their Coppermine 1.4.24 installation, edit include/init.inc.php with a plain text editor (notepad.exe is fine), find:
Code:

$keysToSkip = array('_POST', '_GET', '_COOKIE', '_REQUEST', '_SERVER', 'HTML_SUBST', 'keysToSkip', 'register_globals_flag', 'cpgdebugger', 'key');

and replace with:
Code:

$keysToSkip = array('_POST', '_GET', '_COOKIE', '_REQUEST', '_SERVER', '_FILES', 'HTML_SUBST', 'keysToSkip', 'register_globals_flag', 'cpgdebugger', 'key');

Title: Re: Modpack 1.4.24 isn't working
Post by: rozitcha on July 07, 2009, 07:19:51 pm
Did you check your thumbnails settings? I noticed that it reverted to the regular coppermine settings when I did this so i had to reset the settings for the Stramm modpack to work.
Also you can do that 1.4.25 fix manually. So everything will be upgraded to 1.4.25.

Manual patch:
For those who want to apply the fix manually to their Coppermine 1.4.24 installation, edit include/init.inc.php with a plain text editor (notepad.exe is fine), find:
Code:

$keysToSkip = array('_POST', '_GET', '_COOKIE', '_REQUEST', '_SERVER', 'HTML_SUBST', 'keysToSkip', 'register_globals_flag', 'cpgdebugger', 'key');

and replace with:
Code:

$keysToSkip = array('_POST', '_GET', '_COOKIE', '_REQUEST', '_SERVER', '_FILES', 'HTML_SUBST', 'keysToSkip', 'register_globals_flag', 'cpgdebugger', 'key');

Thank you so much for your help! I just need to know whether the Stramm's 1.4.24 works together with Copp's 1.4.25 or not.
Title: Re: Modpack 1.4.24 isn't working
Post by: marcies on July 07, 2009, 09:00:49 pm
Yes they should work. I did this for dan-radcliffe.net
Title: Re: Modpack 1.4.24 isn't working
Post by: rozitcha on July 07, 2009, 10:09:56 pm
Yes they should work. I did this for dan-radcliffe.net

Thank you once again for all your help!