Support => cpg1.4.x Support => Older/other versions => cpg1.4 miscellaneous => Topic started by: holmes on July 14, 2006, 06:47:32 am

Title: can't make one language became default
Post by: holmes on July 14, 2006, 06:47:32 am
I have read some topic about this broblem, it said because cookie, but I browse my gallery with other computer it still doesn't show my language that I choose. (vietnamese)
I have uncheck the box "return English if..."

Title: Re: can't make one language became default
Post by: Joachim Müller on July 14, 2006, 07:40:00 am
There's no vietnamese language file for cpg1.4.x available anyway.
Here's how coppermine determines the language of a user: when accessed, coppermine checks if a user explicitely has set a language preference (which is stored in a cookie on the client). If one is set, coppermine is being displayed in that particular language.
If no individual language preference has been set, coppermine detects the language preference of a user set up in his browser. If the browser language is (for example) english, then coppermine will display in english.
If the browser language is set to hindi (as an example), while there is no coppermine language file available for that particular language, then coppermine will fall back to the default language you have set up in coppermine's config.
As you can see, the determination of the actual language setting is a three step process:
1) user preference (cookie)
2) browser setting
3) coppermine config setting

To fix this issue, you should post
1) a link to your page
2) what browser language you use
3) what language files you have (inside your "lang" folder)

As suggested above: there's no vietnamese language file for cpg1.4.x, so it's mandatory to use the fallback option in coppermine's config if you want to use the outdated vietnamese cpg1.3.x language file. Keep in mind that this will only work for your site's visitors, but not for you as gallery admin (the gallery can't be administered using an outdated language file).