Support => cpg1.3.x Support => Older/other versions => cpg1.3 Miscellaneous => Topic started by: zeezee on February 19, 2006, 09:51:24 am

Title: Intermediate pictures not resizing
Post by: zeezee on February 19, 2006, 09:51:24 am
ver: 1.3.3

My intermediate pictures are all "max dimension" 400px. I would like to update all of them to be 600px. I changed the setting on the config file from 400->600 and used the admin tools utility, checking "resize pictures only". The utility runs through the album and tells me everything was succesfull. However, when I view the intermediate pictures now, they are still 400px max.

Any thoughts would be greatly appreciated.
Title: Re: Intermediate pictures not resizing
Post by: Joachim Müller on February 19, 2006, 12:45:59 pm
1) Upgrade at least to cpg1.3.5
2) Post a link to your page
Title: Re: Intermediate pictures not resizing
Post by: zeezee on February 19, 2006, 01:22:18 pm
1) completed the update to 1.3.5 and still having the same problems


Now I dont know if it makes a difference or not, but Ill mention it just in case. All the original intermediates were made with GD2 when I batch uploaded the pics, but when I wanted to resize them GD2 kept giving me error messages, memory allocation crap. Searched the forums, most people suggested editing the php.ini to allow more than 8MB, so I did that, upped it to 32MB. That didnt solve the problem so my next step was to install ImageMagick and thats what Im using now, and as I said, cpg outputs succesfull for every pic, just nothing changes. Thanks a bunch
Title: Re: Intermediate pictures not resizing
Post by: zeezee on February 22, 2006, 04:01:42 pm
Maybe I'll add some more detail to my troubles. CPG returns this message
Warning: chmod(): Operation not permitted in /home/httpd/vhosts/ on line 243
albums/thailand/normal_DSC00205.JPGupdated succesfully!
Now this struck me as strange since I'd thought everything (folder and files) had permission 777. So before I posted my last message I check and noticed that apache had grabbed ownership of the intermediates and thumbs created by coppermine. So I went and CHOWNed the albums and then went though and CHMODed the pics I wanted to resize to 777. I received the same error, so then I tried 755 (just to be sure) but no difference. This is when I posted the last message.
Since then I have read through as much relevant material as possible, I am confused since when I use GD I receive the a chmod error but the new larger intermediates are written over the old ones, but with imagemagick they dont overwrite even though I get the exact same message. I tried working with GD some more and found that only some of the larger pictures gave the allowed_memory error (obviously) but it stil surprised me since I upped the value in the php.ini to 32MB and the files that are failing are 3072 by 2304, so according to what I'd read in another thread the memory calculation is like this (3072*2304*3)/1048576=20.25MB Now thats a ways under 32MB however I dont know how much else CPG is using up. The pictures that GD will resize now (after fixing the ownership issue) are 2048 by 1536, so (2048*1536*3)/1048576=9MB, considerably less. So I suppose if I jack up the allowed memory then the larger pics will probably pass through, but I've not read of anyone raising their limit past 32MB so is it just because they dont have pictures this big? I'm also still baffled by my original question, why IM says creation succesful with chmod error and no memory errors even for the largest pics, but wont overwrite.