forum.coppermine-gallery.net

Support => cpg1.4 bridging => cpg1.4.x Support => Older/other versions => cpg1.4 bridge contributions => Topic started by: Pit on December 06, 2005, 01:23:09 am

Title: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Pit on December 06, 2005, 01:23:09 am
I don't know whether anybody is interested in bridging CPG 1.4.x to IPB1.3.1. But if so you can take a look at an existing installation:

My testsite (http://www.rwb-essen.de/cgi-bin/cpg/index.php?lang=english)

Here you will find not only a bridged CPG 1.4.2 but also a skin integrated CPG. Choose a skin from the skin dropdown list in the upper right corner and see CPG changing its outfit.

This integration is the result of my mod "Coppermine Goes Invisionboard 1.3.1" which is available at http://www.invisionize.com (http://www.invisionize.com) (only IPB1.3 and actually for CPG1.3).

Of course you will not see a genuine cpg theme. To optimize skin integration you should create a new IPB skin or a new CPG theme.

My work could be separated in two parts:

1. A bridge file for Invisionboard 1.3
2. An IPB modification to integrate CPG into IPB (like a module).

Furthermore I have tried to integrate CPG with MKPortal Singleboard. The actual state can be tested here (http://www.ibforen.de/index.php?ind=coppermine) (Work in progress)

For integration purpose I have had to change two language files to iso-8951 charset (German and French).

The German users will find my project at http://www.ibforen.de (http://www.ibforen.de)


Edit (2006-03-29)

The bridge file is attached to this post.

You will find 2 files in this archive.

./bridge/invisionboard13.inc.php is the bridge file
./bridgemgr.php is the original bridge manager with an additional section for the new bridge in order to make it chooseable.

Please do not ask for support via email or PM. Use this topic.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.2
Post by: Pit on January 05, 2006, 10:37:36 pm
I don't like to bump this topic but I cannot believe that nobody is using ipb1.3 or nobody wants to update his cpg with ipb1.3.

By the way: at my testsite you can see cpg 1.4.3 running with ipb1.3
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Eddy Newell on January 06, 2006, 05:55:37 pm
I am interested. I use both ipb 1.3 final and coppermine 1.4.3.

I've visited your site (very cool), but I don't see the bridge file that works with cpg 1.4.3.

The latest coppermine version only supports ipb 2.x. where can I get the bridge?
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Pit on January 07, 2006, 12:51:19 pm
@Eddy:

You can send me your email address via PM and I will return the bridge file.

By the way: I have offered the bridge file to the dev team but I have not get any response.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Joachim Müller on January 08, 2006, 03:06:28 pm
By the way: I have offered the bridge file to the dev team but I have not get any response.
???
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Joachim Müller on January 09, 2006, 07:57:40 am
@Pit: sorry for replying late to the PM you sent me a long time ago - I lost focus. If you agree, I will paste your PM into my posting and give a rough translation.

Here's a short summary: Pit introduced himself as active developer on IPB-related sites. He told me about an integration of coppermine with IPB using two methods:
a) an IPB1.3 bridge file for cpg1.4.x
b) a visual integration (port/mod) of coppermine into the template/theming scheme of IPB

Let me clarify some things: we're very fond of bridge file contributions and would love to see your IPB1.3 bridge file. Bridging is the recommended method to link/integrate coppermine with other apps. We're not particularly fond of ports/mods that try to accomplish visual integration of coppermine into a third party app, as this requires coppermine core code to be edited. This was the case for the port/mod "coppermine goes invisionize" (cpg1.3.x integrated with IPB1.x afaik). There were errors/flaws/questions that were asked by users who used this mod on the coppermine support board; after a lot of discussion and support work by the coppermine dev team it turned out that most issues users experienced with "coppermine goes invisionize" were related to IPB issues or stuff related to the coppermine code changes applied due to the mod. The coppermine dev team policy therefor is: we provide support for bridges that come with coppermine (and we'd love to see your new bridge file go into coppermine's code if applicable license-wise), but we don't support any kind of third-party mods nor ports. This doesn't mean that we don't encourage other projects to use coppermine as a codebase and develop it further to work with another app - we just demand that they support the port themselves or clearly tell their users that there's no support at all when using the port.

Summary: please contribute your newly created bridge file if possible, and post what license comes with it (we can only add it to a future coppermine package/release if it doesn't contain IPB code, as IPB is a commercial app, while coppermine is being released under GNU GPL). If the license your bridge file comes with doesn't allow us to add it to coppermine's core, you're still welcome to post it as an add-on. You're welcome as well to start a thread about the mod/port that deals with the visual integration and requires coppermine code changes.

Joachim
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Pit on January 09, 2006, 09:04:32 pm
Joachim, thank you for this reply.

Those things you thought to be clarified are not a problem. I have customized two files using my experiences with IPB1.3:

bridgemgr.php and bridge/invisionboard20.inc.php.

In the bridgemgr.php I have only added a section for enabling selection of the new bridge for IPB1.3 in order to let the manager create the bridging.

The other file was a good template for the new bridge file invisionboard.inc.php (or better: invisionboard13.inc.php).

In a local environment and on some external boards I have tested most of the cpg functions but it should be tested by more experienced persons. Therefore I do not want to release it here in its current state.

If it is approved to be stable then I would like to see it as a part of the distribution package (free under the same conditions as the entire package).

Concerning the visual integration I have the same point of view like you.

For the German users I can offer support at http://www.ibforen.de (http://www.ibforen.de) and for English speaking people I am supporting my mods at http://www.invisionize.com (http://www.invisionize.com).

When members of coppermine-gallery.net are using my mod, you should be aware of the difficulties to distinguish between problems caused by cpg and problems caused by ipb. Therefore I recommend to handle those topics with patience. I will visit this site from time to time and look through the topics concerning that mod.

But I expect that mod users will visit the appropriate support sites to get help for solving problems.

What about the bridge file? Can someone of the dev team test the bridge?

Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Joachim Müller on January 10, 2006, 08:29:05 am
could you zip it and attach it to your reply here please?
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Pit on January 10, 2006, 11:09:56 am
Is is not tested and I do not like to make it public.

Please give me an email address via PM where I can send the files.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Joachim Müller on January 10, 2006, 03:56:58 pm
take your time, test it thoroughly. If you think that it is mature enough to be released, attach it to this thread. There's little point in sending me a beta file, since I won't be able to test it anyway.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: all4one on February 28, 2006, 03:21:08 am
I'm interested in this
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: all4one on March 03, 2006, 09:33:19 am
Are we still working on this bridge?

I like the the version 1.3 where it has the bridge for IPB 1.3. I guess I have to purchase IPB 2
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Pit on March 08, 2006, 02:46:36 pm
Sorry for the late answer, but since only few people seem to be interested in this topic, I do not look very often here.

4 Users have asked me for testing the bridge but they do not give feedback. What a bad attitude.

So, if you want to test the bridge and if you give me feedback you can send me your email address.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: hondaclub on March 08, 2006, 04:31:55 pm
I just upgrated to 1.4 and im using IPB1.3 can you please tell me how i can do the bridging ?Im intrested in this as well
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Joachim Müller on March 08, 2006, 07:12:52 pm
then read the posting just above yours!
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: all4one on March 09, 2006, 05:48:21 pm
Hey Pit, You sent me the bridging files for Coppermine 1.4.4 and IPB1.3 but they don't seem to work.

I tried and it took me to the "Emergency Recovery" screen which requires me to login and disable bridge.

Sorry for the late answer, but since only few people seem to be interested in this topic, I do not look very often here.

4 Users have asked me for testing the bridge but they do not give feedback. What a bad attitude.

So, if you want to test the bridge and if you give me feedback you can send me your email address.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Pit on March 09, 2006, 07:05:41 pm
Hmmm, I have just downloaded cpg 1.44. Copied to the webserver, copied the new bridgefiles to their places and installed cpg.

Then I have called the bridge manager, selected the bridge IPB1.3, setup the bridge, activated the bridge.

Everything without problems. I was logged in, because I was logged in iin my IPB. I log out from IPB, I am logged out from cpg. I log in again in ipb, i am logged in in cpg.

What else can I do for you?

You should not call the bridge manager again, because then cpg is thinking that you have difficulties and in consequence it deactivates the bridge. This is called the "emergency recovery".
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: all4one on March 10, 2006, 01:00:25 am
Then we need more testers because the only different is I upgraded to CPG 1.4.4 from CPG1.3

Downloaded your bridge and upload to the server

The only problem was when I logged in IPB, I'm not login to CPG. When clicked login from CPG it took me to IPB login screen.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: all4one on March 10, 2006, 05:24:53 pm
Do IPB and CPG need to be in the same database?
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Pit on March 10, 2006, 08:19:40 pm
No, IPB and CPG can be in different databases (this is the case in my environment).

But you have to call the bridge manager after upgrading CPG. Only copying the bridge file is not sufficient.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: hondaclub on March 11, 2006, 01:57:51 pm
I would like to test it so if i can be of any help i would be very happy my email is fotis@hondaclub.gr
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Pit on March 11, 2006, 02:17:42 pm
I have already sent the files on March 9th.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Joachim Müller on March 12, 2006, 10:47:29 am
I can't see the point in emailing this file around instead of just attaching it to this thread, with all the caveats, whistles and bells in place.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Pit on March 12, 2006, 02:32:19 pm
The point is that I do not want to publish a bridge before having tested its functionality. Until now I have not received any positive feedback.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: all4one on March 13, 2006, 01:18:30 am
I think you should let everybody download and test it. What is the different between send the file privately and let other people test and share it publicly where people can download and test it? Are you afraid that someone will claim you bridge as theirs?
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: flux on March 29, 2006, 03:55:46 pm
hi Pit,

i'd be interested in testing your cpg bridge for ibp 1.3.1 Final, you should have my email in your pm
thx

.Flux
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Pit on March 29, 2006, 10:27:55 pm
I have received a couple of positive feedback, so I have attached the bridge file to the first post of this topic.

You will find 2 files in this archive.

./bridge/invisionboard13.inc.php is the bridge file
./bridgemgr.php is the original bridge manager with an additional section for the new bridge in order to make it chooseable.


Please do not ask for support via email or PM. Use this topic.

 
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Ivx on March 30, 2006, 06:35:44 pm
Great Job, Pit!! Thank You
The bridge seems to work correctly (invisionboard 1.3 Final and coppermine 1.4.4)
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: flux on April 01, 2006, 07:36:57 pm
Hi,

thx pit for the files, i've made a fresh cpg144 and ibp 1.3.1 installs and your bridge works fine.

Two things though :

- first i was wondering why the "cookies prefix" data has been hidden in the bridge manager and is unused in that bridge script, i've checked and it's also unused in the ibp 2.0 bridge..
My initial stetup wasn't working at first coz my board was configured with a cookies prefix so multiple boards could run on the same (sub)domain..

- second, i was wondering if there's a way to get inside cpg admin when the bridge is running ? in order to create/manage albums and so on..

i have other questions regarding user groups but i'll do some tests first, hopefully i canc ome up with answers myself..

thx again it's good to have a nice gallery system for the very nice invision power board ;)

.flux
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: hondaclub on April 17, 2006, 09:56:32 pm
I tried to upgrade but it doesnt seem to work, I put both files in folder gallery/bridge but when i enable the bridgmgr.php and start the bridging wizard i get the following message ( Bridge Manager: emergency recovery) (If you came here to administer the BBS integration of your Coppermine gallery, you have to log in first as admin. If you can not log in because bridging doesn't work as expected, you can disable BBS integration with this page. Entering your username and password will not log you in, it will only disable BBS integration. Refer to the documentation for details. ) And when i try to open my gallery i get a blank page with the following message (Fatal error : )
I can then access my forum only if i go back as administrator and disable the bridging which gives me the following message (You have successfully disabled BBS bridging. Your Coppermine install runs now in standalone mode.
Log in as admin to edit your bridge settings and/or enable BBS integration again. )

 :-\
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Fireball-HH on May 07, 2006, 08:53:21 am
No Problems at all thumbs up :)

install and bridging worked fine keep up the great work pit :)

greetz

Fire
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: shania on May 11, 2006, 06:46:02 am
Hello

Sorry for hijacking this thread I dont see how  I can start my own topic and since this one relates to my Question I will start here.

Is a mod/bridge available to use coppermine with IPB 2.1.5 ? I can't find one anywhere
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Joachim Müller on May 13, 2006, 11:12:14 am
butt out of this thread - it deals with ipb1.3.1 only. Read the stickies and board descriptions, they should give you an idea where you can start threads and where you can't.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: stormtrooper on May 18, 2006, 10:37:06 pm
this does not work for me.

I have IPB 1.3 and CPG 1.4.5.

My Error comes after confirming the bridge settings:

Code: [Select]
Kritischer Fehler
Beim Ausführen einer Datenbank-Abfrage

Critical Error
Can't connect to Database.

Bridge is built, when I do not take over the groups.
Still, I cannot log in with the CPG admin account. It says, that I do not have sufficient privileges.

@Pit
As I read before, it is working for IPB 1.3.1 and CPG 1.4.4.



Coppermine install: http://www.unihockey-deitingen.ch/gallery/coppermine/
Forum install: http://www.unihockey-deitingen.ch/guests/ipb13
Coppermine version: cpg1.4.5
Forum version: Invision Power Board 1.3 (Final)
Test user account: -

BridgeManager settings:
Forum URL:  http://www.unihockey-deitingen.ch/guests/ipb13
Relative path to your BBS's config file:  ../../guests/ipb13/
Use post-based groups?:  1
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Alk on May 19, 2006, 02:29:39 pm
My install worked sort of.
It has bridged fine it seems as I can login and logout fine without problems using my forum login details and it keeps my sessions correctly. ;D
However, on the last step of the bridge manager enabling I got this error:
Quote
Fatal error: Cannot redeclare class core_udb:cpg_udb in /home/letras00/public_html/gallery/bridge/invisionboard13.inc.php on line 29
Well, it has still bridged ok, but when I go back to the bridge manager I cannot open it because of that error. :-\
Thank you
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Joachim Müller on May 19, 2006, 05:02:31 pm
http://forum.coppermine-gallery.net/index.php?topic=24032.0
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Alk on May 19, 2006, 05:20:36 pm
http://forum.coppermine-gallery.net/index.php?topic=24032.0
Sorry.

I have the following issue when trying to bridge coppermine and IPB v1.3 Final:
Quote
Fatal error: Cannot redeclare class core_udb:cpg_udb in /home/letras00/public_html/gallery/bridge/invisionboard13.inc.php on line 29

Coppermine install: http://www.letrasescondidas.net/gallery
Forum install: http://www.letrasescondidas.net/forum
Coppermine version: cpg1.4.2
Forum version: IPB v1.3 Final
Test user account: tester / testing

BridgeManager settings:
Forum URL:  http://www.letrasescondidas.net/forum
Relative path to your BBS's config file:  ../forum/ 
Use post-based groups?:  Yes

I think that is everything correctly. Thanks.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Nibbler on May 19, 2006, 05:23:40 pm
Change cpg_udb to something unique in the bridge file eg. ipb_udb
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Alk on May 19, 2006, 07:04:17 pm
I changed this bit:
Quote
                // sync groups here now :)
                if ($CONFIG['bridge_enable']){
                  include_once 'bridge/' . $BRIDGE['short_name'] . '.inc.php';
                        $cpg_udb->synchronize_groups();
                } else {
To this:
Quote
                // sync groups here now :)
                if ($CONFIG['bridge_enable']){
                  include_once 'bridge/' . $BRIDGE['short_name'] . '.inc.php';
                        $ipb_udb->synchronize_groups();
                } else {
It now goes to the "Bridge Manager: emergency recovery" when I click on the bridge manager. Is that correct now?
Thanks for your help!
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: stormtrooper on May 19, 2006, 11:07:59 pm
this does not work for me.

I have IPB 1.3 and CPG 1.4.5.

My Error comes after confirming the bridge settings:

Code: [Select]
Kritischer Fehler
Beim Ausführen einer Datenbank-Abfrage

Critical Error
Can't connect to Database.

Bridge is built, when I do not take over the groups.
Still, I cannot log in with the CPG admin account. It says, that I do not have sufficient privileges.

@Pit
As I read before, it is working for IPB 1.3.1 and CPG 1.4.4.



Coppermine install: http://www.unihockey-deitingen.ch/gallery/coppermine/
Forum install: http://www.unihockey-deitingen.ch/guests/ipb13
Coppermine version: cpg1.4.5
Forum version: Invision Power Board 1.3 (Final)
Test user account: -

BridgeManager settings:
Forum URL:  http://www.unihockey-deitingen.ch/guests/ipb13
Relative path to your BBS's config file:  ../../guests/ipb13/
Use post-based groups?:  1

anyone an idea to my problen?
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: stormtrooper on May 19, 2006, 11:14:26 pm
IS THIS INVISIONBOARD 1.3 BRIDGE ALSO COMPATIBLE TO CPG 1.4.5 OR 1.4.6??

Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Pit on May 20, 2006, 11:42:53 am
It is compatible with 1.4.5. 1.4.6 should work too.

@stormtrooper:
Before bridging be sure to have installed cpg properly. Is it working as a standalone application?
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: stormtrooper on May 20, 2006, 04:52:35 pm
cpg is working smoothly without bridge.
I still get the error-message.

I tried with cpg 1.3.5, 1.4.4, 1.4.5 and 1.4.6

when I enable the debug mode, I receive the following message:

Code: [Select]
While executing query "SELECT * FROM `usr_web2364_1 `.ipb12_groups WHERE g_title <> ''" on 0

mySQL error: Access denied for user: 'web2364@localhost' to database 'usr_web2364_1 '


Hmm, something with my database... but
I controlled the access data to the mysql-database several times.
everything is working and I get access via phpmyadmin with the same data I used for CPG.

NB: ipb12 is just the prefix. I am using IPB 1.3 final.

Any ideas?
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: stormtrooper on May 21, 2006, 01:56:39 am
ok, the bridge works so far. there was a space in the mysql data --> 'usr_web2364_1 '

but...

1. user of invisionboard 1.3 are not synchronized with cpg 1.4.6
--> this should be made while enabling the bridge, right?

2. after bridging, I'm logged in as admin. after clicking again on admin tools, cpg says that I don't have the rights to access this page. now I'm also not anymore logged in as admin. it is like guest status.
--> cookie problem? what are the correct settings?

thanks for your answers.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: stormtrooper on May 21, 2006, 02:00:41 am
oh sorry, my updated data:

Coppermine install: http://www.unihockey-deitingen.ch/gallery/coppermine/
Forum install: http://www.unihockey-deitingen.ch/guests/ipb13
Coppermine version: cpg1.4.6
Forum version: Invision Power Board 1.3 (Final)
Test user account: user: cpg146 / pass: cpg146

BridgeManager settings:
Forum URL:  http://www.unihockey-deitingen.ch/guests/ipb13
Relative path to your BBS's config file:  ../../guests/ipb13/
Use post-based groups?:  1
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: stormtrooper on May 22, 2006, 01:59:04 am
solved.
it was a cookie problem.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: hondaclub on May 24, 2006, 12:21:32 pm
I have the following issue when trying to bridge coppermine CPG 1.4.3 and IPB v1.3 Final :

I tried to upgrade but it doesnt seem to work, I put both files in folder gallery/bridge but when i enable the bridgmgr.php and start the bridging wizard i get the following message ( Bridge Manager: emergency recovery) (If you came here to administer the BBS integration of your Coppermine gallery, you have to log in first as admin. If you can not log in because bridging doesn't work as expected, you can disable BBS integration with this page. Entering your username and password will not log you in, it will only disable BBS integration. Refer to the documentation for details. ) And when i try to open my gallery i get a blank page with the following message (Fatal error : )
I can then access my forum only if i go back as administrator and disable the bridging which gives me the following message (You have successfully disabled BBS bridging. Your Coppermine install runs now in standalone mode.
Log in as admin to edit your bridge settings and/or enable BBS integration again. )

Coppermine install: http://www.hondaclub.gr/gallery/
Forum install: http://www.hondaclub.gr/forum/
Coppermine version: CPG 1.4.3
Forum version: Invision Power Board v1.3 Final
Forum Test user account: test / test
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Pit on May 24, 2006, 05:47:45 pm
You must read the instructions very carefully and again and again!!

Do not copy both files into the bridge dir !!! The bridgemgr.php must be copied into the root dir of cpg.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: hondaclub on May 25, 2006, 10:13:55 am
Your my king  this ----> (Do not copy both files into the bridge dir !!! The bridgemgr.php must be copied into the root dir of cpg.) was the only thing i was doing wrong everything works sweet now.
Thank You Pit  ;)
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: vglick on June 06, 2006, 01:12:28 pm
I have installed IPB 1.3.1 and CPG 1.4.4 in different DB.
Can I integrat CPG into IPB and use 2 diferent DBs?
Or I must one same DB?
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: vglick on June 06, 2006, 02:09:52 pm
Thank you!
It's working fine!
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: vglick on June 11, 2006, 10:24:44 am
After intagrate gallery with forum the link for "Upload file" is missing.
Any idea for a solution?
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: vglick on June 11, 2006, 12:55:44 pm
Sorry for my mistake, it's working fine.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Retrolock on June 26, 2006, 06:31:06 am
sorry if i come out dumb here. but does this work with IPB 2.1.x?   :-\
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Billy885 on July 02, 2006, 08:30:54 pm
Pit, thanks a bunch for the bridge, it works great on 1.4.8 also.  As advertized.  ;D
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Alk on July 19, 2006, 03:05:44 pm
There is a problem with the mod.
When you click the "memberlist" link in the gallery, it takes you to the IPB administrator CP instead of the IPB forum Memberlist. ???
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Nibbler on July 19, 2006, 03:07:46 pm
Links are defined in the bridge file, adjust them however you see fit.

Code: [Select]
// Pages to redirect to
$this->page = array(
    'register' => '/index.php?act=Reg&CODE=00',
    'editusers' => '/admin.php',
    'edituserprofile' => '/index.php?showuser='
);
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Alk on July 19, 2006, 03:53:29 pm
Yes, I tried that and put this:
Quote
      $this->page = array(
         'register' => '/index.php?act=Reg&CODE=00',
         'editusers' => '/admin.php',
         'edituserprofile' => '/index.php?showuser=',
                  'viewusers' => '/index.php?showuser='

      );
I don't know if I have that right, but it still redirects to he Admin CP. :(
Thanks for your help.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Nibbler on July 19, 2006, 04:01:22 pm
I said adjust them, not add made up stuff. If it takes you to admin.php instead of xxx.php then change admin.php to xxx.php
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Wolfegar on December 09, 2006, 08:30:42 pm
Pit, I have downloaded your bridge file for IPB 1.3 and then the bridgemgr.php file and placed them in the appropriate places before uploading the upgrade files for Coppermine.  The upgrade and the re-bridging worked fine.  Thank you to both the Coppermine Team and to you.   ;)
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: vglick on December 25, 2006, 01:11:36 pm
Hi, Pit
After integration all working fine, but I have couple problems with Cyrillic.
My forum and gallery runs with UTF-8 coding.
Of course database run with UTF-8 coding too.
But I have couple problems with Cyrillic, I see "question marks"( ?? ).
Please see the links http://www.diving-club.com/gallery/index.php?cat=1 and http://www.diving-club.com/gallery/groupmgr.php
Gallery integration into forum, therefore database "gallery" geting data from database "forum"
I think that have problem in files bridgemgr.php or invisionboard13.inc.php.
Please, help me.
And sorry for my English.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: vglick on December 25, 2006, 01:59:08 pm
This problem is resolved.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: gamemaster on December 27, 2006, 04:48:49 am
Pit, I have used most 1.3 mods in my 1.2 IPB, will this work too? I have tried it but it does not recognize users.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Grimlok on March 24, 2007, 09:41:27 am
Apologies for the topic bump, but I seem to be having problems installing this on my board (http://ravenrepublic.cjb.net/forums/index.php).

So I FTP the files to their proper places. I install Coppermine under the same database where my board is installed to lessen complications. I set the IPB 1.3 bridge. Then I install the actual mod with my board using Pit's ModInstaller. So far, so good.

The instructions after that is where it gets a bit unclear, especially when configuring the board wrappers. As a result, when you look at my gallery, (http://ravenrepublic.cjb.net/gallery/index.php), all you get is a blank page.

Can anyone help? It would be very much appreciated.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Kaworu on September 14, 2007, 05:26:40 am
Can we integrate CPG with IPB ver 2.3.x?
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Joachim Müller on September 14, 2007, 09:14:30 am
Don't clutter the board with double-postings (http://forum.coppermine-gallery.net/index.php?topic=46405.msg223469#msg223469). You already got an answer.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: vintyara on September 23, 2007, 03:05:41 pm
Hi ! After integration i have a problem with administration. I`m logged in at forum as admin, then i go at gallery (gallary "see my login from forum") then try go at http://xxxxx/gallery/admin.php and gallary say to me - you do not have acces to this page =( How i can fix it ?
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Joachim Müller on September 24, 2007, 08:38:59 am
Start a thread of your own on the support board, doing exactly as suggested in the bridging section of the docs - locate the chapter about how to ask for support on bridging issues.
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Lahori_Munda on July 01, 2009, 05:40:01 pm
Ok. how i can integrate with my board version. I am using 2.2.x
Title: Re: Invisionboard 1.3.1 bridged with CPG 1.4.3
Post by: Joachim Müller on July 02, 2009, 02:41:00 pm
Is there an echo in here? Exactly the same thing I said above applies to you as well
Start a thread of your own on the support board (http://forum.coppermine-gallery.net/index.php/board,50.0.html), doing exactly as suggested in the bridging section (http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#integrating) of the docs (http://coppermine-gallery.net/demo/cpg14x/docs/index.htm)
There is even a section there that is named "Bridging support (http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#integrating_support_start)". Your reply clearly shows that you haven't done as suggested and haven't read a single word.
Locking this thread to make sure that this thread doesn't get cluttered even more with such silly replies from people who expect to be spoon-fed.