Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Problem updating coppermine  (Read 947 times)

0 Members and 1 Guest are viewing this topic.

schive24

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Problem updating coppermine
« on: May 13, 2019, 03:02:36 pm »

Hello all.  Hoping someone can point me in the right direction.  My old version of coppermine stopped working, so I installed the latest (1.6) version by uploading all of the new files via FTP, but when I go to the update.php file in the web browser, I get the following fatal error:

Fatal error: Uncaught Error: Call to a member function numRows() on boolean in /home2/bigbenne/public_html/photos/bridge/udb_base.inc.php:356 Stack trace: #0 /home2/bigbenne/public_html/photos/bridge/udb_base.inc.php(99): core_udb->get_user_data(3, Array, 3) #1 /home2/bigbenne/public_html/photos/include/init.inc.php(255): core_udb->authenticate() #2 /home2/bigbenne/public_html/photos/update.php(26): include_once('/home2/bigbenne...') #3 {main} thrown in /home2/bigbenne/public_html/photos/bridge/udb_base.inc.php on line 356

Attached are my PHP settings in cPanel.  any help would be much appreciated!
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1258
Re: Problem updating coppermine
« Reply #1 on: May 13, 2019, 03:31:51 pm »

Begin by trying this:
Check that dbserver in include/config.inc.php is set to just localhost
Then try running update.php again.
Logged

schive24

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Problem updating coppermine
« Reply #2 on: May 13, 2019, 03:57:58 pm »

Thanks for the quick reply.  Yes, it is set to 'localhost'
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1258
Re: Problem updating coppermine
« Reply #3 on: May 13, 2019, 04:25:39 pm »

Logged

schive24

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Problem updating coppermine
« Reply #4 on: May 13, 2019, 10:40:14 pm »

I tried running that script and this is what I get:

"The extension providing ZipArchive is not available"
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1258
Re: Problem updating coppermine
« Reply #5 on: May 14, 2019, 03:48:54 am »

Referencing your CPanel PHP settings above ...

If you could select PHP 7.1, that would be better than 7.0
Enable zip ( and enabling imagick would be beneficial, too )

Try the cpg_installer_stub again.
Logged

schive24

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Problem updating coppermine
« Reply #6 on: May 14, 2019, 01:38:31 pm »

Ok, I was able to run the script and I now have a functioning version of coppermine installed, but now all of my albums are missing... The images are still on the server, but I guess the database information got erased?

Fortunately, I did a database dump before the update, so I have the only mysql file.  Any suggestions on how to restore the albums?
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1258
Re: Problem updating coppermine
« Reply #7 on: May 14, 2019, 03:40:45 pm »

There is no reason for you to have lost anything.  Did you choose to upgrade the current gallery and was it a 1.5.20+ gallery?
If your database information in include/config.inc.php was okay, it should have upgraded with no issue.
Do you need hands-on help sorting this out?
Link to site?
Logged

schive24

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Problem updating coppermine
« Reply #8 on: May 15, 2019, 03:04:03 am »

Yes, I would love you to take a look at it.  I PM'd you the login credentials.
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1258
Re: Problem updating coppermine
« Reply #9 on: May 15, 2019, 05:44:55 am »

It would appear that you were running a CPG 1.4.x gallery. You can not upgrade directly from 1.4 to 1.6 ... you will need to upgrade to CPG 1.5 first.
https://documentation.coppermine-gallery.net/en/upgrading.htm#upgrade_any

You will need to set your PHP version back to 5.6 to be able to do that. Once you have upgraded to 1.5.x, you can upgrade to 1.6.x using the cpg_installer_stub that you already tried. Then you can set your php version to 7.1.

Logged

schive24

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Problem updating coppermine
« Reply #10 on: May 15, 2019, 02:13:32 pm »

Ok... so how do I go from 1.6 back to 1.4 to start over?
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1258
Re: Problem updating coppermine
« Reply #11 on: May 15, 2019, 04:04:19 pm »

Ok... so how do I go from 1.6 back to 1.4 to start over?

I will help you. Will try to do it within a day or two.
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1258
Re: Problem updating coppermine
« Reply #12 on: May 15, 2019, 09:02:14 pm »

I will help you. Will try to do it within a day or two.

I had some time sooner than I expected. Your site is running CPG 1.6.06 with PHP 7.1
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 21 queries.