Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Upgrade to v1.5.16  (Read 4832 times)

0 Members and 1 Guest are viewing this topic.

jackd

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
Upgrade to v1.5.16
« on: December 07, 2011, 08:45:01 pm »

I made a huge error and upgraded my forum before I unbridged the gallery and now when I try to upgrade to v1.5.16 from 1.4.18 I get the usual anonymous group table not found, etc. I read everything here I could find and tried all solutions to no avail.

Being that I did not un-bridge prior to the upgrade do I have any options to upgrade at this point.

I would really hate to re-populate 25,000 images.

Thanks for your time.
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1504
  • aka 'i-imagine'
    • Home Page
Re: Upgrade to v1.5.16
« Reply #1 on: December 08, 2011, 12:41:59 am »

I am not experienced enough with bridging issues, but if you cannot run update.php because you are not logged in, then modify update.php as follows.

Make certain that you have backups as instructed in the docs.

Make a backup of update.php before starting, you will need to restore the original copy when finished.

Find:
Code: [Select]
// define('SKIP_AUTHENTICATION', true);
Replace with / Change to:
Code: [Select]
define('SKIP_AUTHENTICATION', true);
This will allow you to run update.php as an unlogged user.

Quote
I would really hate to re-populate 25,000 images.
Should not occur as long as your db's are backed up. Album folders aren't touched during the upgrade process.

jackd

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
Re: Upgrade to v1.5.16
« Reply #2 on: December 08, 2011, 01:00:54 am »

Appreciate the answer Joe but not logged in is not the problem. I run the update and the first thing that pops up is the anonymous usergroup table is not found. I added it and still no joy. Tried a clean install of 4.18 and tried to hook to the original db and still errors. Can't upgrade to v1.5 without errors. Also tried a clean install of 418 and restored my dump, then fatal errors again.

This was a screw up by me and I assume it has something to do with the bridge that I did not un-bridge first. My main concern was the forum upgrade at the time and I simply forgot about the bridge. So I was just wondering if anyone had any suggestions because I have triied just about everything at this point.

Thanks again
Logged

jackd

  • Coppermine newbie
  • Offline Offline
  • Posts: 17
Re: Re: Upgrade to v1.5.16
« Reply #3 on: December 08, 2011, 01:05:00 am »

Should not occur as long as your db's are backed up. Album folders aren't touched during the upgrade process.

Yes I have dumps and understand about the albums. What I was getting at is if I had to do a clean install and then just ftp all images back in. No problem there but putting them in the right albums with names.

Uhhh, I don't want to have to do that... :(
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1504
  • aka 'i-imagine'
    • Home Page
Re: Upgrade to v1.5.16
« Reply #4 on: December 09, 2011, 01:00:05 am »

...Tried a clean install of 4.18 and tried to hook to the original db and still errors.  Also tried a clean install of 418 and restored my dump, then fatal errors again.
If I was at your keyboard, this is what I would do.

Don't perform a full installation of cpg 1.4.27 - just replace / remove all cpg 1.5.16 files with the older version and point your config.inc,php to the restored copy of your db.
Then do one of two things.

Try to unbridge by going directly to bridgemgr.php and logging in to unbridge the gallery.
Try to update the gallery through update.php.

You could also set the gallery to offline status by changing the value in config using phpMyAdmin or something similar before you start.

... upgrade to v1.5.16 from 1.4.18 ...
That version is quite dated and was updated a few times for security reason.

Pages: [1]   Go Up
 

Page created in 0.021 seconds with 22 queries.