Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: Cannot upload files - nothing happens  (Read 13106 times)

0 Members and 1 Guest are viewing this topic.

sven

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 22
Cannot upload files - nothing happens
« on: May 02, 2010, 12:28:14 pm »

Coppermine version: cpg1.5.3
Testbed URL: http://hildebrandt.no/sven/albums/
Server OS: Linux ?
Web Server: Apache ?
PHP Version: 4.4.9
Image library used: GD2
Bridging: none
Themes tested: Various
Client OS: Windows 7 Ultimate English
Client Browser: IE8, Opera 10.53 and FF3.6.3
Install type: Upgrade from 1.4.18
Source: ?
Browser language: English
Coppermine language: English
What happened (potential bug): Cannot upload any files. In many themes the 'browse button' is simply missing. It does show up in the curve-theme, but I get error 500 on uploading
How to replicate (what I did when the problem showed up): Simply log in as admin and try to upload a picture to any album
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Cannot upload files - nothing happens
« Reply #1 on: May 02, 2010, 01:30:31 pm »

Please provide a test account with upload privileges.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Cannot upload files - nothing happens
« Reply #2 on: May 02, 2010, 03:42:26 pm »

I get error 500 on uploading
That's a matter of webserver setup and not a potential bug.

In many themes the 'browse button' is simply missing.
I just tested this on my testbed with all themes that come with the package. The browse button is there and visible in all themes I tested. I strongly doubt that you are right in this aspect.

Imo this is not a valid bug report, but a straightforward support request. Read up http://documentation.coppermine-gallery.net/en/upload_troubleshooting.htm#upload_support and do as suggested there. A moderator will then move this thread accordingly.
Logged

sven

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 22
Re: Cannot upload files - nothing happens
« Reply #3 on: May 02, 2010, 03:51:34 pm »

Hi, I will check out the section. I'm sorry for maybe posting in the wrong forum. I couldn't find the 1.5 support forums at first, but now I see it's there.

With regards to the 500 error on upload: I find it extremely strange that this is a webserver setup. I've used CPG for YEARS and never had an issue with it before. And seconds after upgrading to 1.5.3 it's suddenly a webserver issue?

Is your testbed an upgrade from 1.4.18 ? I tell you the browse button is not there. However, it might not be CPGs 'fault'. It can be due to the upgrade or other issues.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Cannot upload files - nothing happens
« Reply #4 on: May 02, 2010, 03:59:52 pm »

Please provide a test account with upload privileges.
Logged

sven

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 22
Re: Cannot upload files - nothing happens
« Reply #5 on: May 02, 2010, 04:29:52 pm »

Yes yes  ;)



Username: upload
Pass: test123

Now the SIMPLE upload worked (after creating a test album and a test account) which is some improvement. However, the flash upload does not work. It only returns a 500 error for every image.

Please test, and let me know what additional permissions to give
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Cannot upload files - nothing happens
« Reply #6 on: May 02, 2010, 05:04:53 pm »

I can confirm that simple upload works and flash upload returns 500 on sven's gallery.
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1503
  • aka 'i-imagine'
    • Home Page
Re: Cannot upload files - nothing happens
« Reply #7 on: May 02, 2010, 05:05:55 pm »

.....In many themes the 'browse button' is simply missing........


Coppermine META seems to be missing with your default theme.

I advise to anyone trying to help here to use a standard cpg 1.5.x theme. Otherwise you will see too many errors.

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1503
  • aka 'i-imagine'
    • Home Page
Re: Cannot upload files - nothing happens
« Reply #8 on: May 02, 2010, 05:10:29 pm »

Flash debug returns this:

An ActionScript error has occured

Error #2044: Unhandled IOErrorEvent:. text=Error #2038: File I/O Error.

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Cannot upload files - nothing happens
« Reply #9 on: May 02, 2010, 05:39:48 pm »

Logged

sven

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 22
Re: Cannot upload files - nothing happens
« Reply #10 on: May 06, 2010, 07:22:49 pm »

No solution for this one?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Cannot upload files - nothing happens
« Reply #11 on: May 06, 2010, 08:20:24 pm »

That's a matter of webserver setup
So the solution has to be found by you or your web hosting provider.
Logged

sven

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 22
Re: Cannot upload files - nothing happens
« Reply #12 on: May 06, 2010, 09:58:55 pm »

Aha, but can you give me a hint of why a simple upload works, and not a flash upload? What are the technical difference? Does it need another type of permission?
Logged

sven

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 22
Re: Cannot upload files - nothing happens
« Reply #13 on: May 06, 2010, 10:02:19 pm »

Is it possible to EDIT the posts in this forum? I couldn't find it, so another post here:

Can you also give me a hint of what might be the limit when it comes to the webserver setup? Have I forgotten to enable the 'Allow flash upload to Coppermine Photo Gallery' option in Apache? You get the idea
Logged

Joe Carver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1503
  • aka 'i-imagine'
    • Home Page
Re: Cannot upload files - nothing happens
« Reply #14 on: May 07, 2010, 12:33:59 am »

Although I can not say for sure, if I was at your keyboard I would start with.....

1) See what the server's error logs show
2) Ask the host if they have any restrictions on your account - explain to them the problem is specific to your account and has not been seen elsewhere
3) Fix your default theme by returning the token {META} to the <head> of file template.html

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Cannot upload files - nothing happens
« Reply #15 on: May 07, 2010, 09:25:35 am »

Is it possible to EDIT the posts in this forum?
No. That feature has been disabled deliberately to keep users from doing what you wanted to do. We don't want you to edit your postings, no.
Logged

sven

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 22
Re: Cannot upload files - nothing happens
« Reply #16 on: May 07, 2010, 01:35:34 pm »

Joe Carver: I wish you were at my keyboard and could press the correct keys, hehe

OK, thanks for hints. This is a hosted webserver so I have to ask my host about #1.

I'm not sure if I understand #3, but you say the META tag is missing? Funny, I didn't know I'd edited anything. But I've used CPG since 2001 (Am I wrong? Did it exist then?) so it's possible that I've done something in the past that I don't remember now. Forgetfulness, the weakness of human nature.

I will look into this and give a feedback. We will get this solved.

I also have another small problem which is DEFINITELY a bug, but I will get back to that problem when this problem is solved
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Cannot upload files - nothing happens
« Reply #17 on: May 07, 2010, 01:41:11 pm »

it's possible that I've done something in the past that I don't remember now
You could do a fresh install of cpg1.5.x to check if it happens there, too.

I also have another small problem which is DEFINITELY a bug, but I will get back to that problem when this problem is solved
Please start a new thread in the appropriate board.
Logged

sven

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 22
Re: Cannot upload files - nothing happens
« Reply #18 on: May 07, 2010, 03:02:14 pm »

It will most likely not happen with a fresh install. But I will not install it from scratch. I will not lose all my data, all viewcounts and so on.

Yes, I will start another thread for the other problem
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15765
Re: Cannot upload files - nothing happens
« Reply #19 on: May 07, 2010, 03:37:14 pm »

It will most likely not happen with a fresh install. But I will not install it from scratch. I will not lose all my data, all viewcounts and so on.
You shouldn't delete your data, but install a second gallery for testing.
Logged
Pages: [1] 2   Go Up
 

Page created in 0.026 seconds with 19 queries.