Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Suddenly, blank Index.  (Read 3530 times)

0 Members and 1 Guest are viewing this topic.

Fabricio Ferrero

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 1996
  • From San Juan, Argentina, to the World!
    • http://fabricioferrero.com/
Suddenly, blank Index.
« on: June 30, 2009, 04:14:21 am »

There is a user in this thread (in Spanish) that says that her gallery shows a blank index page.

Link: http://www.crepusculochile.com/galeria/

Since I was not able to fix the problem through forum, I asked for an FTP account and tried to fix it. Unfortunately, I can't. I re-upload all themes files, and I already update the gallery to 1.4.25.

The rest of the gallery is working, check here: http://www.crepusculochile.com/galeria/admin.php?theme=classic

I'm missing some tiny thing or is something out of my knowledge.

I would appreciate some help here.

Thanks!
Logged
Read Docs and Search the Forum before posting. - Soporte en español
--*--
Fabricio Ferrero's Website

Catching up! :)

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Suddenly, blank Index.
« Reply #1 on: June 30, 2009, 11:01:54 am »

http://www.crepusculochile.com/galeria/thumbnails.php?album=1 works as well, so the index or one of the files that the index is including is broken. Did you take a look at anycontent - maybe that file is broken. Go to the config panel and disable any custom include and the usage of anycontent temporarily.
Logged

Fabricio Ferrero

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 1996
  • From San Juan, Argentina, to the World!
    • http://fabricioferrero.com/
Re: Suddenly, blank Index.
« Reply #2 on: June 30, 2009, 02:29:57 pm »

Did you take a look at anycontent - maybe that file is broken.
Actually I did. I tried a lot of thing with this gallery, something weird is happening here. Now the gallery looks like "breadcrumb/catlist/" and despite that, is not working.

I even tried to remove the withe spaces in the themes files. Anyways, I replace them again with a fresh copy.

???
Logged
Read Docs and Search the Forum before posting. - Soporte en español
--*--
Fabricio Ferrero's Website

Catching up! :)

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Suddenly, blank Index.
« Reply #3 on: July 04, 2009, 10:29:29 am »

Please PM me the coppermine admin account and the FTP details.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Suddenly, blank Index.
« Reply #4 on: July 08, 2009, 04:07:00 pm »

Using the account data and FTP access you PMed me I was able to narrow things down: if you change "the content of the main page" in coppermine's config to "" or just "breadcrumb", the index page will show. Only if you set it to "bradcrumb/catlist/alblist", the index goes blank. The order doesn't matter,  nor does it matter if I enter "alblist" or "catlist" only - the result remains the same.
To make sure that this is not related to some broken file I replaced all files and got rid of the unused themes. The anycontent file looks OK as well as the config file, so I'm not sure what actually goes wrong. Quite frankly: I'm running out of ideas as well.
Logged

Nibbler

  • Guest
Re: Suddenly, blank Index.
« Reply #5 on: July 08, 2009, 04:20:10 pm »

Try removing the flush() calls here in index.php

Code: [Select]
                    case 'catlist':
                        if ($breadcrumb != '' || count($cat_data) > 0) theme_display_cat_list($breadcrumb, $cat_data, $statistics);
                        if (isset($cat) && $cat == USER_GAL_CAT) {
                            list_users();
                        }
                        flush();
                        break;

                    case 'alblist':
                        list_albums();
                        flush();
                        break;
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Suddenly, blank Index.
« Reply #6 on: July 08, 2009, 04:43:25 pm »

And again Nibbler saves the day: did as you suggested and voila: the index work as expected.
Logged

Fabricio Ferrero

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 1996
  • From San Juan, Argentina, to the World!
    • http://fabricioferrero.com/
Re: Suddenly, blank Index.
« Reply #7 on: July 08, 2009, 08:07:46 pm »

WOW! I think this problem was going to be unsolved for ever!

Thank you very much Joachim for the time on this issue!

Thank you very much for you too Nibbler for bringing once again a fantastic solution!

Cheers,

:)
Logged
Read Docs and Search the Forum before posting. - Soporte en español
--*--
Fabricio Ferrero's Website

Catching up! :)

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Suddenly, blank Index.
« Reply #8 on: July 09, 2009, 11:20:41 am »

@Nibbler: do you think we should review the usage of flush if that is causing issues?
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 19 queries.