Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: [Solved]: Strange upload problem with CPG 1.4.18  (Read 6956 times)

0 Members and 1 Guest are viewing this topic.

divuk83

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
[Solved]: Strange upload problem with CPG 1.4.18
« on: June 15, 2008, 11:52:33 pm »

Hi All

Just upgraded my coppermine gallery in the hope of fixing a problem I was having with the batch upload on CPG however the problem is still the same.

Basically I go to batch, then select the folder, the select the files by checking the boxes, select the album I want them to go in and press insert selected files only to be taken straight back to the main "select directory" page of the batch upload page. I had a bit of bother with batch upload and used the trouble shooting sorted it out last time however its not working this time. Its not actually showing any error messages, even when I forget to select an album (as I frequently do!) it just goes back to the select directory page.
http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#upload_trouble

Not really sure what else to try.

Thanks in advance.

Dave
« Last Edit: June 18, 2008, 02:00:26 pm by Nibbler »
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: Strange upload problem with CPG 1.4.18
« Reply #1 on: June 16, 2008, 06:29:27 am »

Read this thread and the one nibbler suggests in there : http://forum.coppermine-gallery.net/index.php/topic,52656.0.html
Logged

divuk83

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Strange upload problem with CPG 1.4.18
« Reply #2 on: June 16, 2008, 09:35:05 am »

Thanks for the speedy reply.

Don't think I can get at the php.ini file on the server, though upload_max_filesize is already set to 32mb.

I still get the same problem wether I try and upload 1 individual file or 100+ via the batch method. The files are all small 160kb jpegs.

http://www.divuk83.net/images/cpgproblem.jpg [Edit GauGau] Replaced hotlinked image with attachment [/Edit]

I will try emailing my Webhost to get them to increase the Suhosin upload limits, would that still stop me from uploading 1 small file via the batch method?

Cheers

Dave
« Last Edit: June 21, 2008, 04:01:10 pm by Joachim Müller »
Logged

divuk83

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Strange upload problem with CPG 1.4.18
« Reply #3 on: June 16, 2008, 04:51:46 pm »

Emailed tech support and as per Nibblers suggestions in this thread asked them to increase the upload limit.

Reply from tech support.

Quote
A value of 1000 for these settings is excessive. I need sensible specific values for these before I will increase them.

Dave
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: Strange upload problem with CPG 1.4.18
« Reply #4 on: June 16, 2008, 04:54:23 pm »

Then go for a 100. See if that works.
Logged

Nibbler

  • Guest
Re: Strange upload problem with CPG 1.4.18
« Reply #5 on: June 16, 2008, 05:10:41 pm »

Depends how many pics you need to be able to process at a time. 100 is enough for about 30 pics, 1000 is enough for about 300. 200 is the default I think, so 100 probably won't help you.
Logged

divuk83

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Strange upload problem with CPG 1.4.18
« Reply #6 on: June 16, 2008, 08:51:14 pm »

Surely even with a low number it would still allow me to upload small numbers of pictures? At the moment I can't even upload them one at a time via the batch upload.

Dave
Logged

Nibbler

  • Guest
Re: Strange upload problem with CPG 1.4.18
« Reply #7 on: June 16, 2008, 08:53:41 pm »

What do you mean by 'one at a time'? Ticking one file out of a folder of many or adding from a folder containing only a single file? If the former then the restriction will apply there too.
Logged

divuk83

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Strange upload problem with CPG 1.4.18
« Reply #8 on: June 16, 2008, 09:10:10 pm »

Ticking 1 out of a folder of many files doesn't work, seems odd as I have uploaded 137 photos of the same size in the same way without any bother before, the folder I'm trying to do now contains 132 images.

Cheers

Dave
Logged

Nibbler

  • Guest
Re: Strange upload problem with CPG 1.4.18
« Reply #9 on: June 16, 2008, 09:23:29 pm »

It's probable your host has only recently added the new restrictions. Either get your host to increase the limits or get used to uploading smaller batches.
Logged

divuk83

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Strange upload problem with CPG 1.4.18
« Reply #10 on: June 18, 2008, 12:41:56 am »

If I delete over 100 of the photos in the folder I can upload the remaining 25 without any problem.

I found 4 missing "critical" files from the update which I have just sorted, was hoping that would sort it but its made no difference.

On the version check page it says my "anycontent.php" is still the 1.3.2 version however I don't think I can update this as it will knacker the gallery even more if I do.

Dave
Logged

divuk83

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Strange upload problem with CPG 1.4.18
« Reply #11 on: June 18, 2008, 12:44:25 am »

Nibler, would it help if I create you an account an PM you some login details?

Cheers

Dave
Logged

Nibbler

  • Guest
Re: Strange upload problem with CPG 1.4.18
« Reply #12 on: June 18, 2008, 10:02:25 am »

How would it help? We already know what the problem is.
Logged

divuk83

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Strange upload problem with CPG 1.4.18
« Reply #13 on: June 18, 2008, 12:03:01 pm »

I have run out of ideas of things to try, thats all.

Web host has tried upping the limit to no effect.

Last nights reply:

Quote
I think your stuck with a max 30 upload limit

Dave
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: Strange upload problem with CPG 1.4.18
« Reply #14 on: June 18, 2008, 12:30:07 pm »

Ok. Maybe this wil help then: http://cpg-contrib.org/board/index.php?board=25.0

Quote
There are 3 major reasons you might want to use CPGMassImport instead of "batch adding".


You already have a directory structure and don't want to create the categories and albums any differently
You have a lot of images, and don't want to babysit the batch add process
CPGMassImport is less resource intensive on the web server than doing batch adds
Logged

Nibbler

  • Guest
Re: Strange upload problem with CPG 1.4.18
« Reply #15 on: June 18, 2008, 12:46:55 pm »

What are the limits now for suhosin.post.max_vars and suhosin.request.max_vars ?
Logged

divuk83

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Strange upload problem with CPG 1.4.18
« Reply #16 on: June 18, 2008, 01:01:04 pm »

Having a fiddle with mass import now, though will be posting in the support area for that soon I think!

They didn't tell me what the limits were upped to, I asked them to multiply them by 7 times as I can upload a folder of about 25-30 files however if I try any bigger then it would just go back to the batch upload directory page. After they increased the limits it made no difference to the number of files.

Dave
Logged

Nibbler

  • Guest
Re: Strange upload problem with CPG 1.4.18
« Reply #17 on: June 18, 2008, 01:08:37 pm »

You can see what the limits are by looking at the phpinfo.php page in your web browser.
Logged

divuk83

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Strange upload problem with CPG 1.4.18
« Reply #18 on: June 18, 2008, 01:15:26 pm »

Cheers for that.

Set at the following, which explains why I can only get about 30 pics up.

Code: [Select]
suhosin.post.max_vars    100
suhosin.request.max_vars   100

Dave
Logged

divuk83

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Strange upload problem with CPG 1.4.18
« Reply #19 on: June 18, 2008, 01:59:20 pm »

Limit has now been upped to 500 which is allowing me to get 131 photos uploaded. Thanks for all your help.

Dave
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 19 queries.