Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Batch Add Interface - no permission to access minibrowser.php  (Read 3763 times)

0 Members and 1 Guest are viewing this topic.

stevensonjr

  • Coppermine newbie
  • Offline Offline
  • Posts: 5

Hello,

First allow me to thank all the community that works around this excellent Gallery. I really think it is welldone.
I have an issue when trying to use the batch-add interface. In the IFRAME, it complains that I don't have access. So I looked at the generated HTML, and see the following :
Code: [Select]
<iframe src="minibrowser.php?startfolder=/var/www/vhosts/jpro.ch/subdomains/depart/httpdocs/photos/albums/&amp;parentform=choosefolder&amp;formelementname=startdir&amp;no_popup=1&amp;limitfolder[b][i]=/var/www/vhosts/jpro.ch/subdomains/depart/httpdocs/photos/albums/[/i][/b]&amp;hidefolders=.%2C..%2CCVS%2Cedit%2Cuserpics&amp;linktarget=searchnew.php&amp;searchnew_php=1&amp;radio=0" width="95%" height="400" name="popup_in_a_box">The thing is that my gallery is installed on a subdomain of jpro.ch (depart.jpro.ch). When I FTP I only have access to the 'depart' folder as root. I believe that using the full path (as in bold above) is my problem.
To proof my doubt, I opened a new page with
Code: [Select]
minibrowser.php?startfolder=/httpdocs/photos/albums/&amp;parentform=choosefolder&amp;formelementname=startdir&amp;no_popup=1&amp;limitfolder=/httpdocs/photos/albums/&amp;hidefolders=.%2C..%2CCVS%2Cedit%2Cuserpics&amp;linktarget=searchnew.php&amp;searchnew_php=1&amp;radio=0" width="95%" height="400" name="popup_in_a_box", and it seemes to work (although the path I used was wrong.)

Well there is where I am, and would appreciate some advice. I am not a webmaster and my knowledge are approximate ;)
« Last Edit: March 12, 2007, 07:46:43 am by GauGau »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Batch Add Interface - no permission to access minibrowser.php
« Reply #1 on: March 12, 2007, 07:47:34 am »

Post a link to your coppermine-driven gallery for a start.
Logged

stevensonjr

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Batch Add Interface - no permission to access minibrowser.php
« Reply #2 on: March 12, 2007, 07:05:41 pm »

Post a link to your coppermine-driven gallery for a start.
Sure, sorry... ;) Here is the link to the gallery http://www.de-part.ch/photos (which actually resolves to http://depart.jpro.ch/photos)
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Batch Add Interface - no permission to access minibrowser.php
« Reply #3 on: March 12, 2007, 07:12:35 pm »

Review your config settings for "URL of your coppermine gallery folder". What did you set up there?

Your current setup (not redirecting, but pretending that you have two different domains) will be considered as link farming by Google and other search engines and will result in severe punishment in Google's page rank. I suggest reviewing your server setup.
Logged

stevensonjr

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Batch Add Interface - no permission to access minibrowser.php
« Reply #4 on: March 12, 2007, 11:09:57 pm »

Review your config settings for "URL of your coppermine gallery folder". What did you set up there?

I've used the gallery as home (index.php)

Your current setup (not redirecting, but pretending that you have two different domains) will be considered as link farming by Google and other search engines and will result in severe punishment in Google's page rank. I suggest reviewing your server setup.
Not sure I understand the "pretending that you have two different domains" part of your quote. As stated, I am a huge newbie on domains and webmaster. I can say following though :
  • I know that this gallery is hosted on a subdomain of jpro.ch, whereas the prefix depart links to a specific httpdocs (/var/www/vhosts/jpro.ch/subdomains/depart/httpdocs) folder on the apache server.
  • http://www.de-part.ch is only a web redirection to http://depart.jpro.ch (which is the blog)
  • All the necessary folders for coppermine (which is in the folder photos) that need special permissions are set to 777.
  • I saw in phpinfo.php that /var/www/vhosts/jpro.ch/subdomains/depart/httpdocs is actually triggered from the open_basedir configuration of my PHP core. This is the path that is then found in the parameters of minibrowser.php, if you look at my first post.
  • I suspect that my userid to log on the apache server has no right to use this full path, however, as I have no other acces than FTP, I can't confirm (and woulden't know how).
Sorry to put so many details, hopefully someone will be able to give me good advices.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Batch Add Interface - no permission to access minibrowser.php
« Reply #5 on: March 13, 2007, 07:39:41 am »

I've used the gallery as home (index.php)
Should be a URL, not just a reference to a file, e.g.
Quote
http://depart.jpro.ch/photos/

http://www.de-part.ch is only a web redirection to http://depart.jpro.ch (which is the blog)
It is not a proper redirect in webserver terms, it is just pointing somewhere else. Google will see this as double content and punish this. Not related to your initial issue. Let's focus on your actual coppermine issue. Sorry for the thread drift.
Logged

stevensonjr

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Batch Add Interface - no permission to access minibrowser.php
« Reply #6 on: March 13, 2007, 12:24:27 pm »

Should be a URL, not just a reference to a file, e.g.
Sorry, once more I was wrong in my statement. Indeed I used the URL for my coppermine folder, and I uses index.php for the 'home' link

Not related to your initial issue. Let's focus on your actual coppermine issue. Sorry for the thread drift.
I would appreciate in fact... ;) I tried some more. Don't seem to be able to make it work :
Code: [Select]
Forbidden
You don't have permission to access /photos/minibrowser.php on this server.

--------------------------------------------------------------------------------

Apache Server at depart.jpro.ch Port 80
Logged

Nibbler

  • Guest
Re: Batch Add Interface - no permission to access minibrowser.php
« Reply #7 on: March 13, 2007, 03:29:56 pm »

This is caused by mod_security or the php hardening patch or some similar security filter. It block access because of the path in the URL. Try getting it disabled or adjusted.
Logged
Pages: [1]   Go Up
 

Page created in 0.026 seconds with 19 queries.