Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Need help with planepix.nl to work with PHP 7.2  (Read 1046 times)

0 Members and 1 Guest are viewing this topic.

altenae

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 234
Need help with planepix.nl to work with PHP 7.2
« on: October 21, 2018, 02:43:45 pm »

Who can make my planepix.nl work with php 7.2
Planepix.nl has been online for many many many years.

Upgrading to CPG 1.6 will undo so many many mods (also without plugins) over the last 12 years that everything is lost.
I have no idea how to save planepix.nl so to it can stay online after December (php 7.2)

Would someone give it a try.
For now it seems to be an issues with the connect to the DB.
Already tried a  lot with "mysqli" but always something new is going wrong.

Edward
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4573
    • Windsurf.me
Re: Need help with planepix.nl to work with PHP 7.2
« Reply #1 on: October 22, 2018, 06:36:38 pm »

A list of mods would probably help anyone wanting to assist.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

altenae

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 234
Re: Need help with planepix.nl to work with PHP 7.2
« Reply #2 on: October 22, 2018, 06:41:47 pm »

There are so many mods made by Donnovan and Andre.
I was hoping when the connection was made to the database under PHP 7.2 I could see what else is not working or still working.
And start from there.

Edward
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4573
    • Windsurf.me
Re: Need help with planepix.nl to work with PHP 7.2
« Reply #3 on: October 22, 2018, 11:10:20 pm »

Hopefully André will remember what he has done for you. Your gallery looks great. Looks like a lot of the adjustment has been to display the planes details with the file details.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1005
Re: Need help with planepix.nl to work with PHP 7.2
« Reply #4 on: October 23, 2018, 01:38:29 am »

Can you view your past posts when you look at your profile? There, you should find all the threads where you were given information for changes that were made to core files. Backup all your current CPG files; upgrade to CPG 1.5.46; upgrade to CPG 1.6.x; try to add those patches to the new files.

I would recommend that you try to get plugins created or theme modifications made to arrive at your desired site modifications in the future.

Is the wildlife site still active and also in need of updating?
Logged

altenae

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 234
Re: Need help with planepix.nl to work with PHP 7.2
« Reply #5 on: October 23, 2018, 06:26:27 am »

Yes the wildlife-photos.net is also still active.
But that website is almost the same as planepix.nl.

So when one website is made php 7.2 compatible it should be easy to apply it on another.
Also made some request about mods directly to Andre.

So the best thing is to upgrade to 1.6.x  instead  of making the current version work with php 7.2?
I was hoping some adjustments like mysql_ (into mysqli_) would give me a start ;)
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1005
Re: Need help with planepix.nl to work with PHP 7.2
« Reply #6 on: October 23, 2018, 01:20:00 pm »

Yes, there have been MANY changes and improvements to CPG code in version 1.6.x that have nothing to do with the mysql issue. Some coding in v1.5.x that has nothing to do mysql will fail because of changes with PHP 7.2.  Some coding methods that generated warnings in PHP 5.6 become total fails in PHP 7.2.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15577
Re: Need help with planepix.nl to work with PHP 7.2
« Reply #7 on: October 23, 2018, 05:10:48 pm »

I'm in contact with Edward. If I remember correctly most mods have been discussed and developed privately, so you won't find them in the past posts. I'll check the differences in his gallery with a vanilla cpg1.5.x to find the mods and then try to re-apply them to the upgraded gallery (or convert them to plugins, if it's not too much work).
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 20 queries.