Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Save New Configuration Button Not Working  (Read 136 times)

0 Members and 1 Guest are viewing this topic.

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 109
Save New Configuration Button Not Working
« on: July 08, 2018, 11:02:48 pm »

So I solved one issue on the upgrade, but a new one has come up. This on all my upgrades. I'll use the same gallery of http://stephennichols.org/gallery using the latest stable version of 1.6.03.

So the issue I have now is I went to change the thumbnail size on this gallery to align with a new theme I'm going to use, but when I hit the "save new configuration" button, it won't work. I tried this on two of my other galleries I've upgraded to this same version and the same issue is present.

Sorry for the double post but while solving the one issue, this one came up.
Logged
Sometimes my musings are too confusing for someone not inside my head.

nowordneeded

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 109
Re: Save New Configuration Button Not Working
« Reply #1 on: July 09, 2018, 01:03:37 am »

Along with the button not working, when I upload new images I get a fatal error warning. On this gallery http://tamara-braun.com/gallery using the latest stable version 1.6.03



Fatal error: Uncaught Error: Call to undefined function mysql_num_rows() in /tamara-braun.com/gallery/themes/KED-cpg104/theme.php:58 Stack trace: #0 /tamara-braun.com/gallery/displayimage.php(443): theme_display_fullsize_pic() #1 {main} thrown in /tamara-braun.com/gallery/themes/KED-cpg104/theme.php on line 58 and it won't show full size image. The code in line 58 is this:

Code: [Select]
if (!mysql_num_rows($result)) {
Also when I went to put the images in the album on the page where the images are supposed to show up, I got this image in the first attachment, then in the second is what happens when you bring up the full size image.
Logged
Sometimes my musings are too confusing for someone not inside my head.

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 889
Re: Save New Configuration Button Not Working
« Reply #2 on: July 09, 2018, 03:08:58 am »

Thumbnail size
Changes in Config to thumbnail sizes only affect any newly uploaded images. To modify the size of any existing thumbnails, use Admin Tools to regenerate them.

Theme errors
Your theme is not compatible with PHP 7. For the most part, you must change any calls in a theme .php file of the form mysql_xxx_xxxx to cpg_db_xxx_xxxx and that will solve compatibility issues.
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 20 queries.