Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: After my web host migrated to a new company I'm getting an error?  (Read 958 times)

0 Members and 1 Guest are viewing this topic.

prospectator

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

This is the error I'm receiving after my host company migrated to a new host.  Any help would be great.  Thanks.

"Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home2/bryceadams/public_html/coppermine/include/functions.inc.php:183 Stack trace: #0 /home2/bryceadams/public_html/coppermine/include/init.inc.php(171): cpg_db_connect() #1 /home2/bryceadams/public_html/coppermine/thumbnails.php(32): require_once('/home2/bryceada...') #2 {main} thrown in /home2/bryceadams/public_html/coppermine/include/functions.inc.php on line 183"

Originally, the directory home2/bryceadams/public_html didn't exist.  On the old server the coppermine folder was in the root folder.  I'm not sure what I need to change.

Logged

prospectator

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 926

You need to have your host set you up with older (5.x) PHP or you need to upgrade your gallery to CPG 1.6.x
http://forum.coppermine-gallery.net/index.php/topic,79013.msg383037.html#msg383037
Logged

prospectator

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: After my web host migrated to a new company I'm getting an error?
« Reply #3 on: May 13, 2018, 07:02:53 am »

I just checked the web server, the PHP version is 5.6.30
Logged

prospectator

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: After my web host migrated to a new company I'm getting an error?
« Reply #4 on: May 13, 2018, 07:24:59 am »

Sorry, trying to figure out the new host software.  When I view myphpadmin is see version 5.6.30, but when I navigate to my control panel is says the server php version is 7.0.29.  Sorry for the confusion.  Thanks for the help.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4564
    • Windsurf.me

That means the MySQL version is 5.6 and PHP is Version 7. They are different elements of the server.

Hopefully you now know what you need to do. Upgrading is probably your best option.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

prospectator

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: After my web host migrated to a new company I'm getting an error?
« Reply #6 on: May 13, 2018, 08:57:36 am »

Just ran the update and all seems to be working correctly.  Can't thank you enough for the help.  :)
Logged
Pages: [1]   Go Up
 

Page created in 0.056 seconds with 20 queries.