Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Upgrade to 1.6 from 1.5.20  (Read 1352 times)

0 Members and 1 Guest are viewing this topic.

anglefire

  • Coppermine newbie
  • Country: 00
  • Offline Offline
  • Posts: 18
    • Disco3Club
Upgrade to 1.6 from 1.5.20
« on: March 11, 2018, 03:59:23 pm »

Afternoon,

We have recently upgraded our phpBB board to 3.2.2 and also changed server which is running php7 - so the gallery has ceased to function!

So I'd like to upgrade it to the latest 1.6 which supports php7 - but would like some advice on the best way of doing it.

Now, the other way that is open to us is to upgrade the old server as that is still up, but not in use, and transfer the files over once upgraded (I assume the DB's are upgraded in some way?)

I have read some of the available documents, but unless I missed it (likely!) then I'm not sure the best way to upgrade - and I did see that 1.6 is lacking some docs hence not a release candidate yet!
Logged
Mark
Disco3Club Admin

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15578
Re: Upgrade to 1.6 from 1.5.20
« Reply #1 on: August 16, 2018, 03:27:27 pm »

You should first upgrade to the latest version of cpg1.5.x (currently cpg1.5.46) as described in the docs. Don't forget to run update.php! Then, perform the upgrade to cpg1.6.x the same way or read this: http://forum.coppermine-gallery.net/index.php/topic,79013.0.html
Logged
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 21 queries.