Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: When the mobile display doesn't mirror the desktop display  (Read 1386 times)

0 Members and 1 Guest are viewing this topic.

Hanna.

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 127
  • webstar
When the mobile display doesn't mirror the desktop display
« on: February 24, 2018, 01:16:59 am »

Hi everyone. I am seeking some assistance in what can be done to make sure that the mobile devices- display/design/look/functions etc. mirrors the desktop. for instance, my coppermine galleries, in mobile mode, are very slowly appearing. And they are only made at 360px which is not that big, and sometimes they don't even load even if the page finished loading. What could be the cause of this? The once used javascript for image-display is apparently not needed anymore, so what are the options?
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 837
Re: When the mobile display doesn't mirror the desktop display
« Reply #1 on: February 24, 2018, 05:18:59 am »

As I said in another thread, you need to determine (as in the attached) why images are failing to be properly sent to the browser. That has nothing to do with mobil or not.
If you clear browser cache and try to load Sarah or Rachel, you get missing (not properly sent) images.

Themes that are fairly good with mobile: http://monicandesign.com/shop/category/themes/
« Last Edit: February 24, 2018, 06:17:10 am by ron4mac »
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 837
Re: When the mobile display doesn't mirror the desktop display
« Reply #2 on: February 27, 2018, 01:45:02 am »

I'm almost certain now that your theme is causing the thumbnails to not be properly displayed (along, probably, with some other issues). Something in your theme, and the external scripts that it invokes, is causing your <theme>/style.css file to be reloaded while in the process of rendering images. The same thing is happening with 'Kristin' ... but I think the large logo image is causing the render timing to be different enough that the thumbnail display escapes being messed up.

I think your best bet is to move to a modern, responsive theme design like one of the ones linked to above (MonicaNDesign).

Or if you want to zip up and post your theme here, or PM me with it, I'll try to clean it up for you.
« Last Edit: February 27, 2018, 01:52:22 am by ron4mac »
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 21 queries.