Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: With Firefox Quantum the multiple files upload using Flash [b]no longer works  (Read 831 times)

0 Members and 1 Guest are viewing this topic.

DKogan

  • Coppermine newbie
  • Offline Offline
  • Posts: 15

Re: Coppermine Photo Gallery 1.5.46 (stable)

With Firefox Quantum 57.0 the multiple files upload using Flash no longer works.
Flash was upgraded to make sure it wasn't Flash.

The error:
Quote
Upload interface could not load. You may need to install or upgrade Flash Player. Visit the Adobe website to get the Flash Player.
Alternately you can use the single file upload interface.

I am very green :-[ when it come to this tech stuff so Please dumb down the answer and give a step by step.

Thank you in advance.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4507
    • Windsurf.me

With CPG 1.6 we are switching to an HTML5 uploader. You could upgrade to that or use the HTML5 uploader plugin for your current version.

I the mean time, we will investigate to see if there is anything obvious. I assume everything is fine in other browsers.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

DKogan

  • Coppermine newbie
  • Offline Offline
  • Posts: 15

It was pointed out to me that the Forum moderators want a link to my installation:
https://www.smpub.com/ubb/ssfgallery/index.php
Logged

DKogan

  • Coppermine newbie
  • Offline Offline
  • Posts: 15

With CPG 1.6 we are switching to an HTML5 uploader. You could upgrade to that or use the HTML5 uploader plugin for your current version.

Thank you for the prompt reply.

I am very green but responsible for my site.
I do see a long forum thread about  the HTML5 uploader plugin.
That thread has numerous code suggestions/corrections much are way above my pay grade  ;) so I am unsure which are applicable.
I would appreciate being directed to a 'step by step' to accomplish the Coppermine Photo Gallery 1.5.46 (stable) upgrade to  the HTML5 uploader plugin.
In reading the forums its apparent everyone is more technical than me/us.....
We have been happily using Coppermine Photo Gallery for years. We have been successfully upgrading Coppermine ourselves without a problem.

A clear step by step would be greatly appreciated but if we have to wait for the next stable release we will try to be patient.

Thanks again & thanks in advance. :)
Logged

DKogan

  • Coppermine newbie
  • Offline Offline
  • Posts: 15

Quote
I assume everything is fine in other browsers.

I would think so but haven't tested.

FYI: Right before the FF upgrade to Quantum my FF was working just fine for single or multiple file uploads to Coppermine.
Simultaneously, we were being to look into some Mac user complaints about  multiple file uploads to Coppermine. We didn't get too far.
The first Mac user got a new device but before the new device/MAC they were not having any issues.
For the second Mac user we need to get more specific info from them. Until then we aren't counting this user as having an open issue until we get more info.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4507
    • Windsurf.me

Ok, it was my assumption that other browsers are still working. While installing the HTML5 uploader is a simple task, just install it like any other plugin, it may not actually fix your problem if something more fundamental is going on. So first we need to make sure uploads are working with other browsers. If that is the case then we can look into either fixing the flash issue or changing uploader. In the docs we have a section titled upload troubleshooting. In it we detail the information and setup we need to assist you. So either setup coppermine and provide a test logon as detailed, or test uploading yourself in other browsers. Then we will be better placed to help you.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

DKogan

  • Coppermine newbie
  • Offline Offline
  • Posts: 15

Thanks again.
The day is ending here in NYC so I will circle back tomorrow.
I'll give the documentation another try.
Also if I have several browsers installed .. most are not up date. Email me if testing with the out of date browsers would be helpful... I'll let you know which browsers/versions.
Logged

DKogan

  • Coppermine newbie
  • Offline Offline
  • Posts: 15

For what its worth here are the most recent comments from the two MAC users.

Pxxx (user)
Not a new PC, just an old Mac with the most recent OS.


axxx (user)
Sorry to be a bit slow in coming back. I have had several attempts at multiple uploads, trying to be sure flash player is on.My issue seems to be exactly the same as Polly's.

Mind you, I think I have always had to upload photos one by one. Normally when I click on something that needs flash, a reminder pops up that I need to install (or activate) it. That has never happened with this photo host. In the past, to the best of my memory, I have always just given up and loaded them one by one because I wasn't sure how to activate flash without the reminder.

To be clear, I now have flash permanently set on for SMPub, Coppermine and, for some reason, my bank. Everywhere else has to ask.


Since I don't use or know anything about MACs ..... what would you like me to ask them?
Logged

DKogan

  • Coppermine newbie
  • Offline Offline
  • Posts: 15

OK the requested Test Album, tester user account (pw: tester#123) has been setup. (if interested I could make some suggestions to improve the very detailed and appreciated instructions)
Quote
It's a good idea to show supporters that you tried for yourself before asking for support - explain what actually goes wrong, how far you got, what error message you get etc.
The tester user id was used to single upload a test image. It went OK.
The problem remains as described in the first post that started this thread.
Logged

DKogan

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4507
    • Windsurf.me

OK, so your coppermine install is working as expected. However, the new firefox is not flash friendly. So best bet is to install the HTML5 uploader and set that as the default method.

The plugin is available here - http://forum.coppermine-gallery.net/index.php/topic,75927.0.html

Installation is simple and detailed in the docs (we are always happy for contributions to improve the docs) here - http://documentation.coppermine-gallery.net/en/plugins.htm
Logged
It is a mistake to think you can solve any major problems just with potatoes.

DKogan

  • Coppermine newbie
  • Offline Offline
  • Posts: 15

OK, so your coppermine install is working as expected. However, the new firefox is not flash friendly. So best bet is to install the HTML5 uploader and set that as the default method.

The plugin is available here - http://forum.coppermine-gallery.net/index.php/topic,75927.0.html

Installation is simple and detailed in the docs (we are always happy for contributions to improve the docs) here - http://documentation.coppermine-gallery.net/en/plugins.htm

Thank you.

I suppose it will be OK for me to set the user id tester to inactive and to turn off debug mode?

I will next tackle the HTML5 uploader plug-in.  If I have questions should they be added to this thread or start a new post (in what forum?)?

Thanks again.
Logged

DKogan

  • Coppermine newbie
  • Offline Offline
  • Posts: 15

Quote
The plugin is available here - http://forum.coppermine-gallery.net/index.php/topic,75927.0.html

This is a long thread (5 pages).
Does the download in the first post of the long thread incorporate all the required suggestions/corrections mentioned throughout the 5 page thread?
Logged

DKogan

  • Coppermine newbie
  • Offline Offline
  • Posts: 15

I must say that was easy!!
My fear of screwing something was really slowing me down. It was real easy and it worked for me with Firefox Quantum.
Now lets see if the MAC users are OK?

Again, Thank you.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4507
    • Windsurf.me

Very glad you have things sorted. Yes, the latest release is in the first post so you have installed the correct one.

Logged
It is a mistake to think you can solve any major problems just with potatoes.

DKogan

  • Coppermine newbie
  • Offline Offline
  • Posts: 15

 :)Both of the Mac users who were having problems say the HTML5 uploader works for them.

Please know our thanks for your efforts and the HTML5 uploader plugin developer efforts are very sincere. :D

Logged

DKogan

  • Coppermine newbie
  • Offline Offline
  • Posts: 15

The choices drop down still shows: multiple files - flash-driven (recommended)

Is there a way to get recommended removed? And perhaps get multiple files - HTML5-driven to the top of the drop down list?
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 742

The choices drop down still shows: multiple files - flash-driven (recommended)

Is there a way to get recommended removed? And perhaps get multiple files - HTML5-driven to the top of the drop down list?

For that you'll need to upgrade to version 1.6
http://forum.coppermine-gallery.net/index.php/topic,78505.msg381584.html#msg381584
or
http://forum.coppermine-gallery.net/index.php/topic,79013.0.html
Logged
Pages: [1]   Go Up
 

Page created in 0.105 seconds with 22 queries.