Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: PHP 7 version wanted!!!!  (Read 197 times)

0 Members and 1 Guest are viewing this topic.

Hanna.

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 101
PHP 7 version wanted!!!!
« on: October 11, 2017, 06:13:21 am »

Not sure if this is the right category, but I am panicking.

My server provider tells me "Seems your cms you use on this side is really old and does not support the stable and secure php7 versions so it fails
we changed your php version to the old one 5.6 and works -- you should upgrade your scripts to make it compatible with php7 that is used since month already and 5.x will be out of date soon anyway"

I cannot afford to keep my websites down just because the versions are not compatible. When is Coppermine upgrading to support PHP7?
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4455
    • Windsurf.me
Re: PHP 7 version wanted!!!!
« Reply #1 on: October 11, 2017, 12:18:08 pm »

Coppermine version 1.6 is already compatible with PHP 7. Details on this can be found in the CPG 1.6 forums here.

Having said that, PHP 5.6 is still a current product and far from what your host is suggesting. It is still supported and being actively updated until December 2018. As such PHP 5.6 is still secure and will be for a long time. PHP 7 is currently only in use by 7% of websites but that figure is growing rapidly. It is good that your host supports it as many do not yet.

Logged
It is a mistake to think you can solve any major problems just with potatoes.

Hanna.

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 101
Re: PHP 7 version wanted!!!!
« Reply #2 on: October 11, 2017, 07:20:22 pm »

Ok, I understand. Although my coppermine installations are up-to-date with latest which is 1.5. I am assuming that 1.6 is coming shortly then?
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Online Online
  • Posts: 669
Re: PHP 7 version wanted!!!!
« Reply #3 on: October 11, 2017, 09:38:02 pm »

Ok, I understand. Although my coppermine installations are up-to-date with latest which is 1.5. I am assuming that 1.6 is coming shortly then?

You can upgrade to 1.6 now!  Many sites are running it.
http://forum.coppermine-gallery.net/index.php/topic,79013.0.html
Logged
Pages: [1]   Go Up
 

Page created in 0.101 seconds with 21 queries.