Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Disable\Install\Uninstall Plugins  (Read 1399 times)

0 Members and 1 Guest are viewing this topic.

netb

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 81
Disable\Install\Uninstall Plugins
« on: June 21, 2017, 05:14:48 pm »

The Disable\Install\Uninstall buttons doesn't seem to be working in the Plugin Manager. Sometimes it displays:
 
Quote
Error
A valid form token could not be found.
Logged

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 720
    • GMC Design Photo Gallery
Re: Disable\Install\Uninstall Plugins
« Reply #1 on: June 21, 2017, 06:41:56 pm »

The form token is only valid for a period of time... I don't recall the actual limit - but if you are getting this error after the page has been displayed for a while - it is a 'normal' expected response...  Also could be an issue if cookies are cleared.

If other than that - please provide more details in how you might create the error.
Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money

netb

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 81
Re: Disable\Install\Uninstall Plugins
« Reply #2 on: June 21, 2017, 10:59:39 pm »

Okay maybe it's a faulty plugin or something I don't expect all to be working in 1.6 but it seems the error happens always when I try to enable the Image Manipulation (image_manipulation): v2.3.

Currently I somehow managed to disable it by clicking the Disable button. It stays listed on the upper part of the page where the installed plugins are. And cannot be re-enabled. Only the error is shown when I click on the Enable button.
Logged

netb

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 81
Re: Disable\Install\Uninstall Plugins
« Reply #3 on: June 25, 2017, 08:15:46 pm »

Okay this looks like to be the same thing in another case. I get this error in the logs:

Quote
Jun 25, 2017 at 05:29 PM - Denied privileged access to viewlog.php by user Guest at IP

I thought it may be some sort of an aggressive caching or I don't know what else. I've just logged in and when I tried to view a photo which is uploaded to a private album for approval - it behaves as I'm not logged in and displayed the last public photo and I had to log in again.


Also for the plugins, their buttons seem to work but nothing is refreshed when I disable a plugin and I have to Ctrl+F5 force it.

Should I change the cookie name from config, currentrly it is cpg15x?


I have enabled notices from Debug, but they are only shown in the source of the page, should they be printed on the page?

Also this appears:

/include/init.inc.php
Notice line 198: Undefined index: log_retention

I've put the site in development mode on CloudFlare for the moment which should disable caching. But again the page needs to be forcibly refreshed with Ctrl+F5.

When I tried to disable the sitemaps and Check files (check_files): v0.3 plugin I got this which may be another problem with them not being compatible with 1.6:

Code: [Select]
Error

A valid form token could not be found.

File: /homepathfoo/pluginmgr.php - Line: 506
Logged

netb

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 81
Re: Disable\Install\Uninstall Plugins
« Reply #4 on: June 25, 2017, 08:28:50 pm »

Website address is greatmusclebodies.com and I have followed the instructions here
http://documentation.coppermine-gallery.net/en/upload_troubleshooting.htm?expand_all=1#upload_support_step-by-step

I have created a test user as described in the docs. User is: tester pass is the same as username. If that would be of any help.
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 657
Re: Disable\Install\Uninstall Plugins
« Reply #5 on: June 25, 2017, 11:20:34 pm »

You've got some things going on with your site that are likely being caused by plugins (or perhaps a modified index.php file).
Upload didn't work for me whether it was HTML5 or single.
I recommend that you create a folder called, say, "disabled" in the root of your CPG directory. Other than the core plugins, move all your plugins into "disabled". Check your site thoroughly for proper operation. If it's running okay, return one plugin at a time and recheck operation until you find the culprits.

There also seems to be something messing with cookies.
If I go to http://greatmusclebodies.com/?theme=sample , it should continue showing me the sample theme regardless if I click on 'Home'.
Logged

netb

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 81
Re: Disable\Install\Uninstall Plugins
« Reply #6 on: June 28, 2017, 05:29:46 pm »

The removal of all plugins and leaving just the default ones in the folder seems to did it and also the theme looks to stay as "sample" all the time.

But still I couldn't finish a successful upload, which is my other problem and maybe wasn't related to this one. You seem to have managed to upload two files but now I can't.

Will post in the other discussion.
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 21 queries.