Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Does CPG 1.6 contain newest security update (from 1.5.46)?  (Read 550 times)

0 Members and 2 Guests are viewing this topic.

nl

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Does CPG 1.6 contain newest security update (from 1.5.46)?
« on: April 08, 2017, 09:34:25 AM »

Hi there.
I have installed a 1.5.46 on a PHP 7 system, which currently is downgraded to an earlier release of PHP in order to run (.htaccess change).
I have to "upgrade" to PHP 7 soon, and would like to know if the mentioned CPG 1.6 (cpg_installer_stub.php) does contain the newest security release - or there is another way to install this release?
Looking forward to an answer for this :D - while I try installing a phpBB bridge. ;)
Thank you! :)
./nl
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4357
    • Windsurf.me
Re: Does CPG 1.6 contain newest security update (from 1.5.46)?
« Reply #1 on: April 08, 2017, 01:47:38 PM »

Yes, all security updates applied to 1.5.x line are also applied to the 1.6.x line.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 524
Re: Does CPG 1.6 contain newest security update (from 1.5.46)?
« Reply #2 on: April 08, 2017, 02:13:46 PM »

I have to "upgrade" to PHP 7 soon, and would like to know if the mentioned CPG 1.6 (cpg_installer_stub.php) does contain the newest security release - or there is another way to install this release?

You have several ways to install 1.6 over 1.5:
You can get the latest release and manually place the files in your install.
You can use the upgrader to do the work for you when you are logged in as admin to your gallery.
You can use the installer stub to perform a standalone install .. either new or over an existing install.
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 524
Re: Does CPG 1.6 contain newest security update (from 1.5.46)?
« Reply #3 on: April 08, 2017, 03:49:44 PM »

Looking forward to an answer for this :D - while I try installing a phpBB bridge. ;)

If you want to try a different method for user synchronization between phpBB3 and CPG, you could try this:
http://forum.coppermine-gallery.net/index.php/topic,76302.msg379846.html#msg379846

For use with CPG 1.6 you'll need the updated plugin attached here.
Logged

nl

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Does CPG 1.6 contain newest security update (from 1.5.46)?
« Reply #4 on: April 14, 2017, 10:21:51 AM »

Thanks a lot for your help :-)
Though .. I've just tried it over again - deleting everything and set up from start.
Last time, I had trouble with https vs http .. At least I think it was the issue.

Now, in the new setup, the following happens:
I go to https://mysite.com/cpg
Here I click on Login, which returns me to https://mysite.com/phpBB3
Where I do the login, and I will be returned to https://mysite.com/cpg .. but still not logged in  ???

Any quick solutions before I start all over again?

./nl
Logged
Pages: [1]   Go Up
 

Page created in 0.071 seconds with 21 queries.