Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Problem with PHP is not enabled to use MySQL.  (Read 3444 times)

0 Members and 1 Guest are viewing this topic.

daani_lb

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Problem with PHP is not enabled to use MySQL.
« on: November 16, 2016, 04:02:23 pm »

Let's see if you can help me. I am trying to install the gallery on my hosting of "1and1.com" and when I am going to put the name of the database and password I get this error: PHP is not enabled to use MySQL.

I have tried to insert incorrect data to see what was happening and it does not matter to write the name and password that I put. Do I have something to activate?

Do you know what it is because of this?

Thanks!!!!! :) :) :)
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1045
Re: Problem with PHP is not enabled to use MySQL.
« Reply #1 on: November 16, 2016, 04:47:39 pm »

You will either have to arrange with your hosting account to use an older version of PHP or you will have to install the beta version of CPG 1.6
https://github.com/coppermine-gallery/cpg1.6.x/releases
« Last Edit: November 16, 2016, 05:55:16 pm by ron4mac »
Logged

daani_lb

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Re: Problem with PHP is not enabled to use MySQL.
« Reply #2 on: November 16, 2016, 05:59:29 pm »

You will either have to arrange with your hosting account to use an older version of PHP or you will have to the beta version of CPG 1.6
https://github.com/coppermine-gallery/cpg1.6.x/releases

Hello,

Thank you very much. I am a bit lost. Could you tell me what to do? I have already installed the new version but I do not know what to select if MYSQLi or PD: MYSQL

I select the first one and it tells me the following: Could not create a MySQLi connection, please check the MySQLi details entered
Database error: No such file or directory.

Thank you.

A greeting.
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1045
Re: Problem with PHP is not enabled to use MySQL.
« Reply #3 on: November 16, 2016, 09:20:43 pm »

I select the first one and it tells me the following: Could not create a MySQLi connection, please check the MySQLi details entered
Database error: No such file or directory.

This indicates that you have entered the database username and/or password incorrectly.
Logged

daani_lb

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Re: Problem with PHP is not enabled to use MySQL.
« Reply #4 on: November 17, 2016, 01:16:21 am »

This indicates that you have entered the database username and/or password incorrectly.

Thank you. It is already resolved. Insisting and changing the PHP version has left me.
Logged
Pages: [1]   Go Up
 

Page created in 0.014 seconds with 20 queries.