Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Albums and images not showing up after update  (Read 3177 times)

0 Members and 1 Guest are viewing this topic.

oracle271

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Albums and images not showing up after update
« on: March 21, 2016, 10:43:32 PM »

Over the weekend I installed the latest update but now my albums and images are not displaying.
The images are still in the Albums folder, so I assume something is pointed to the wrong place. I just have no idea where to start looking.
Logged

oracle271

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Albums and images not showing up after update
« Reply #1 on: March 21, 2016, 10:47:20 PM »

Sorry, forgot to mention that I was forced to set up a new MySQL database when I updated.
Logged

allvip

  • Global Moderator
  • Coppermine addict
  • *****
  • Country: 00
  • Offline Offline
  • Posts: 1290
Re: Albums and images not showing up after update
« Reply #2 on: March 21, 2016, 11:39:40 PM »

Sorry, forgot to mention that I was forced to set up a new MySQL database when I updated.

You exported the coppermine database then deleted it.
After that you create a new database and imported in to it the exported .sql file.
RIGHT?

Anyway post the gallery link please to figure out what is wrong?
If you don't want the gallery link posted on the forum I will edit your post to delete the link.
Logged

oracle271

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Albums and images not showing up after update
« Reply #3 on: March 22, 2016, 12:22:56 AM »

Sorry, I am just barely technical enough to get this up and running. That said, I didn't export or delete anything on purpose.

I copied the new files for the update, ran the update, and it took me through some setup steps that requested database info. It would not let me continue with the defaulted info about the database, so I thought my only choice was to create a new database using the tool on the screen.

Here is a link to the gallery - http://roswelloracle.com/coppermine/index.php

Thanks

Logged

allvip

  • Global Moderator
  • Coppermine addict
  • *****
  • Country: 00
  • Offline Offline
  • Posts: 1290
Re: Albums and images not showing up after update
« Reply #4 on: March 22, 2016, 12:51:29 AM »

No image to display even for Last uploads means no files in the database.
The database is empty.

Open include/config.inc.php (not config.inc.php.sample)

I belive you know the name, the username of the database and the password of your coppermine database.
Insert them. Maybe during update was created a new empty database and now the values in config are the value of the empty one.

Usually the username and password are the user and pass for your host CPanel.

If you don't remeber the database name go in the host CPanel and click PHPMyAdmin to see the coppermine database name or click MySql databases or something like that to see the name and user.

MySql databases you can also change the password for the coppermine database if you don't remember it.

Ask your host to do it if you don't know anything about this kind of things so you won't ruin all.
« Last Edit: March 22, 2016, 01:08:34 AM by allvip »
Logged

allvip

  • Global Moderator
  • Coppermine addict
  • *****
  • Country: 00
  • Offline Offline
  • Posts: 1290
Re: Albums and images not showing up after update
« Reply #5 on: March 22, 2016, 01:02:12 AM »

With phpMyAdmin you can see the database.
Click on it then click on cpg15x_pictures and see if there are any files.

If you can only see an empty database then hurry and ask your host to give you the database back up.

Always back the database and include/config.inc.php before updating.
Read here http://documentation.coppermine-gallery.net/en/upgrading.htm#upgrade_any
« Last Edit: March 22, 2016, 02:12:55 AM by allvip »
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15381
Re: Albums and images not showing up after update
« Reply #6 on: March 22, 2016, 10:26:14 AM »

Sorry, forgot to mention that I was forced to set up a new MySQL database when I updated.

You probably deleted include/config.inc.php while updating your gallery. Restore that file from your backup (or adjust the data manually) and everything should be working as before the upgrade.
Logged

oracle271

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Albums and images not showing up after update
« Reply #7 on: March 22, 2016, 08:00:56 PM »

It is working!
Thank you so much guys!
Logged

allvip

  • Global Moderator
  • Coppermine addict
  • *****
  • Country: 00
  • Offline Offline
  • Posts: 1290
Re: Albums and images not showing up after update
« Reply #8 on: March 22, 2016, 08:05:19 PM »

It is working!
Thank you so much guys!

Resolve your threads
If you have found an answer to your question, resolve your thread. Don't just post "I have found the answer", but tell others what you actually did to solve your issues. Posting a link to the page where you found the answer might help. Describing what you did might help as well. Finally, you can tag your thread as "solved" by clicking on the "Topic Solved" button on the bar at the left hand side at the bottom of your thread.
Logged
Pages: [1]   Go Up
 

Page created in 0.081 seconds with 21 queries.