Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Some browsers do not use the default language  (Read 2837 times)

0 Members and 1 Guest are viewing this topic.

tflaat

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 21
Some browsers do not use the default language
« on: September 29, 2015, 03:18:32 pm »

I have Norwegian as default language. I have noticed that when I use Internet Explorer11 on my job and home computer the language is switched to English. When i use Google Crome and Firefox on the same computer I get Norwegian language. Same with Safari on iOS devices.

I have tried to turn off Autodetect language, but it does not help. Any idea what to do? I want it to always use Norwegian.
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4483
    • Windsurf.me
Re: Some browsers do not use the default language
« Reply #1 on: September 29, 2015, 10:14:15 pm »

All that probably means is a cookie has been set on your IE. You can clear the cookie by adding ?lang=xxx To the end of your url. It is outlined in the docs but it is hard to paste a link from my phone so please search the docs for yourself.
« Last Edit: October 01, 2015, 08:58:02 pm by Phill Luckhurst »
Logged
It is a mistake to think you can solve any major problems just with potatoes.

tflaat

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 21
Re: Some browsers do not use the default language
« Reply #2 on: September 30, 2015, 01:57:45 pm »

Yes, ?lang=norwegian solved the problem :-)

Thank you!

However, that means that the autodetect language option does not work. Or it is not possible to switch it off.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15429
Re: Some browsers do not use the default language
« Reply #3 on: October 01, 2015, 04:45:49 pm »

Please try to delete Coppermine's "data" cookie in your Internet Explorer and try again. Alternatively, add
Code: [Select]
?lang=xxxto the end of your url, to reset any user defined language settings in your browser.
Logged

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 723
    • GMC Design Photo Gallery
Re: Some browsers do not use the default language
« Reply #4 on: October 02, 2015, 12:50:21 am »

Yes, ?lang=norwegian solved the problem :-)

Thank you!

However, that means that the autodetect language option does not work. Or it is not possible to switch it off.
A value in a valid cookie overrides the autodetect... Presumably because you previously requested a specific language...
A user with no language defined in cookie will auto detect if option is on, or use config set default language if option is off.
Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money
Pages: [1]   Go Up
 

Page created in 0.015 seconds with 21 queries.