Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Browser error after update to 1.5.30  (Read 3249 times)

0 Members and 1 Guest are viewing this topic.

cboudier

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 30
    • Album-Photos
Browser error after update to 1.5.30
« on: September 07, 2014, 01:34:45 AM »

Hi everybody,

just uploaded the content of the last package cpg1.5.30 (protecting my "albums" folder and the 2 files "any content.php" and "config.inc.php")
Now, when I try to launch my gallery ( http://cboudier.free.fr ), I get this message in Safari :

Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /mnt/136/sdb/b/a/cboudier/include/inspekt.php on line 117

I tried re-uploading everything, but still get the same error...

Any idea ?
Thanks
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15381
Re: Browser error after update to 1.5.30
« Reply #1 on: September 07, 2014, 01:30:02 PM »

You need to re-upload at least the file include/inspekt.php, as it got corrupted during upload. Maybe your downloaded Coppermine package is already corrupted, so I suggest to download a fresh copy before you re-upload the file(s) to your gallery.
Logged

cboudier

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 30
    • Album-Photos
Re: Browser error after update to 1.5.30
« Reply #2 on: September 07, 2014, 08:34:28 PM »

Thank you André,

I did download a complete new cpg1.5.30, and I changed my old FTP Client to the last FileZilla.
FileZilla reported no errors.

Unfortunately, I get the same error in the browser :-\

NB1 : I edit the file config.inc.php with TextEdit ; should it be the problem ?
NB2 : my previous cpg version was (1.5.24 I think)
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15381
Re: Browser error after update to 1.5.30
« Reply #3 on: September 08, 2014, 12:18:54 PM »

Do the files actually get uploaded and overwritten, or does FileZilla report some (permission) issues?
Logged

cboudier

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 30
    • Album-Photos
Re: Browser error after update to 1.5.30
« Reply #4 on: September 08, 2014, 07:13:01 PM »

The files are actually uploaded.
FileZilla report nothing except everything's fine
I just downloaded the file update.php to check : it's the 1.5.30 version.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15381
Re: Browser error after update to 1.5.30
« Reply #5 on: September 08, 2014, 08:23:46 PM »

Please download include/inspekt.php and attach it as zip file to your next reply. Additionally, attach the same file from the extracted Coppermine package on your local disk. Please use self-explaining file names.
Logged

cboudier

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 30
    • Album-Photos
Re: Browser error after update to 1.5.30
« Reply #6 on: September 08, 2014, 09:02:00 PM »

I'll do that... once I'll be sure the problem isn't on my internet provider side (Free) !
The FTP server disconnects regularly, this may be the cause...
(I have difficulties to upload everything in one "shot", I have do to it folder by folder)

Thank you for your help.
I will keep you informed.
Logged

cboudier

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 30
    • Album-Photos
Re: Browser error after update to 1.5.30
« Reply #7 on: September 19, 2014, 12:06:01 AM »

Hi, it's me again.
The FTP server seems OK now, but I get the same error message  :-\

Type
http://cboudier.free.fr
and you get
Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /mnt/136/sdb/b/a/cboudier/include/inspekt.php on line 117

Joined files include/inspekt.php from source forge and from my gallery

thanks
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15381
Re: Browser error after update to 1.5.30
« Reply #8 on: September 19, 2014, 09:18:49 AM »

Logged

cboudier

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 30
    • Album-Photos
[Solved] Re: Browser error after update to 1.5.30
« Reply #9 on: September 20, 2014, 12:07:27 AM »

Solved !
André, you're the best  :)

The php version was 4.4.3
I upgraded it to 5.1.3RC4-dev (the highest for Free.fr) and now it works

Thanks
Logged
Pages: [1]   Go Up
 

Page created in 0.07 seconds with 21 queries.