Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: 1 2 [3] 4 5   Go Down

Author Topic: MiniCMS plugin for cpg1.5.x  (Read 49192 times)

0 Members and 1 Guest are viewing this topic.

cattivix

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 114
Re: MiniCMS plugin for cpg1.5.x
« Reply #40 on: March 29, 2011, 09:56:19 am »

Hello everyone I have the verson 1.5.8 of coppermine I loaded the plungins the list, but it shows me with a symbol that indicates to me that did not meet the minimum requirements what can I do?  thanks
Logged

alanz01

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 20
  • http://www.alanzeleznikar.com/photography
    • Alan R Zeleznikar Photography
Re: MiniCMS plugin for cpg1.5.x
« Reply #41 on: March 29, 2011, 03:28:13 pm »

I would start with upgrading to 1.5.12. Maybe that will help you.
Logged
CPG 1.5.12 / Curve Theme / modified color scheme
Plugins (in order):
 - External Tracker 2.6
 - Social Sharing 1.5
 - First Visit Hint 1.0
 - Add Meta Description 1.5
 - SEF URLs
 - Image Preloader 1.4

cattivix

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 114
Re: MiniCMS plugin for cpg1.5.x
« Reply #42 on: March 29, 2011, 05:57:02 pm »

ok thanks
Logged

katedavis

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: MiniCMS plugin for cpg1.5.x
« Reply #43 on: June 29, 2011, 05:57:01 pm »

Hello,

I'm also being told that my installation doesn't meet the minimum requirements. I've spent hours going round and round in circles trying to fix it, but feel that I've actually made the situation worse.

I installed minicms this morning and discovered I had not removed the database tables from a previous installation and the plugin didn't appear to like this. When I tried to edit cms I got the following error Fatal error: Cannot redeclare cpggetmicrotime

I deleted the database tables, reinstalled the plugin and got a list of actions that suggested the site was struggling to set up the database (possibly because it wasn't compatible with my coppemine installation). I discovered there was a newer version of the plugin 2.1 and hoped this would fix the error, but after installing I started getting the minimum requirement message.

The only suggestion I've found is too install the latest version of coppermine. I was already running that, but reinstalled it anyway just to make sure nothing was wrong, but no change.

I'm sure I'm missing something very simple, but I've run out of my own suggestions, so would appreciate any help available.

My site is www.darktea.co.uk and the debug mode is currently on in case it is useful.

Thank you for your help.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15396
Re: MiniCMS plugin for cpg1.5.x
« Reply #44 on: June 30, 2011, 02:14:38 pm »

Works as expected in my testbed. Please check configuration.php, the line
Code: [Select]
$plugin_cpg_version = array('min' => '1.5.10');defines the minimum version requirement.
Logged

katedavis

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: MiniCMS plugin for cpg1.5.x
« Reply #45 on: June 30, 2011, 11:06:59 pm »

Thank you Αndré, I finally got there.

The code in configuration.php was wrong (see below) so I updated it with your code.

Code: [Select]
$plugin_cpg_version = array('min' => '1.4', 'max' => '1.4.99');
However, I still had a problem when I tried to install the plugin and got messages such as "Can't DROP 'pos'; check that column/key exists". After spending time going round and round again, I finally solved it by deleting the minicms files and the database tables and then reinstalling the minicms files.

Thank you again for your help, it was certainly the key in solving my problem.
Logged

KchoPrro

  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 202
    • Adolfo Ventas - Naturaleza Andaluza
Re: MiniCMS plugin for cpg1.5.x
« Reply #46 on: August 18, 2011, 08:53:43 pm »

Installed, works perfectly.

I upload the file to the Spanish language. Thank you very much!
Logged

KchoPrro

  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 202
    • Adolfo Ventas - Naturaleza Andaluza
Re: MiniCMS plugin for cpg1.5.x
« Reply #47 on: August 24, 2011, 06:34:11 pm »

VEGA, please try what happens if you set
Code: [Select]
FCKConfig.HtmlEncodeOutput = true ;to
Code: [Select]
FCKConfig.HtmlEncodeOutput = false ;in plugins > minicms > fckeditor > fckconfig.js

Clear your browser cache to ensure that the changes will be taken into account.

I had the same problem.

The two opened galleries in the same browser, firefox 6

The installation in the gallery without the problem was a new installation.
The gallery that had the problem was an upgrade from CPG 1.4.27

In the gallery that had the problem I followed your recommendation and the problem was solved.

thanks

KchoPrro
Logged

peterb

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: MiniCMS plugin for cpg1.5.x
« Reply #48 on: May 05, 2012, 10:01:18 pm »

Does MiniCMS work in latest coppermine (1.5.20)?

Thanks
Logged

peterb

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: MiniCMS plugin for cpg1.5.x
« Reply #49 on: May 05, 2012, 10:24:10 pm »

Okay, I figured it out.  In the sql file "TYPE" MUST be changed to "ENGINE" and then it will install correctly.  Maybe this will help someone else out.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15396
Re: MiniCMS plugin for cpg1.5.x
« Reply #50 on: May 09, 2012, 10:39:28 am »

In the sql file "TYPE" MUST be changed to "ENGINE"
Version 2.2 (attached to initial post) fixes that issue.
Logged

Tankertom

  • Contributor
  • Coppermine regular visitor
  • ***
  • Offline Offline
  • Posts: 73
Re: MiniCMS plugin for cpg1.5.x
« Reply #51 on: August 06, 2012, 10:10:29 am »

Hello,

how it can be set up that works well in MiniCMS PW protected folders?

VG TT
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15396
Re: MiniCMS plugin for cpg1.5.x
« Reply #52 on: August 06, 2012, 10:30:51 am »

I assume your gallery has a password protection on web server level? What exactly doesn't work?
Logged

sharpo

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 173
Re: MiniCMS plugin for cpg1.5.x
« Reply #53 on: December 02, 2012, 06:17:36 pm »

I noticed yesterday that the text box for MiniCMS was not displaying correctly when adding or editing text. It only happened with Firefox, not with Internet Explorer. I was gathering "evidence" as an example, and when I checked to see the version of Firefox I was using, it said a new version was available - which I downloaded, and the problem has now gone.

Seems problem was with Firefox 17.0 as the version I now have is 17.0.1

This what it looked like:-
<p>All recent updates are listed in my <a href="http://www.sharpos-world.co.uk/blog/">blog</a>. Since 2011, <a href="http://my.vidahost.com/aff.php?aff=744"><input type="image" align="absBottom" longdesc="undefined" alt="Vidahost.com image" src="http://www.vidahost.com/images/ab/80by15a.jpg" /></a> has been my host and the images are loading much faster. For 10% discount on hosting, use code:- <span style="font-size: larger;"><strong>vh-10</strong></span></p>

and now showing correctly:-
"All recent updates are listed in my blog. Since 2011, has been my host and the images are loading much faster. For 10% discount on hosting, use code:- vh-10"

http://www.sharpos-world.co.uk/cpg/

So if anybody else has a similar problem, check your Firefox version. Hope this may help somebody, as I was searching for answers yesterday but found nothing.
Logged
Sharpo (not an expert, just a Coppermine user)

pasenger

  • Coppermine newbie
  • Country: pl
  • Offline Offline
  • Gender: Male
  • Posts: 10
Re: MiniCMS plugin for cpg1.5.x
« Reply #54 on: March 29, 2013, 08:24:47 pm »

After uploading my plugin displays this message:

"Fatal Error

An error occurred while processing database ..

While executing query "SELECT * FROM WHERE conid cms = '0 'AND type = '0' ORDER BY cpos' in plugins / minicms / codebase.php on line 92

mySQL error: Table 'natorze1.cms' does not exist



File: / autoinstalator / coppermine / include / functions.inc.php - Line: 272"

Where there may be a problem, cpg version 1.5.22 ??
Logged

pasenger

  • Coppermine newbie
  • Country: pl
  • Offline Offline
  • Gender: Male
  • Posts: 10
Re: MiniCMS plugin for cpg1.5.x
« Reply #55 on: April 04, 2013, 08:53:07 am »

Problem solved.
Plugin in my database "sql" failed to create table "cms". So for this purpose I used cpg new installation on a test server, there minicms plugin installed and exported tables "cms", which is then imported the old database to the "sql".

There remains another problem, the plugin does not work in the search menu and I would write instructions for searching.
Logged

Russ_

  • Coppermine regular visitor
  • **
  • Country: nz
  • Offline Offline
  • Posts: 57
Re: MiniCMS plugin for cpg1.5.x
« Reply #56 on: April 05, 2013, 12:26:21 am »

I get the same error as pasenger above after installation (CPG1.5.20):

Quote
Critical error

There was an error while processing a database query.

While executing query 'SELECT * FROM cpg15x_cms WHERE conid='0' AND type='0' ORDER BY cpos' in plugins\minicms\codebase.php on line 92 mySQL error: Table 'coppermine_a.cpg15x_cms' doesn't exist


File: C:\Inetpub\vhosts\chainsawphotos.co.nz\httpdocs\gallery\include\functions.inc.php - Line: 270

Unfortunately I do not know enough to follow his method for solving this.

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15396
Re: MiniCMS plugin for cpg1.5.x
« Reply #57 on: April 09, 2013, 12:07:34 pm »

the plugin does not work in the search menu and I would write instructions for searching.
As a quick fix I suggest to edit the file search.php. I don't know when I can have a closer look at that issue.
Logged

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 723
    • GMC Design Photo Gallery
Re: MiniCMS plugin for cpg1.5.x
« Reply #58 on: December 24, 2013, 03:53:34 pm »

Certainly the easiest way to use MiniCMS is to create/edit content on the desired dispaly page, but in re-organizing a gallery, I had the need to 'move' MiniCMS content from the home/index page to a newly created category...
Editing the content on the index page - changing the content number to match the new category number - and submitting the update resulted in the content number being reset to 0 (display on index page...) I found this post previously in this thread that appeared to be same issue:
 
It goes off from everywhere when I put it under Cat, Section or Thumb Type with Content 0, and when I put it under Img Type it shows on all the pages. I tried changing value of Content but it loops back to 0. I did delete all the text contents I had before and created new one, but didn't help.   ???

In reviewing minicms/cms_edit.php, the code retrieves both type and conid (content number) from the input variables, but never passed the conid in the UPDATE statement.
Changing (line 63 of version 2.2 in my case):
Code: [Select]
$query = "UPDATE {$CONFIG['TABLE_CMS']} SET title = '$title', content = '$content', type = '{$MINICMS['type']}' WHERE ID = '$id'";to:
Code: [Select]
$query = "UPDATE {$CONFIG['TABLE_CMS']} SET title = '$title', content = '$content', type = '{$MINICMS['type']}', conid = '{$MINICMS['conid']}' WHERE ID = '$id'";resolved the issue.

Hopefully will help someone else with same issue... (or can be included as an update...)
Thanks!
Greg
Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15396
Re: MiniCMS plugin for cpg1.5.x
« Reply #59 on: December 27, 2013, 12:21:14 pm »

Before I commit this change, is conid always submitted by the form (i.e. is $MINICMS['conid'] always populated)?
Logged
Pages: 1 2 [3] 4 5   Go Up
 

Page created in 0.025 seconds with 21 queries.