Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: bride with active directory  (Read 8776 times)

0 Members and 1 Guest are viewing this topic.

steakfries

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
bride with active directory
« on: October 01, 2010, 05:26:59 pm »

Moved a copy of our production 1.45 version to a test server, then upgraded test instance to 1.58. Most seems to work fine, except for the login. After login, I get only a blank screen.  If I replace include\init.inc.php with the 1.45 version, it seems to work fine, except of course versioncheck is wrong. I'm using bridge\ad.inc.php for authenticating off active directory. This install was before my time, so I'm not sure where ad.inc.php came from. Either someone here wrote it or found it. So, if they found it, do I need to find/update ad.inc.php. Or, should I not worry so much and just use the 1.45 version of init.inc.php? Or, maybe I should step up through the versions to find the latest version that doesn't break the bridge? Using the old init.inc, bridgemanager checks out fine. I've since disabled bridemanager while using new init.inc and get a fatal error you can see at:

http://wwwnew.oneonta.edu/imagegallery
tester/test
Thank you.
Logged

Nibbler

  • Guest
Re: bride with active directory
« Reply #1 on: October 01, 2010, 06:53:16 pm »

ad.inc.php probably needs updating for 1.5. I have no knowledge of active directory but if you post the file here maybe someone can help.
Logged

steakfries

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: bride with active directory
« Reply #2 on: October 01, 2010, 07:03:26 pm »

thank you. attached ad.inc.php
Logged

Nibbler

  • Guest
Re: bride with active directory
« Reply #3 on: October 01, 2010, 07:05:56 pm »

There's another file referenced in there - include/adLDAP.php. Please attach that too.
Logged

steakfries

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: bride with active directory
« Reply #4 on: October 01, 2010, 07:25:23 pm »

thanks again. adLdap attached.
Logged

LnQ

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38
Re: bride with active directory
« Reply #5 on: December 17, 2010, 10:40:51 am »

has something happende here? are we able to bridge cpg1.5 with AD? or
Logged

ewise

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: bride with active directory
« Reply #6 on: March 18, 2014, 05:40:29 pm »

Works with Coppermine 1.5?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15363
Re: bride with active directory
« Reply #7 on: March 19, 2014, 09:07:44 am »

Regarding the first post it doesn't seem to work with cpg1.5.x. Please give it a try if you want to make sure.
Logged

ewise

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: bride with active directory
« Reply #8 on: March 19, 2014, 01:07:10 pm »

Does not work with 1.5.x. :/
Logged
Pages: [1]   Go Up
 

Page created in 0.013 seconds with 21 queries.