Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: "Upload Error: 404" when using Flash-driven uploader  (Read 9429 times)

0 Members and 1 Guest are viewing this topic.

Jon F

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
"Upload Error: 404" when using Flash-driven uploader
« on: July 19, 2010, 09:56:55 pm »

Hi folks,

I've been battling this problem for days now. I've tried different MySQL versions, erased and uploaded, started from scratch - everything I could do in my best knowledge. I've read the documents and my error doesn't appear to be listed, so I'm using this forum as a last result. Here is the problem -

Whenever I use the flash uploader, I get a "Upload Error: 404" despite the file sizes - however, if I use the simple uploader, everything works as planned. I've checked permissions according to the installation document, and I've tried multiple computers in my network.

Here's the account information -
User: test
Password: test

Here's the link to the gallery -
http://insideuniversal.net/Gallery/index.php

I've attached a picture for you to reference.

Thanks again,
Jon
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15527
Re: "Upload Error: 404" when using Flash-driven uploader
« Reply #1 on: July 20, 2010, 11:03:09 am »

Hm. That's strange. Do you have access to the tmp_upload folder of your web server? Or can you please check the content of the albums/ dir, if the files are there, regardless of the error message?
Logged

Jon F

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: "Upload Error: 404" when using Flash-driven uploader
« Reply #2 on: July 20, 2010, 11:17:15 am »

Hello Αndré, I appreciate your assistance.

Quote
Do you have access to the tmp_upload folder of your web server?

This is a shared hosting account, so I'm assuming no.

Quote
Or can you please check the content of the albums/ dir, if the files are there, regardless of the error message?

Files uploaded using the Flash uploaded do not appear in the directory though those that are uploaded using the classic uploader are.

Thanks again,
Jon
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15527
Re: "Upload Error: 404" when using Flash-driven uploader
« Reply #3 on: July 20, 2010, 11:23:07 am »

Sorry, but I cannot help you any further. I never had that issue, but it comes somehow from your web server. I assume there's an issue with the configuration of your web server. But I'm no expert in this field.
Logged

Jon F

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: "Upload Error: 404" when using Flash-driven uploader
« Reply #4 on: July 20, 2010, 11:26:39 am »

Oh boy, well, thanks for your attempt.

I'm really not sure what to do at this point. Your software was easily the most usable in terms of what I had been looking for.

Thanks again though.

Jon
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15527
Re: "Upload Error: 404" when using Flash-driven uploader
« Reply #5 on: July 20, 2010, 11:38:13 am »

You can try to use the JUpload plugin as an alternative batch upload interface for your users. You, as admin, can always use the FTP + batch add feature.
Logged

Jon F

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: "Upload Error: 404" when using Flash-driven uploader
« Reply #6 on: July 20, 2010, 11:42:46 am »

Hi Andre,

I'll guess I'll try that as an alternative. For what it's worth, I had a feeling that the main website (which is running Drupal) had an affect with its .htaccess file during uploads. I removed the file and got a 403 error instead.

Jon
Logged

Jon F

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: "Upload Error: 404" when using Flash-driven uploader
« Reply #7 on: July 20, 2010, 11:48:47 am »

Sorry to post again, but should I mark this as resolved? I've found an alternative but I'm still open to any solution.

Jon
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15527
Re: "Upload Error: 404" when using Flash-driven uploader
« Reply #8 on: July 20, 2010, 11:58:26 am »

Do you have any htaccess files in your Coppermine directory or sub-directories? Maybe that's the culprit.


should I mark this as resolved? I've found an alternative
Please describe your alternative to help others with the same issue. Then you can mark it as solved. Maybe someone will post here later who has a real solution for that issue.
Logged

Jon F

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: "Upload Error: 404" when using Flash-driven uploader
« Reply #9 on: July 20, 2010, 12:03:42 pm »

Hi Andre,

No .htaccess file in my gallery directory.

Quote
Please describe your alternative to help others with the same issue.

I was actually referring to your batch suggestion which I'll try in a few minutes. If someone needs help with that, I think there's a support document for that.

Jon
Logged

djcascao

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: "Upload Error: 404" when using Flash-driven uploader
« Reply #10 on: July 31, 2010, 12:32:15 am »

I'm facing the same problem.
I already take a look onto my /album folder and there is no problem there.
this is the message that appears to me:

SWF DEBUG: SWFUpload Init Complete
SWF DEBUG:
SWF DEBUG: ----- SWF DEBUG OUTPUT ----
SWF DEBUG: Build Number:           SWFUPLOAD 2.2.0
SWF DEBUG: movieName:              SWFUpload_0
SWF DEBUG: Upload URL:             /upload.php
SWF DEBUG: File Types String:      *.*
SWF DEBUG: Parsed File Types:     
SWF DEBUG: HTTP Success:           0
SWF DEBUG: File Types Description: All Files (*.*)
SWF DEBUG: File Size Limit:        5120000 bytes
SWF DEBUG: File Upload Limit:      0
SWF DEBUG: File Queue Limit:       0
SWF DEBUG: Post Params:
SWF DEBUG:                         process=1
SWF DEBUG:                         user=YToyOntzOjc6InVzZXJfaWQiO3M6MToiMSI7czo5OiJwYXNzX2hhc2giO3M6MzI6IjY2OTY4MzFhMmEzNWI0YmI0ZTk0MWZlYzQ5YjNhMWZlIjt9
SWF DEBUG: ----- END SWF DEBUG OUTPUT ----
SWF DEBUG:
SWF DEBUG: Event: fileDialogStart : Browsing files. Multi Select. Allowed file types: *.*
SWF DEBUG: Select Handler: Received the files selected from the dialog. Processing the file list...
SWF DEBUG: Event: fileQueued : File ID: SWFUpload_0_0
SWF DEBUG: Event: fileDialogComplete : Finished processing selected files. Files selected: 1. Files Queued: 1
SWF DEBUG: StartUpload: First file in queue
SWF DEBUG: Event: uploadStart : File ID: SWFUpload_0_0
SWF DEBUG: Global Post Item: process=1
SWF DEBUG: Global Post Item: album=2
SWF DEBUG: Global Post Item: user=YToyOntzOjc6InVzZXJfaWQiO3M6MToiMSI7czo5OiJwYXNzX2hhc2giO3M6MzI6IjY2OTY4MzFhMmEzNWI0YmI0ZTk0MWZlYzQ5YjNhMWZlIjt9
SWF DEBUG: ReturnUploadStart(): File accepted by startUpload event and readied for upload.  Starting upload to /upload.php for File ID: SWFUpload_0_0
SWF DEBUG: Event: uploadProgress (OPEN): File ID: SWFUpload_0_0
SWF DEBUG: Event: uploadProgress: File ID: SWFUpload_0_0. Bytes: 44620. Total: 44620
SWF DEBUG: Event: uploadError: HTTP ERROR : File ID: SWFUpload_0_0. HTTP Status: 406.
SWF DEBUG: Event: uploadComplete : Upload cycle complete.
Error Code: HTTP Error, File name: 03-12-06_1345.jpg, Message: 406
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15527
Re: "Upload Error: 404" when using Flash-driven uploader
« Reply #11 on: August 16, 2010, 02:41:05 pm »

HTTP Status: 406.
That's not the same issue. Please start a new thread.
Logged
Pages: [1]   Go Up
 

Page created in 0.033 seconds with 20 queries.