Advanced search  


cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.

Pages: 1 2 [3] 4 5 6 7 ... 10
 on: March 11, 2018, 05:14:21 pm 
Started by ron4mac - Last post by ron4mac
Run the installer script again but choose the bottom (red) version to install. You'll pick up a change that corrects this (along with some other bug fixes).

But also please note that the recommended version to upgrade from in this way was mentioned as 1.5.32+.

 on: March 11, 2018, 04:58:34 pm 
Started by ron4mac - Last post by anglefire
I've run this script on  my 1.5.20 install - and it says everything is installed and the option to complete install is displayed.

But running that and I get this error:

Fatal error: Uncaught Error: Call to undefined function cpg_db__fetch_assoc() in /var/www/disco3club/public_html/gallery/bridge/ Stack trace: #0 /var/www/disco3club/public_html/gallery/bridge/ cpg_udb->get_groups(Array) #1 /var/www/disco3club/public_html/gallery/bridge/ core_udb->load_user_data(Array) #2 /var/www/disco3club/public_html/gallery/include/ core_udb->authenticate() #3 /var/www/disco3club/public_html/gallery/update.php(26): include_once('/var/www/disco3...') #4 {main} thrown in /var/www/disco3club/public_html/gallery/bridge/ on line 167

Any ideas?


 on: March 11, 2018, 03:59:23 pm 
Started by anglefire - Last post by anglefire

We have recently upgraded our phpBB board to 3.2.2 and also changed server which is running php7 - so the gallery has ceased to function!

So I'd like to upgrade it to the latest 1.6 which supports php7 - but would like some advice on the best way of doing it.

Now, the other way that is open to us is to upgrade the old server as that is still up, but not in use, and transfer the files over once upgraded (I assume the DB's are upgraded in some way?)

I have read some of the available documents, but unless I missed it (likely!) then I'm not sure the best way to upgrade - and I did see that 1.6 is lacking some docs hence not a release candidate yet!

 on: March 11, 2018, 02:46:54 pm 
Started by Αndré - Last post by Stulle
Hi everyone,

I finally got around to upgrade to CPG1.6.03 and - as would be expected - it crashed this nice plugin. All it took to get it working again was the replacement of two instances of mysql_result (admin.php and normal.php). I attached an updated version for your convenience.

Please note, as far as I can tell, this works flawlessly with the mobile_light theme so no need to change anything there... I guess.


 on: March 11, 2018, 01:41:38 pm 
Started by papukaija - Last post by theqe2story
It doesn't let me edit my previous post... I meant to say I installed it onto 1.5.46 (the current version of coppermine) with no issue.

 on: March 11, 2018, 01:38:44 pm 
Started by papukaija - Last post by theqe2story

I just installed this and nothing has come up in the config screen?  Where do I config it for Google Analytics?

Thanks in advance

Kriss :)

Click on Config > Plugin Manager, then click the little grey cog within the section for this plugin.

I've just installed this plugin onto a 1.5.26 gallery with no problems, thank you!

 on: March 09, 2018, 04:38:22 pm 
Started by Finswimmer - Last post by ron4mac
It would seem that include/archive.php is not being included.

At the top of zip.php in the plugin, change:
Code: [Select]
Code: [Select]
require_once 'include/archive.php';
That may reveal more of the situation.

 on: March 09, 2018, 02:35:50 pm 
Started by lurkalot - Last post by gmc

I'll try to get my sandbox up and running with 2.0.0 this weekend and see what I can find...
Can't really suggest a change just from that result.


 on: March 09, 2018, 01:53:33 pm 
Started by Finswimmer - Last post by FrA1l3
Thank you for the reply!

Before publishing my message yesterday I made sure that my flags are still correct, and PHP has enabled the ZIP extension in Cpanel.
I have also tried with PHP 7.0, 7.1 and 7.2 versions (cpanel flags.png)

As you can see in the image, the original plugin gives me this error (error.png)

So I went to review the documentation of the function:

And I see that there is the ZipArchive () method, which is what I've been testing. But it does not work either.
In any case, I have reinstalled the original plugin, but the same error of the first capture still comes out

Thanks in advance!

 on: March 09, 2018, 02:55:37 am 
Started by Finswimmer - Last post by ron4mac
The original plugin works with CPG 1.6.03 without problem.

The only change in your file that I see could be an issue is using ZipArchive(). Your new PHP version (7) may not have the ZIpArchive extension enabled.

Pages: 1 2 [3] 4 5 6 7 ... 10

Page created in 0.016 seconds with 17 queries.