forum.coppermine-gallery.net

Support => cpg1.6.x Support => cpg1.6 upgrading => Topic started by: nowordneeded on July 08, 2018, 10:34:45 pm

Title: Critical Error After Upgrading
Post by: nowordneeded on July 08, 2018, 10:34:45 pm
The gallery I'm needing help on is http://stephennichols.org/gallery running the current stable version of 1.6.03.

The issue I'm having is that after deleting all but the albums folder, one theme in the themes folder, and the include/config.inc.php file, then uploading all files and folders excluding the ones aformentioned and running the updater, I received a Critical Error message.

Thanks in advance.
Title: Re: Critical Error After Upgrading
Post by: nowordneeded on July 08, 2018, 10:50:11 pm
I solved it. When I had to move the site from one host to another for some reason the onlinestats plugin wouldn't work. I uploaded it with this new install and it created the error. I deleted the plugin and now the gallery is back.

Sorry for wasting the post.
Title: Re: Critical Error After Upgrading
Post by: ron4mac on July 09, 2018, 02:58:22 am
When upgrading a CPG site to 1.6.x make sure your plugins are compatible. Check here (http://forum.coppermine-gallery.net/index.php/board,143.0.html) or here (https://github.com/coppermine-gallery/cpg1.6.x-plugins) for plugin replacements that are compatible with CPG 1.6.x and PHP 7.
Title: Re: Critical Error After Upgrading
Post by: Phill Luckhurst on July 09, 2018, 09:55:59 pm
Thank you for returning and resolving your thread.
Title: Re: Critical Error After Upgrading
Post by: nowordneeded on July 09, 2018, 10:12:21 pm
You're welcome. I thought since I resolved it I'd let you know what it was and what I did.