forum.coppermine-gallery.net

Support => cpg1.4 plugins => cpg1.4.x Support => Older/other versions => cpg1.4 plugin contributions => Topic started by: thenetimp on January 18, 2006, 07:26:14 am

Title: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: thenetimp on January 18, 2006, 07:26:14 am
Digibug Pro Photo Commerce allows you to sell photos and generate profits from your Coppermine Photo Gallery.  The service is free* and set-up takes about 10 minutes.

Key features of Digibug 

- you set the prices and choose the products (over 110 products to choose from)
- low wholesale prices allow you to control the profit you receive from images ordered off your Coppermine site
- you control the branding of the shopping cart, email notifications and shipping docs
- we pay you monthly (checks in the U.S., PayPal outside U.S.). 
- we ship to the world (from the U.S. currently)
- multiple price lists are supported (different pricing for different albums, etc.). 

Included in this post is the plug-in for CPG 1.4  Installation and configuration directions are in the README.txt in the docs directory of the included tar file.  If you have questions ask them here in this thread and I will respond withing a reasonable amount of time.  The plugin is released under the GPL.  Contributions, suggestions are welcome.

For more details on the Digibug API, see http://www.digibug.com/digibugapi/.  To set up your free Digibug account, or to learn more, please visit. http://www.digibug.com.

* there is no charge to create an account on Digibug, though we do deduct a small processing fee from the profits you generate on each order (see Digibug.com for more details).
Title: Re: ANNOUNCING: Digibug4CPG for Photo Prints and Photo Gift Items. public beta v0.3
Post by: TranzNDance on January 18, 2006, 07:29:08 am
Thank you for the contribution. :) Is there a particular reason why you ask people to ask for help via PM? We prefer people ask questions in the forums so that anyone can benefit from the Q&A.

Thanks.
Title: Re: ANNOUNCING: Digibug4CPG for Photo Prints and Photo Gift Items. public beta v0.3
Post by: thenetimp on January 18, 2006, 07:47:50 am
Thank you for the contribution. :) Is there a particular reason why you ask people to ask for help via PM? We prefer people ask questions in the forums so that anyone can benefit from the Q&A.

Thanks.

Only because it would notify me of questions, but you are right the forums are the right place for it.  I have edited my initial message, and will check daily for questions.

Title: Re: ANNOUNCING: Digibug4CPG for Photo Prints and Photo Gift Items. public beta v
Post by: TranzNDance on January 18, 2006, 08:03:55 am
You can click the NOTIFY button for this thread so that you will receive notifications when there are new messages. :) Oh, I just read your correction. People shouldn't post questions anywhere else in the forums so you don't have to check the forums aside from this thread.
Title: Re: ANNOUNCING: Digibug4CPG for Photo Prints and Photo Gift Items. public beta v
Post by: thenetimp on January 18, 2006, 08:20:03 am
You can click the NOTIFY button for this thread so that you will receive notifications when there are new messages. :) Oh, I just read your correction. People shouldn't post questions anywhere else in the forums so you don't have to check the forums aside from this thread.

OK, edited and Notified checked.  I am now ready to answer questions. :-D
Title: .3.1 beta. Major Bug Fixes.
Post by: thenetimp on January 19, 2006, 10:47:32 pm
There were a couple bugs preset in the .3.1 version.  We had a form name change that broke the form that submited to  orders to Digibug  this prevented your company id for getting credit for the order.  If you have installed version .3 beta you need to update.  We have added some error correction on the server side that should prevent orders from going through with the .3 version.

.3 also did not work correctly in subdirectorys, so if your gallery was installed in /gallery off of your domain, it would not have worked at all.  This is now fixed and coppermine installations that are in a subdirectory can now use our plugin.

Sessions are required to use our plugin.  If auto_start session was not = 1 then the plugin failed to work.  We have added code to start sessions.  It should suppress errors regarding session starting if you have problems with this please let us know so we can work out a resolution.

The old file has been removed from the top post, and the new file has been uploaded.
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: desertcities on February 07, 2006, 07:14:05 am
I cannot seem to get this plugin to work. 

It installed correctly; setup my account at Digibug, and adjusted the:
$digibugCompanyId=452;
$digibugEventId=1190;

But does not work.  Why?

I do see the +/Cart under each thumbnail (why not in full size mode too?).  However, when you click on any thumbnail (using Rainy Day template) nothing happens except a browser error.  Also, under each thumbnail the +/Cart link is going to http://www.desertcities.net/galleries/index.php# which cannot be found.

http://www.desertcities.net/galleries (http://www.desertcities.net/galleries)

A cool idea.  Not many downloads here, I hope I'm not posting in wrong section.

Mark
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: thenetimp on February 07, 2006, 04:57:49 pm
Hrm....  Let me change my theme to this theme and see if I can solve the problem.   I will be addign a [+cart] to the full size page.  I just hadn't thought iof it at the time of initial release.  I'll get back to you with a solution to this.
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: thenetimp on February 07, 2006, 06:46:14 pm
I cannot seem to get this plugin to work. 

It installed correctly; setup my account at Digibug, and adjusted the:
$digibugCompanyId=452;
$digibugEventId=1190;

But does not work.  Why?

I do see the +/Cart under each thumbnail (why not in full size mode too?).  However, when you click on any thumbnail (using Rainy Day template) nothing happens except a browser error.  Also, under each thumbnail the +/Cart link is going to http://www.desertcities.net/galleries/index.php# which cannot be found.

http://www.desertcities.net/galleries (http://www.desertcities.net/galleries)

A cool idea.  Not many downloads here, I hope I'm not posting in wrong section.

Mark


Mark,

Did you edit any of the javascript or php code in the module?  I noticed the [ ] are missing from around the + Cart.  If you did then you may have broken some of the code.  I changed to the Rainy Day theme on my test site, and it worked fine by default.  Just trying to figure out what's different.

Thanks,
James
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: desertcities on February 07, 2006, 10:26:29 pm
Hi James,

No, I did not change any other code. 

In fact, I don't have any other plug-ins installed except for the Digibug Pro. 

Would it help if I PMed you my Coppermine Login info? 

I shall also try to uninstall and re-install too.  Maybe there was something wrong with my Rainy Day template already and I never knew about it?

Thank you very much James.

Mark
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: thenetimp on February 07, 2006, 10:31:56 pm
I cannot seem to get this plugin to work. 

It installed correctly; setup my account at Digibug, and adjusted the:
$digibugCompanyId=452;
$digibugEventId=1190;

But does not work.  Why?

http://www.desertcities.net/galleries (http://www.desertcities.net/galleries)


Hi Mark,

I found what I think is the problem.  Part of our plugin calls for a CSS file that we keep in the plugin directory.  When we call it it takes your gallery url that you have set in your site config and pre-appends it to the path where our CSS file is.   That URL is

http://desertcities.net/galleries/plugins/Digibug4CPG/includes/DigibugAPI.css (http://desertcities.net/galleries/plugins/Digibug4CPG/includes/DigibugAPI.css)

If you click on the above URL you will notice that your website redirects to a 404 error (ie the link below)

http://www.desertcities.netgalleries/plugins/Digibug4CPG/includes/DigibugAPI.css (http://www.desertcities.netgalleries/plugins/Digibug4CPG/includes/DigibugAPI.css)

You'll notice that the URL is broken.  There is no / between "net" and "galleries"  So you have some kind of redirect from desertcities.net to www.desertcities.net that does not include the trailing slash when it rewrites URLs and that is breaking our module.  To fix this, please modify your redirect to include trailing slash.

This should rectify your problem.

James
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: desertcities on February 08, 2006, 11:23:36 am
Hi Mark,

I found what I think is the problem.  Part of our plugin calls for a CSS file that we keep in the plugin directory.  When we call it it takes your gallery url that you have set in your site config and pre-appends it to the path where our CSS file is.   That URL is

http://desertcities.net/galleries/plugins/Digibug4CPG/includes/DigibugAPI.css (http://desertcities.net/galleries/plugins/Digibug4CPG/includes/DigibugAPI.css)

If you click on the above URL you will notice that your website redirects to a 404 error (ie the link below)

http://www.desertcities.netgalleries/plugins/Digibug4CPG/includes/DigibugAPI.css (http://www.desertcities.netgalleries/plugins/Digibug4CPG/includes/DigibugAPI.css)

You'll notice that the URL is broken.  There is no / between "net" and "galleries"  So you have some kind of redirect from desertcities.net to www.desertcities.net that does not include the trailing slash when it rewrites URLs and that is breaking our module.  To fix this, please modify your redirect to include trailing slash.

This should rectify your problem.

James

Hi James,

I corrected the redirect problem.  Thank you very much for pointing that out to me.  I have noticed the CSS is working now.

However, after clicking on any image I'm still not getting any action and nothing is being saved to the cart.

When I click on any photo I get the following: http://www.desertcities.net/galleries/index.php#

I hate to keep bugging you about this.  I would really like to see this program working as I have another site of my photography works.

Sincerely,

Mark
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: thenetimp on February 08, 2006, 04:02:21 pm
Hi James,

I corrected the redirect problem.  Thank you very much for pointing that out to me.  I have noticed the CSS is working now.

However, after clicking on any image I'm still not getting any action and nothing is being saved to the cart.

When I click on any photo I get the following: http://www.desertcities.net/galleries/index.php#

I hate to keep bugging you about this.  I would really like to see this program working as I have another site of my photography works.

Sincerely,

Mark

Hi Mark,

Ok, so after digging around, I found this.  I was in Firefox with the javascript console open looking for possible javascript errors and I got this error when I loaded your page.  "Error: uncaught exception: Permission denied to call method XMLHttpRequest.open".  I did a google search and found this error is cause by cross-domain scripting with XMLHttpRequest.  In your config for Coppermine under "General settings" --> "URL of your coppermine gallery folder (no 'index.php' or similar at the end)"  you have http://desertcities.net/galleries/ but your redirect sends it to http://www.desertcities.net/galleries/ which is where your site redirects too.  We pull from this config setting to set the path to our files so our XMLHttpRequests for our AJAX code can find the correct path to the files that return the needed XML for the plugin.  Part of the security for AJAX is to disallow "cross-domain" scripting, so we are making our calls from http://www.desertcities.net/galleries/ to http://desertcities.net/  causing the security error in the javascript.  So to resolve this the config should be set to what the final domain of the server really is which is " http://www.desertcities.net/galleries/".  If this is a problem we can try to find a work around.

James



Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: desertcities on February 08, 2006, 11:55:48 pm
Hi James,

I adjusted the config setting and added the www.  It seems to be working now.

Is there any way to make the text link 'x images in the cart' and 'check out' into the color white instead of the dark blue for this template?  Not sure where to change that code though.

Also, in the future will you have it so we could pick and chose which photo albums we might want to sell from and to place the link on the larger photos?  And, I gather a short description would be wise telling users they can buy the photo while viewing the thumbnail instead of guessing what the +/add cart button was for.

Thank you very much for your time.

Mark
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: thenetimp on February 09, 2006, 12:55:50 am
Hi James,

I adjusted the config setting and added the www.  It seems to be working now.

Is there any way to make the text link 'x images in the cart' and 'check out' into the color white instead of the dark blue for this template?  Not sure where to change that code though.

Also, in the future will you have it so we could pick and chose which photo albums we might want to sell from and to place the link on the larger photos?  And, I gather a short description would be wise telling users they can buy the photo while viewing the thumbnail instead of guessing what the +/add cart button was for.

Thank you very much for your time.

Mark

Hi Mark,

Glad to see that you were able to get it working. I just looked at the code and see that I hadn't defined ID's or classes for those.  I will do that  and try to add the button the the image page.  There are some limitations on what I can do, as I am limited to where filters are placed within the CPG code.  I am not sure if there is a filter that I can use for the image page, but there might be.  The filter hooks aren't really documented to well. Hopefully the CPG team are working on that.   Once I have Ids defined I'll post the new version here and then post instructions on where to edit the CSS.

James
Title: Digibug4CPG v0.3.2 beta.
Post by: thenetimp on February 09, 2006, 09:30:01 pm
Hi Everyone,

I have made a quick change to the Digibug4CPG plugin, to allow you to change the colors of the cart and checkout links so it can match your theme.  inside the includes directory in the Digibug4CPG plugin directory is a DigibugAPI.css file.  It contains 2 new class definitions digibug-sub-menu and digibug-sub-menu:hover  using standard CSS coding you can change the behavior of these 2 hyperlinks.

There have been many requests for having the add/remove button added to the image page.  This functionality will be in the next release 0.3.3 which will be out before the end of the month.

James
Title: Vacation: Feb 10th through Feb 21 2005
Post by: thenetimp on February 09, 2006, 09:31:21 pm
I will be away on vacation from the 10th to the 21st.  If you send me a PM or a question to the board, I will respond when I return.

Thanks, and have a great week.

James
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: desertcities on February 10, 2006, 06:56:43 am
James,

I modified the css submenus changing link color and roll over effect and now when I go to add an item to my cart, it does not add.  Not sure what's going on.

I will uninstall this plugin until you get back.

Mark
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: Tsumik on February 16, 2006, 08:29:11 pm
I have installed this plug in and it seems to work fine in the modified hardwire theme I'm currently using. I also have it setup with a IPB Forum bridge. I do have a couple questions:

1) Will the additional button be placed on the Full size image or the secondary image that's larger then the thumbnail? I have it setup where the user can only see the thumbnail and the intermediate image not the full size image.

2) Which image is used for printing? The original full size image or the itermediate image which shows after clicking the thumbnail?

3) Any chance we'll be able to move the cart counter and checkout link to a different spot by use of a tag or possibly even an admin tool?

4) I currently have the option that one can not view an image unless they are signed up as a registared user but can view thumbnails. Any chance we can have the plugin not active if the user is nott signed in as to prevent guest users from purchasing prints.

5) Do you work for digibug or just someone who decided to create an API for coppermine? (just wondering so I know if I should ask you or them questions about billing, customer service, returns etc)

6) Not really a question but I'm looking forward to the remove photo option in the cart as it's a pretty key piece I'd like to have before allowing my gallery out to the public again.

Hope to hear back from you soon as I've got a couple thousand people waiting for me to put the gallery back online! =)

Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: thenetimp on February 22, 2006, 04:49:39 am
I have installed this plug in and it seems to work fine in the modified hardwire theme I'm currently using. I also have it setup with a IPB Forum bridge. I do have a couple questions:

1.) It will be on the secondary image, and thumbnail, not the full res image.

2) The full resollution image is sent.

3)  I plan on revisiting these links, as it's not very customizable right now.

4)  I can see about adding this as a config option, I see no reason why it can't be added.

5) I work for Digibug.  I do not always have the answer for billing, customers service, or returns, those questions are best sent to our customer service department.  I am relatively sure it's  customerservice@digibug.com  If not yell at me, and I'll get the right address.

6) I will discuss this with people tomorrow, I don't think we had planned for a remove photo option in the cart as all you need to do is zero out the product and it doesn't get ordered, but I can see why you may want it.

Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: thenetimp on March 20, 2006, 08:05:41 pm
Digibug now has its new corporate website set up with our own forums.  You can continue to ask questions about the coppermine plugin here, but you can also ask them on our forums.  We do ask that questions about Digibug, our products, and those questions not relating to the coppermine pluggin be asked in our forums as they are not related to coppermine, and those in our community who do not use coppermine may also have interests in the answers.

I am working on a couple updates to the coppermine pluggin.  I hope to put those out at the end of the week.

http://www.digibug.com/

James
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: ayoungblood on March 31, 2006, 01:45:29 pm
Hello,
I have installed this plugin and it does not work. I click on the little cart icon under the thumbnails and nothing happens. Nothing is added to the cart.

I did set up a digibug account and an event and put the id's in the config file. Tried a couple of themes.

Any ideas?

Alan
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: thenetimp on March 31, 2006, 04:38:09 pm
Hello,
I have installed this plugin and it does not work. I click on the little cart icon under the thumbnails and nothing happens. Nothing is added to the cart.

I did set up a digibug account and an event and put the id's in the config file. Tried a couple of themes.

Any ideas?

Alan

Hi Alan,

Do you have sessions enabled in your php configuration?  Our plugin requires php sessions, and if they are not turned on this will happen, also can you provide a URL so we can see the broken functionality?

James
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: ayoungblood on March 31, 2006, 08:19:22 pm
Hi James,

The URL is http://www.cyberpup.com/gallery

How would I enable sessions?

Alan
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: thenetimp on March 31, 2006, 08:48:10 pm
Hi James,

The URL is http://www.cyberpup.com/gallery

How would I enable sessions?

Alan

Hi Alan,

I actually see what your problem is.  Our plugin works using AJAX.  One of the security features of AJAX is it doesn't allow cross-site execution.  The way you have Coppermine set up makes it seem like you are doing cross-site execution.

Here's the example.
You coppermine gallery is set up to think the site is http://cyberpup.com/gallery/  The URL you are going too is http://www.cyberpup.com/gallery/

To javascript it sees cyberpupgallery.com as being a different site as www.cyberpup.com because of the full host name.

If you visit the first URL you'll notice that the plugin is working just fine, but when you go to the second one, it doesn't that's because we feed off of configuration information inside of coppermine to build the URLs that we use to identify where the plugin's files are.

My recommendation to fix this is as follows.  I would set http://www.cypberpup.com/gallery/ to redirect to http://cyberpup.com/gallery/  That way  it always works off the config information inside of gallery.

Let me know if you have any questions.


Title: Digibug Showcase of User Galleries
Post by: jtreadway on April 14, 2006, 04:54:17 pm
All users of the Digibug plugin for Coppermine are encouraged to add their sites to our user Showcase.  Post your site information, including URL, information on your site, etc. to our forums at http://corp.digibug.com/component/option,com_smf/Itemid,77/board,13.0.

After we confirm that it is valid we will put it on our main site Showcase page at http://corp.digibug.com/content/view/53/91/

Thanks!
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: ayoungblood on April 17, 2006, 12:26:58 am
Hi Gang,

The api was working using the fix mentioned above but now it is not. I can't add things to the cart.

Since the last post however, I upgraded to 1.4.4 of Coppermine.

Any ideas?

The gallery url is http://cyberpup.com/gallery/

Thanks,

Alan
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: tibu on May 16, 2006, 05:00:42 pm
This plugin seems to conflict with the Master Template plugin. Is there a way around this?

I had first installed DigiBug, then installed the master template, it doesn't work properlly:

Basically, when you click on cart, nothing happens, the box is also gone from around "+Cart".
Also, at the top of the page there are four lines present that look like they have something to do with the digibug cart.

httpRemoved site reference - no longer avaialable
Login: Guest
Password: guest467


EDIT TO ADD:
It seems that the sample section of the master template is what was conflciting with digibug (the Google Analytics section). I removed the google analytics section from the master template plugin and reinstalled it,
it now works.
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: jeffcole455 on July 31, 2008, 11:43:44 pm
In your config for Coppermine under "General settings" --> "URL of your coppermine gallery folder (no 'index.php' or similar at the end)"  you have http://desertcities.net/galleries/ but your redirect sends it to http://www.desertcities.net/galleries/ which is where your site redirects too.  We pull from this config setting to set the path to our files so our XMLHttpRequests for our AJAX code can find the correct path to the files that return the needed XML for the plugin.  Part of the security for AJAX is to disallow "cross-domain" scripting, so we are making our calls from http://www.desertcities.net/galleries/ to http://desertcities.net/  causing the security error in the javascript.  So to resolve this the config should be set to what the final domain of the server really is which is " http://www.desertcities.net/galleries/". 

Hi James,

First, let me express how glad I am that you posted this information here.  I've been fighting with my digibugAPI for several days and now I can see there is hope.

In the redirect instructions above, I understand the need to go into config>general and set the URL of your coppermine gallery folder to "http://www.mydomain.com/gallery/", but I can't figure out what sort of redirect changes I can make.  I've tried navigating to my gallery via its real URL (http://www.oklahomaedge.com/pics/) and it works great, but the subdomain redirect uses http://pics.oklahomaedge.com/index.php and messes everything up.  I'll have a look and see if I can solve this problem and post back.

Jeff
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: jeffcole455 on August 01, 2008, 12:00:28 am
My recommendation to fix this is as follows.  I would set http://www.cypberpup.com/gallery/ to redirect to http://cyberpup.com/gallery/  That way  it always works off the config information inside of gallery.


James,

I got to tooling around with it and used your approach as stated above and it is working great!  Thanks so much for seeing this thread through.  Now I'll have to check out the digibug forum to see if I can get the +cart buttons on my intermediate images.

Kudos!

Jeff
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: MikeFL on December 25, 2008, 03:18:44 am
I just found this plugin and installed it on the latest Coppermine (1.4.19).  I am using the Grey-Style-20 theme for my gallery.

When I install this, my theme has problems - instead of the thumbnails appearing in 2 rows, they have appeared on the far right side of the screen (1 in each row).  In the Random Photos area, they appear scattered.  Also, I do not see the + cart link below the thumbnails, so I cannot select images to purchase.  Maybe a DIV statement is misplaced?

However, I believe the plugin is working because on the right sidebar, I see the (0) items in the cart and checkout links.

Now a problem with getting support on the Digibug site.  I have been a registered user of Digibug for some time.  I can login to my account and view events, etc.  When I go to the homepage and click SUPPORT for the forums, I am asked to login first, but there is no login form on the main page...only when I login to my account.  When I am logged in to my account and try to access the forums, it again asks me to login first.  ???

Thank you for any help with these!
Mike

PS:  My gallery is at http://www.thephotositook.com/cpg    (I disabled this plugin for now)
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: azeoli on December 26, 2008, 05:57:19 am
Dear MikeFL:

I saw your posting here about DigiBug support. I am the VP of Product Development working on DigiBug.

First, please accept my sincere apologies for the lack of response on the DigiBug boards. Internally, we've been setting up a better process to handle DigiBug issues. The Forums had fallen through the proverbial cracks, so to speak. We're working hard to resolve that.

Recently, I updated the DigiBug Forum boards with new Topic headers and have begun to respond to user queries. We've set up a new internal bug system to push any issues up to our developers. On minor issues, response times will be 24 to 48 hours. On larger issues, we can't guarantee a response time, because we may need to determine whether or not we hold a major bug for the next release, and there is some coordination between stakeholders to make a determination.

What I can tell you is that we are going to improve the DigiBug front end to add a user login, which will pop up in a new browser window or a new tab your specific admin panel. We know this is an issue that was not incorporated into the launch of the new corp site. A huge oversight, but one that we are certainly aware of and are working to fix. We had depended on a third party to build the corp site and they didn't manage to integrate the corp site with the application. Not very smart...we know...we're fixing  ::)

The changes to DigiBug.com will be coming in early January. This will include user login from the home page, request user/pass, request admin url, FAQ information and some changes to the general site UI. I don't have a specific date, but we have the requests in now to our development team and are starting down the road to resolve these important issues.

Plug-in dev will commence in February. The goal is to work on plug-ins for Wordpress, Joomla and Drupal first. Advancements to the DigiBug ordering system will be interspersed over the next few months.

I'll reach out to the Coppermine folks and see if they have a list of features they'd like to see. If there's anything we can do with the API to enhance integration, we will try our best to fit it in.

Thanks for your patience while we work out these issues and thanks for standing by DigiBug regardless. We're working hard to make things better.

Sincerely,

Tony Zeoli
VP of Product Development
DigiBug

Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: MikeFL on December 26, 2008, 08:03:28 pm
Hello Tony,

Thank you for the response.  I was unable to get on the Digibug forums, as mentioned previously.  Now I realize that the message which read "ask questions in our (Digibug) forums" was posted in 2006.  ;D

One comment I would like to make regarding future development, and this is only my opinion:  When I think of online photo galleries and software, I look at gallery software such as Coppermine, JAlbum and Menalto.  I use blogging software for blogging.  Wordpress, Joomla and Drupal are very capable packages for content management, but when I post my photos I tend to use a dedicated gallery package.  Unless I read the response incorrectly, it appears Digibug will develop and support CMS plugins first, then support gallery software at a later date.  (?)

Thanks again,
Mike
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: azeoli on December 26, 2008, 09:45:19 pm
Hi Mike:

Thanks for your note.

Actually, we'll continue to support Gallery2, Coppermine and a few other gallery specific plugins with the API we released. I'm not sure if Coppermine has adopted any of the latest API changes or not, but I'm looking into it.

As far as dev for CMS goes, we believe both CMS and standalone galleries are equally important and want to ensure that we support both efforts equally. There is no one or the other, we're going to be working on both as we do.

NextGenGallery for Wordpress is a pretty sweet gallery tool that I'm working on speaking to the creator to get DigiBug into Wordpress through that back channel. While also focusing on Wordpress plug-in integration for one-off photos, or somehow linking DigiBug plugin to Next Gen in some way through Wordpress.

Because of the transition in acquiring DigiBug, we fell short on some things over the last few months. However, I've been doing some research and we're very excited about the adoption of DigiBug in environments we didn't even know existed. That being said, we're doing some clean-up, looking at the product from a variety of perspectives and starting a road map for development.

Lot's of fun stuff to do!

Hope this helps clarify my last statement. I don't want you to think that we would abandon our efforts to be integrated directly into the gallery's themselves. It's those galleries that are plug-ins to Wordpress, Joomla and Drupal that are critically important to us.

Sincerely,

Tony Zeoli
Title: Re: ANNOUNCING: Digibug Pro Photo Commerce Plug-in for CPG
Post by: azeoli on December 26, 2008, 09:49:25 pm
Mike,

One more thing, our company, Online Photo Products, acquired DigiBug. The Forum moderator I see here is no longer with DigiBug. It's a whole new crew, so to speak. We're just catching up now on all of these postings out there and working hard to resolve them.

Thanks for your patience in the transition.

Sincerely.

Tony Zeoli
VP of Product Development
DigiBug