Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: issues with http and https  (Read 842 times)

0 Members and 1 Guest are viewing this topic.

Hanna.

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 150
  • webstar
issues with http and https
« on: October 31, 2018, 03:01:36 pm »

Hi all! I need some quick assistance. It might be a quick fix but I cannot find it.

So, in the middle of uploading pictures in my new gallery, I got logged out and the settings were pointed to http - and my host upgraded to https. Now the URL directly goes to https (which is fine) but I cannot login as admin.

It simply gives me a blank page and I am guessing it is because the settings in admin.php at this point are to http.

How can I get to login/admin to point the http to https or is there any back door to just have  me login admin and change the URL settings in there...?
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15577
Re: issues with http and https
« Reply #1 on: October 31, 2018, 03:22:49 pm »

I wonder how you logged in before? The setting "URL of your Coppermine gallery folder" (which you're probably talking about) doesn't affect the login.
Logged

Hanna.

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 150
  • webstar
Re: Re: issues with http and https
« Reply #2 on: October 31, 2018, 04:07:07 pm »

I wonder how you logged in before? The setting "URL of your Coppermine gallery folder" (which you're probably talking about) doesn't affect the login.

I was logged in great once installed, but then there was an SSL added and my site automatically went blank when trying to read log in page... I don't think I ever logged out actually but then my cache was cleared and my website was at https instead of http.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15577
Re: issues with http and https
« Reply #3 on: October 31, 2018, 04:18:15 pm »

The setting "URL of your Coppermine gallery folder" (which you're probably talking about) doesn't affect the login.
If you want to test anyway, you have to access your MySQL database with a tool like phpMyAdmin, open the config table and search for the row "ecards_more_pic_target".

Have you tested a different browser? Do you have a test user account (no admin account!), so we can test ourselves? If not and you agree, I'll send you my contact via PN so you can give me your admin login data.
Logged

Hanna.

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 150
  • webstar
Re: Re: issues with http and https
« Reply #4 on: October 31, 2018, 04:49:36 pm »

If you want to test anyway, you have to access your MySQL database with a tool like phpMyAdmin, open the config table and search for the row "ecards_more_pic_target".

Have you tested a different browser? Do you have a test user account (no admin account!), so we can test ourselves? If not and you agree, I'll send you my contact via PN so you can give me your admin login data.

sent you PM. Thank you André.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15577
Re: issues with http and https
« Reply #5 on: October 31, 2018, 05:33:21 pm »

According to the timestamp on your server, the file include/functions.inc.php has been modified 2.5 hours ago. The function cpg_get_user_data was missing, that's why you couldn't login. I restored the file with a clean copy and I now get an error message (as expected) when submitting wrong credentials. You need to re-apply any mods to that file, if applicable.
Logged

Hanna.

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 150
  • webstar
Re: issues with http and https
« Reply #6 on: November 03, 2018, 12:48:21 pm »

Thank you for figuring that out so quickly. However, I use that exact same functions file with my other galleries (ex - www.kristindaily.org, www.rachelbilson.us) and never had an issue. The specific add to that functions is the dimensions to be shown under the thumbnails. Why is that though? And I host them all from my own/same server.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15577
Re: issues with http and https
« Reply #7 on: November 03, 2018, 01:29:05 pm »

If the function is also missing in the other files, you'll get the same issue when you try to login. If you there's no issue, it's not the same file (or you use another Coppermine version where that function doesn't exist in include/functions.inc.php.
Logged

Hanna.

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 150
  • webstar
Re: Re: issues with http and https
« Reply #8 on: November 03, 2018, 01:47:15 pm »

If the function is also missing in the other files, you'll get the same issue when you try to login. If you there's no issue, it's not the same file (or you use another Coppermine version where that function doesn't exist in include/functions.inc.php.

That is correct. The new gallery has 1.6.04 and my other ones have 1.6.03. I need this part from version 3 to 4: -- I just tried adding it but again it interupts the entire function frame on my gallery:

Code: [Select]
if (in_array('ctime', $must_have)) {
            $caption .= '<span class="thumb_caption thumb_caption_ctime">' . localised_date($row['ctime'], $lang_date['lastup']) . '</span>';
        }


$caption .= '<span class="thumb_dimensions">' . $rowset[$key]['pwidth'] . " x " . $rowset[$key]['pheight'] . '</span>';
$rowset[$key]['caption_text'] = $caption;

        if ($CONFIG['caption_in_thumbview'] && !empty($row['caption'])) {
            $caption .= '<span class="thumb_caption thumb_caption_caption">' . strip_tags(bb_decode($row['caption'])) . '</span>';

Where would you recommed to put it so it works without interruption?
       
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15577
Re: issues with http and https
« Reply #9 on: November 03, 2018, 01:50:37 pm »

Please post more details where you have it added now, or even better, attach your modified functions.inc.php file.
Logged

Hanna.

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 150
  • webstar
Re: issues with http and https
« Reply #10 on: November 03, 2018, 02:08:48 pm »

Here we go. Version 1.6.03. Line 1158.
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1005
Re: issues with http and https
« Reply #11 on: November 04, 2018, 04:51:41 am »

@hanna
I'll have a plugin for you within a day from now (see post time) that will do that for you so you don't have to modify a core file.
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1005
Re: issues with http and https
« Reply #12 on: November 04, 2018, 08:01:09 pm »

Here is a quick and dirty beginning for a plugin to add image properties to a thumbnail. I plan to develop it more, adding significant versatility. You configure it with HTML sprinkled with image property substitutions. You should get the drift if you look at the plugin config.
« Last Edit: November 05, 2018, 03:24:19 pm by ron4mac »
Logged

Hanna.

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 150
  • webstar
Re: issues with http and https
« Reply #13 on: November 05, 2018, 06:55:46 pm »

That is the best news yet!!! I have been waiting so long for something like this, thank you so much! I just installed it - and it works great!
Logged

Hanna.

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 150
  • webstar
Re: Re: issues with http and https
« Reply #14 on: November 07, 2018, 02:08:53 pm »

Here is a quick and dirty beginning for a plugin to add image properties to a thumbnail. I plan to develop it more, adding significant versatility. You configure it with HTML sprinkled with image property substitutions. You should get the drift if you look at the plugin config.

where can I follow updates on this?
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1005
Re: issues with http and https
« Reply #15 on: November 07, 2018, 03:18:47 pm »

where can I follow updates on this?
When it's more than something quickly put together for you, I'll post it in the appropriate places and let you know about it.
Logged

Hanna.

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 150
  • webstar
Re: Re: issues with http and https
« Reply #16 on: November 07, 2018, 08:28:08 pm »

When it's more than something quickly put together for you, I'll post it in the appropriate places and let you know about it.

Ok, for now though, could you just quickly add here what the attribute is for views and then for date added (what do the {} look like for those?)
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 1005
Re: issues with http and https
« Reply #17 on: November 08, 2018, 02:40:07 am »

Ok, for now though, could you just quickly add here what the attribute is for views and then for date added (what do the {} look like for those?)

For views: {hits}
For date: you can try {mtime} (although you won't like it)

I'll soon add some formatting for things, like date, that don't display well in their raw format.
Logged

Hanna.

  • Coppermine frequent poster
  • ***
  • Country: us
  • Offline Offline
  • Gender: Female
  • Posts: 150
  • webstar
Re: Re: issues with http and https
« Reply #18 on: November 08, 2018, 04:59:24 pm »

For views: {hits}
For date: you can try {mtime} (although you won't like it)

I'll soon add some formatting for things, like date, that don't display well in their raw format.

Ok sounds good. Because the latest albums one is a bit tricky. It is included in this plugin, so now when I only choose size and views, i will need the name to the album but then the name will be added to random thumbnails as well, and the album names can be quite long. Anyhow thanks for the help, and hoping to see this feature/plugin getting developed! It is MUCH needed.
Logged
Pages: [1]   Go Up
 

Page created in 0.049 seconds with 21 queries.