Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error  (Read 515 times)

0 Members and 5 Guests are viewing this topic.

Fity

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« on: June 09, 2018, 09:10:17 am »

I have been trialling CPG 1.6.03 and it has been functioning as expected up until now.  I enabled bridging and then the next screen that appeared was white screen with the following error message.

Quote
Coppermine critical error:
Unable to connect to UDB database !

Error: :

I can no longer access any page from Coppermine.  They all have the above message. I tried to access bridgemgr.php as suggested in the documents but the same error message appears and I can't disable bridging.

I tried a clean install of CPG1.6.03 with a new data base and the same bridging error occurred.

I know that bridging for VBulletin is for VB3, however I have used bridging with VB4 and CPG 1.5.x until a server configuration change to PHP7.1 which forced a Coppermine change.

Bridging was an important feature when selecting Coppermine.  Any ideas?
Logged

Fity

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« Reply #1 on: June 09, 2018, 09:13:43 am »

I forgot to mention that I tried to repair the database tables in case that was the problem with no luck.
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 865
Re: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« Reply #2 on: June 10, 2018, 02:21:02 am »

Use the installer stub to install/upgrade to CPG 1.6 with the very latest changes. (select the bottom choice, highlighted in red, in the installer)
http://forum.coppermine-gallery.net/index.php/topic,79013.msg383037.html#msg383037
Logged

Fity

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« Reply #3 on: June 10, 2018, 10:59:36 am »

OK thanks. I will try that and post the results.
Logged

Fity

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« Reply #4 on: June 11, 2018, 02:23:47 pm »

I have reinstalled CPG with a new database using the stub suggestion above with no luck.  Every time that I enable bridging I loose CPG access with the same error message.  Any other suggestions?
Logged

Fity

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« Reply #5 on: June 14, 2018, 12:43:55 pm »

 Any suggestions?  I am liking v1.6 a lot and would like to get the gallery live.
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 865
Re: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« Reply #6 on: June 14, 2018, 02:56:24 pm »

If the vBulletin database is separate from the CPG database, make sure the correct credentials are configured for the bridge.

Or you can try installing CPG to use the same database as vB (with a different prefix).
« Last Edit: June 14, 2018, 03:22:19 pm by ron4mac »
Logged

Fity

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« Reply #7 on: June 15, 2018, 03:43:14 am »

Thanks for the reply.

There are 2 databases, one for the forum and the other for CPG.  I am hesitant to use the same database for CPG and VB.

The structure is:

http://www.website.com/forum
http://www.website.com/gallery

In the bridging settings I have tried different paths with no luck.  Sometimes I can recover by clicking "back" and disabling bridging and other times the CPG installation is not accessible.

Could the problem be that there is also a CPG1.5 installation bridged to the same VB4?  Do I need to disable bridging in CPG1.5 before enabling cpg1.6?



Logged

Fity

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« Reply #8 on: June 15, 2018, 06:45:52 am »

These are the paths that I believe to be correct.

URL of bridging app:
http://www.website.com/forum

Relative path
../forum/
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 865
Re: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« Reply #9 on: June 15, 2018, 12:19:02 pm »

I can't put together a VB 4.2.5 instance to test with so you would have to give me access to your site to try to determine the problem. You would have to PM me with your site and its credentials or I can post a file for you to place in your site root that I can use to access everything I need.
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 865
Re: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« Reply #10 on: June 16, 2018, 12:25:26 pm »

Here's the file. Place it unzipped, of course.

see next post first
« Last Edit: Yesterday at 12:57:31 pm by ron4mac »
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 865
Re: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« Reply #11 on: June 16, 2018, 01:12:02 pm »

I was just looking at things prior to doing any work at your site and may have come up with a solution.
Replace the vBulletin bridge file in your CPG 1.6 bridge folder with the one attached here (as .php).
Let me know if it solves the problem.
Logged

Fity

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« Reply #12 on: June 18, 2018, 02:23:09 am »

Thanks for the file.  I replaced the file in the bridging folder as suggested.  The error remains. :(
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4544
    • Windsurf.me
Re: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« Reply #13 on: June 18, 2018, 10:25:49 am »

Did you remember to rename the file to end in.php
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Fity

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« Reply #14 on: June 18, 2018, 10:46:57 am »

Yes i removed the .txt and left it named the same as the original file.  The original file was renamed and left in the bridging folder. Will that be an issue?
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 865
Re: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« Reply #15 on: Yesterday at 12:56:49 pm »

Replace bridge/udb_base.inc.php with the attached file (as .php).
It will still fail but may give more indication of the error condition.

Are you using mysqli or PDO/mysql for the CPG 1.6 install?
Logged

Fity

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« Reply #16 on: Today at 01:37:44 am »

Thanks for the file.

cpg1.6 is MySQL. 

I replaced the file as suggested and the error message has a little more information.

Quote
Coppermine critical error:
Unable to connect to UDB database !

Error: 2005 : Unknown MySQL server host 'localhost:3306' (2)
Logged

Fity

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Bridging CPG 1.6.03 with VBulletin 4.2.5 - Critical Error
« Reply #17 on: Today at 01:53:57 am »

I forgot to mention that since replacing the vbulletin30.inc.php I have reliably backed out of the error message to the previous screen to disable bridging.
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 21 queries.