Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: help fixing Template Error Failed to find block 'comment_captcha'  (Read 493 times)

0 Members and 1 Guest are viewing this topic.

aps

  • Coppermine novice
  • *
  • Country: au
  • Offline Offline
  • Gender: Female
  • Posts: 24

hello,

I upgraded my coppermine gallery from 1x4 to 1x5. i am not using a custom theme. using curve. when trying to comment or view an image i receive this html error.

Code: [Select]
Template error
Failed to find block 'comment_captcha' (#<!-- BEGIN comment_captcha -->(.*?)<!-- END comment_captcha -->#s) in :

<table align="center" width="{WIDTH}" cellspacing="1" cellpadding="0" class="maintable">
        <tr>
                <td width="100%" class="tableh2_compact"><b>{ADD_YOUR_COMMENT}</b></td>
        </tr>
        <tr>
                <td colspan="3">
                <form method="post" name="post" action="db_input.php">
                        <table width="100%" cellpadding="0" cellspacing="0">

<tr><td colspan="2"><input type="hidden" name="msg_author" value="stella" /></td>
<!-- BEGIN input_box_smilies -->
                                <td class="tableb_compact">
                                {COMMENT} </td>
                                <td width="100%" class="tableb_compact">
                                <textarea class="textinput" id="message" name="msg_body" onselect="storeCaret_post(this);" onclick="storeCaret_post(this);" onkeyup="storeCaret_post(this);" maxlength="{MAX_COM_LENGTH}" style="width: 100%;" rows="2"></textarea>
<!-- END input_box_smilies -->

                                </td>
                                <td class="tableb_compact">
                                <input type="hidden" name="event" value="comment" />
                                <input type="hidden" name="pid" value="{PIC_ID}" />
                                <input type="submit" class="comment_button" name="submit" value="{OK}" />
                                </td></tr>
                        </table>
                </form>
                </td>
        </tr>
<!-- BEGIN smilies -->
        <tr>
                <td width="100%" class="tableb_compact">
                        {SMILIES}
                </td>
        </tr>
</table>
<!-- END smilies -->

can anyone help me fix this problem. of course i am willing to pay a fee.

board location.
http://www.a-p-s.org.au/webfolios2/index.php


cheers
stella.

Logged

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 721
    • GMC Design Photo Gallery
Re: help fixing Template Error Failed to find block 'comment_captcha'
« Reply #1 on: August 18, 2017, 03:42:16 am »

No need to pay for support when having an issue with a provided theme...
The block for comment_capcha should be defined in yourcpgfolder/include/themes.inc.php... (and in yourcpgfolder/themes/sample/theme.php as example of what can be customized...)

Sounds like themes.inc.php is not correct - I would try re-uploading that file from our distribution and see if it fixes your problem.
Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money

aps

  • Coppermine novice
  • *
  • Country: au
  • Offline Offline
  • Gender: Female
  • Posts: 24
Re: help fixing Template Error Failed to find block 'comment_captcha'
« Reply #2 on: August 18, 2017, 03:50:57 am »

hello,

i tried that. no love. problem is still there.  any other ideas?
Logged

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 721
    • GMC Design Photo Gallery
Re: help fixing Template Error Failed to find block 'comment_captcha'
« Reply #3 on: August 18, 2017, 03:53:17 am »

Do you see this code in themes.inc.php:
Code: [Select]
<!-- BEGIN comment_captcha -->Just being sure we have a valid file...

Any other modifications made to the code?
Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money

aps

  • Coppermine novice
  • *
  • Country: au
  • Offline Offline
  • Gender: Female
  • Posts: 24
Re: help fixing Template Error Failed to find block 'comment_captcha'
« Reply #4 on: August 21, 2017, 12:16:33 am »

hi.

yes i found that bit of code in includes/themes.inc.php. i tried commenting it out but still the error will not go away. no other mods anywhere. fresh upgrade using curve.
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 670
Re: help fixing Template Error Failed to find block 'comment_captcha'
« Reply #5 on: August 21, 2017, 01:03:00 am »

Either themes/curve/theme.php or include/themes.inc.php has been modified.  You'll have to sort out which one and replace it with the correct file from the cpg1.5.46 distribution.

The only other rather remote possibility is that you are using a plugin that is causing problems. Temporarily rename the plugins folder (to maybe ppluginss), which will effectively disable all plugins, to see if that makes a difference.
Logged

aps

  • Coppermine novice
  • *
  • Country: au
  • Offline Offline
  • Gender: Female
  • Posts: 24
Re: help fixing Template Error Failed to find block 'comment_captcha'
« Reply #6 on: August 21, 2017, 02:29:08 am »

 8) 
renaming the plugins folder worked to fix this issue.  big thank you.  how do you recommend that i proceed now with the plugins folder renamed?
should i re-upload a fresh copy of the /plugins/ folder?
Logged

ron4mac

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Posts: 670
Re: help fixing Template Error Failed to find block 'comment_captcha'
« Reply #7 on: August 21, 2017, 03:34:04 am »

how do you recommend that i proceed now with the plugins folder renamed?
So one of your plugins is causing the problem. One method you could use would be to change the plugin folder name back to plugins and then uninstall plugins one at a time until the problem goes away again. Last plugin uninstalled was the problem one.

Please report back here and let us know what plugin was the problem.
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 21 queries.