Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Downloading 1.4.0  (Read 1739 times)

0 Members and 1 Guest are viewing this topic.

annek

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Downloading 1.4.0
« on: October 30, 2016, 11:43:59 pm »

Hey,

I'm upgrading from version 1.3.5 because my host upgraded PHP and the old version is no longer working (in various ways). I tried to install the newest version of Coppermine, before reading I should have upgraded to 1.4.x first. But now my problem is, I can't find version 1.4.0 anywhere online. (I use FTP to upload then take it from there.)

So my question is - where can I download version 1.4.0?

Cheers
Logged

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 722
    • GMC Design Photo Gallery
Re: Downloading 1.4.0
« Reply #1 on: October 31, 2016, 01:09:18 am »

All versions of Coppermine (current and old) are available to download here: https://sourceforge.net/projects/coppermine/files/Coppermine/  (or follow 'Download' link at the top of all forum pages and then select Coppermine from list.)

I would suggest 1.4.27 - the last stable release of 1.4.x...

There are significant changes - especially in theme area - when going from 1.3 to 1.4. Please read the documentation especially if you have a custom theme.
Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money

annek

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Downloading 1.4.0
« Reply #2 on: October 31, 2016, 08:14:12 pm »

Ah, Files > Coppermine! There it is! I was on SourceForge but I didn't find that particular page.

Thank you very much!!
Logged

annek

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Downloading 1.4.0
« Reply #3 on: October 31, 2016, 09:38:24 pm »

It would seem I can't edit my post. Probably need 5 posts or more to edit?

Anyway I managed to successfully upgrade to 1.4.27. Now I'm wondering what version I should go for next - I went to 1.5.44 but that had some unwanted behaviour on the layout and character settings (Norwegian characters went missing). Any suggestions?
Logged

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 722
    • GMC Design Photo Gallery
Re: Downloading 1.4.0
« Reply #4 on: October 31, 2016, 10:03:31 pm »

1.5.44 is where you want to be...
Sounds like a Character Set issue - typically a conflict between defined charset and the actual data in the database.
Ideally you want to be using UTF8 as the charset (defined in MySQL tables) - and all the contained data should also be in UTF8. (Second part is key... just changing the charset of a table doesn't change the data stored in the table.

There is also an optional parm in config.inc.php ($CONFIG['dbcharset']) that can be used to override the character set requested when CPG establishes the database connection.

There are several threads dealing with these mismatches. A test copy of your gallery to try changes will be very helpful if you don't have one already - at the very least insure you have a good backup before altering data.

http://forum.coppermine-gallery.net/index.php/topic,77017.msg373366.html#msg373366
Search for 'convert cast' and you'll find others.

If you need additional help - please open a thread in the 1.5 boards so others will be able to find later.
Thanks!
Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money

annek

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Downloading 1.4.0
« Reply #5 on: November 01, 2016, 07:17:33 pm »

Thanks for your input.
There's also this thing about the layout though - the buttons when you're logged in as an admin align vertically and stretch to the width of the board, so the charset isn't the only issue. I'd avoid doing minor fixes one by one if there's the option of going for a version before 1.5.44, and if so, which version is recommended (like 1.5.0.) But I'm reading from your answer there's no "next step" recommendations here?
Logged

gmc

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 722
    • GMC Design Photo Gallery
Re: Downloading 1.4.0
« Reply #6 on: November 02, 2016, 12:04:06 am »

1.5.44 (and several other earlier 1.5 releases) was a security release... Anything older than 1.5.44 would have known exposures.
You can see all the changes reviewing file CHANGELOG.txt in the 1.5.44 distribution showing all changes made along the way...
1.5.1 (alpha) was released in July 2009...

I'm not aware of a change made during 1.5 that would have affected the CHARSET... Most issues with this came up with 1.4 to 1.5... or with a change of servers... or upgrade to software like MySQL by ISP.

What theme are you using?  If one of the CPG provided themes - did you refresh it with the upgrade?
I'd need to see screen pics of what you are seeing with the buttons - but most theme issues can be easily addressed.
(and again not aware of anything mid 1.5 that would have impacted themes - we try hard to make everything downward compatible within a major release (1.5.x).  We may add additional options - but default behavior is not changed as the rule unless broken.
Logged
Thanks!
Greg
My Coppermine Gallery
Need a web hosting account? See my gallery for an offer for CPG Forum users.
Send me money
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 21 queries.