Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Prevent registered users from creating albums  (Read 3005 times)

0 Members and 1 Guest are viewing this topic.

Kawboy

  • Coppermine newbie
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 11
Prevent registered users from creating albums
« on: February 10, 2015, 03:03:32 pm »

I know what an admin is thinking- we've discussed this in detail before, but...

I read the documentation, and searched the message forum, and I thought I had everything set correctly, but I've just had a new registered user upload a picture into their own album which I thought I had set everything to prevent that. I want the registered users to only be able to upload into albums I already created. I have attached a screenshot to the groups manager to show what I have set there. You'll see under the personal galleries settings that I have allowed set to "no" and of course the approval set to "no" as I thought that wouldn't make any difference since the other setting was set to no. Under the album properties I have set that anybody can view the album, and didn't think that should make a difference on who can upload to it. Can someone help me to see what I did wrong or diagnose my visual problems in seeing the directions on this that may have already been noted somewhere but I can't seem to see. The attachment of the group manager shot and other info is below. I did already move that picture into an album I created and deleted the album the user had.

My gallery is: http://www.pachapteri.com/copperminephoto/index.php
username to text: tester
password: foobar
Logged

allvip

  • Global Moderator
  • Coppermine addict
  • *****
  • Country: 00
  • Offline Offline
  • Posts: 1290
Re: Prevent registered users from creating albums
« Reply #1 on: February 10, 2015, 03:37:35 pm »

In Config - Registration - Create user album in personal gallery on registration - disable.
Logged

allvip

  • Global Moderator
  • Coppermine addict
  • *****
  • Country: 00
  • Offline Offline
  • Posts: 1290
Re: Prevent registered users from creating albums
« Reply #2 on: February 10, 2015, 03:49:22 pm »

Also Files- Category - choose a category - click edit category  - Group(s) allowed to create albums in this category - click [Ctrl]-button and click on the selected group (Registred) - click Update/Create Category.
Click the ? after Group(s) allowed to create albums in this category. That will tell you how to allow and disallow.

If you have it highlight with blu then their are allowed. If not then they are not allowed.

I loged in on your gallery and I'm able to create albums in the main Category so you have it set to allow Create Albums.
Logged

allvip

  • Global Moderator
  • Coppermine addict
  • *****
  • Country: 00
  • Offline Offline
  • Posts: 1290
Re: Prevent registered users from creating albums
« Reply #3 on: February 10, 2015, 03:58:40 pm »

That has nothing to do with allow Personal Gallery. You have all the settings right for that. I can not create albums in My Gallery and I can not upload in My Gallery even if I have My Gallery button. No default album for me was created or maybe only you can see that. Make sure you disable Create user album in personal gallery on registration like I said in my first reply.

I find it unusual that My Gallery button shows even if I am not allowed to have it.
« Last Edit: February 10, 2015, 04:05:48 pm by allvip »
Logged

allvip

  • Global Moderator
  • Coppermine addict
  • *****
  • Country: 00
  • Offline Offline
  • Posts: 1290
Re: Prevent registered users from creating albums
« Reply #4 on: February 10, 2015, 04:08:38 pm »

Well, is the same thing on my gallery and it should not show if users are not allowed.
Maybe the copp team can tell me why My Gallery button shows for Registred users when their not allowed to have it.
Logged

Kawboy

  • Coppermine newbie
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 11
Re: Prevent registered users from creating albums
« Reply #5 on: February 10, 2015, 04:12:37 pm »

Thanks Allvip! I did have the setting set to disable on your first post, but the second one I did not have disabled for registered users to create albums, I just plain missed that one. It took me a little bit to figure out how to disable that but your directions absolutely helped. I can see where someone (at least me) might miss this setting. Thanks so much again!
Logged

allvip

  • Global Moderator
  • Coppermine addict
  • *****
  • Country: 00
  • Offline Offline
  • Posts: 1290
Re: Prevent registered users from creating albums
« Reply #6 on: February 10, 2015, 04:15:53 pm »

Thanks Allvip! I did have the setting set to disable on your first post, but the second one I did not have disabled for registered users to create albums, I just plain missed that one. It took me a little bit to figure out how to disable that but your directions absolutely helped. I can see where someone (at least me) might miss this setting. Thanks so much again!

Login just now and everything is fine.
Even My Gallery button is gone.
Logged

allvip

  • Global Moderator
  • Coppermine addict
  • *****
  • Country: 00
  • Offline Offline
  • Posts: 1290
Re: Prevent registered users from creating albums
« Reply #7 on: February 10, 2015, 04:19:03 pm »

Well, is the same thing on my gallery and it should not show if users are not allowed.
Maybe the copp team can tell me why My Gallery button shows for Registred users when their not allowed to have it.

I see why now. If they are allowed to create albums (I have allowed for just one cat) My Gallery button shows.
My mistake.
Logged

Kawboy

  • Coppermine newbie
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 11
Re: Prevent registered users from creating albums
« Reply #8 on: February 10, 2015, 04:23:20 pm »

Login just now and everything is fine.
Even My Gallery button is gone.

Yes, seen what I figured was you there. Thanks again!  ;D ;D
Logged
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 21 queries.