Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: galería inactiva "Fatal error"  (Read 6697 times)

0 Members and 1 Guest are viewing this topic.

BusAmerica

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
galería inactiva "Fatal error"
« on: December 16, 2013, 11:48:15 pm »

Hola,
mi nombre es Alejandro y soy administrador del sitio www.bus-america.com , que cuenta con su sección "galeria" con el soporte Coppermine.
Dicha sección hoy ha querido dejar de trabajar:
http://galeria.bus-america.com
o si se quiere
http://www.bus-america.com/galeria/index.php
Dejndome por mensaje unicamente
"Fatal error :"
buscando el codigo fuente de dicha pàgina/mensaje, no me aparece nada mas como para poder aportar

Otro moderador de la galería, me dijo que un sitio colega que usa el mismo soporte Coppermine le ha pasado lo mismo. Dicho sitio es:
http://solobus.com.ar/fotodiaria/index.php
y ahi el mensaje dice algo mas:
"Fatal error :
.
While executing query "SELECT * FROM cp_config" on 0
mySQL error: Can't find file: './solobus_cpm1/cp_config.frm' (errno: 13)"

Por este común problema es que me da a pensar en que tiene algo relacionado con el soporte

Les cuento que la versiòn que tengo es la 1.4.17, y no llegue a actulizarla. En junio del año 2010 Matute me ha ayudado al respecto:
http://forum.coppermine-gallery.net/index.php/topic,65399.msg325849.html#msg325849

Poniendome en autos y leyendo, veo que debo ir por la actualizaciòn 1.4.26 obligatoriamente (o superior estimo)
A su vez buscando en "Serch" no encuentro topico parecido, por eso abro este.

Por otra parte como la galeria no me muestra absolutamente nada, no se que mas aportarles. Si me pueden tirar una idea por donde encarar

Les mando un saludo y quedo a la espectativa
Alejandro
 
Logged

Niecher

  • LocalSupporter
  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 191
Re: galería inactiva "Fatal error"
« Reply #1 on: December 17, 2013, 12:02:48 am »

Actualiza a la ultima versión, encontrarás la descarga en la página principal.

Saludos.
Logged

BusAmerica

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: galería inactiva "Fatal error"
« Reply #2 on: December 17, 2013, 01:06:39 am »

Gracias Quote

Si es eso, me pongo en marcha

¿Pero por que alguna galería con una versión anterior sigue funcionando sin problema?

Saludos
Alejandro
Logged

Niecher

  • LocalSupporter
  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 191
Re: galería inactiva "Fatal error"
« Reply #3 on: December 17, 2013, 10:06:46 pm »

Quizás han realizado actualizaciones en tu host. No te sabría decir un motivo exacto.

Saludos.
Logged

BusAmerica

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: galería inactiva "Fatal error"
« Reply #4 on: December 18, 2013, 03:49:11 pm »

Hola Niecher

Antes que nada, gracias por tu respuesta y tiempo.

Te cuento que en el host, no han actualizado nada, segun me contaron.

Procedi a la actualizacion siguiendo todos los pasos explicitados muy bien en:
http://documentation.coppermine-gallery.net/es/upgrading.htm

Al llegar al ultimo: "Ejecuta el script de actualización"
Se me presenta el siguiente inconveniente, me pide
"Authentication needed
Please provide your coppermine admin account details or your mySQL account data"

pongo mi usuario de la base de datos y clave y nada
Estoy intentando cambiar la clave de la base de datos, pero no funciona mas...

como pide "your coppermine admin" , los consulto ¿cual seria mi coppermine admin?

Agradecido por tu tiempo

Saludos
Alejandro
Logged

BusAmerica

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: galería inactiva "Fatal error"
« Reply #5 on: December 18, 2013, 04:08:23 pm »

Hola ya solucione lo de la base de datos y con ello la actualizacion

Quedo bien segun parece

Caso, cerrado, pero cual seria mi usuario coppermine que menciono en el post anterior

Abrazo y gracias por todo
Alejandro
Logged

Niecher

  • LocalSupporter
  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 191
Re: galería inactiva "Fatal error"
« Reply #6 on: December 18, 2013, 09:15:20 pm »

Se trata de la cuenta de administrador al instalar coppermine por primera vez y se crea desde el asistente de instalación.

Es el primer usuario de la galería y por defecto es admin. La password, obviamente, la que tu pusieras en su momento.

Saludos.
Logged

BusAmerica

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: galería inactiva "Fatal error"
« Reply #7 on: December 19, 2013, 03:49:09 am »

Gracias Niecher por la respuesta!

Pero este tópico lo vuelvo a abrir

Luego de actualizar con update, todo funcionó bien pero...

luego (horas después) y en este momento me acontecen indistintamente dos problemas:

1° a veces no abre la galería y tira el siguiente mensaje:
"Template error
Failed to find block 'file_line' (#<!-- BEGIN file_line -->(.*?)<!-- END file_line -->#s) in :

                    <div class="{CSS_CLASS}">
                        <h2>{HEADER_TXT}</h2>
                        <span class="cpg_user_message">{MESSAGE}</span>

                        <br /><br />
                    </div>"
En este caso no interpreto de que se trata


2° a veces me permite ver la galería, pero al loguearme me tira:
"Error crítico
Se produjo un error al procesar una consulta de base de datos"

Interpreto que en este caso es un problema con la base de datos, pero no tengo idea por donde ir

Agradecido por tu tiempo Niecher, y pensaba que ya estaba solucionado, pero ya lo decia un tal Tusam: "puede fallar"
Quedo a la espectativa

Saludos
Alejandro
Logged

Niecher

  • LocalSupporter
  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 191
Re: galería inactiva "Fatal error"
« Reply #8 on: December 19, 2013, 11:59:32 pm »

La última versión de coppermine (en este momento) es la 1.5.24 y parece ser que tú has actualizado a la versión 1.5.16

Hay bastantes mejoras en la versión 1.5.24. cpg1.5.24 maintenance release - upgrade recommended.

Saludos.
Logged

BusAmerica

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: galería inactiva "Fatal error"
« Reply #9 on: December 20, 2013, 06:20:22 am »

Hola iecher

Desde ya agradecido por tu respuesta
La propuesta es alentadora, un salto hacia adelante y eso voy a hacer, volver a actualizarla, mas a modo de consulta
¿no puede ocurrir que este problema se traslade?

Pues me resulta insolito que otros puedan acceder y yo no, interpretando dificulatades en la base de datos

Otro tema, veo de tus post que no ha quedado soporte técnico en español de Coppermine, y que vos has tomado la posta ¿sabés que pasó con Matute?

Abrazo y agradecido por respuesta
Ale

Logged

Niecher

  • LocalSupporter
  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 191
Re: galería inactiva "Fatal error"
« Reply #10 on: December 20, 2013, 10:33:34 am »

No, no se nada de Matute.

Cuando subas los archivos al ftp, asegurate de borrar/sobreescribir todos los archivos de cualquier versión anterior. Y posteriormente ejecutar el update para actualizar la base de datos. Haz copia de seguridad tanto de la base de datos como de los archivos de coppermine, por si surgen errores.

En teoría no debería trasladarse el problema.

Saludos.
Logged

BusAmerica

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: galería inactiva "Fatal error"
« Reply #11 on: December 20, 2013, 06:18:36 pm »

Hola
Habia posteado mi respuesta pero no me aperece

He tenido esos cuidados y actualice la galeria, persiste el problema

He mantenido y cuidado la carpeta "albums" y el fichero "anycontent.php"
estimando que segun el procedimiento no decia nada en contrario, reemplace la carpeta "include"
Y pensando que tal vez por ahi venga el problema

Otros usuarios puedn loguearse, los moderadores casi que no

Quedo a la expectativa, para ver tu opinón

Saludos
Ale
Logged

BusAmerica

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: galería inactiva "Fatal error"
« Reply #12 on: December 20, 2013, 06:41:04 pm »

Estoy viendo que tengo ficheros que en el zip de la version 1.5.24 no están mas y son estos:
1) cgi-bin (carpeta)
2) CHANGELOG
3) COPYNG
4) error_log
5) info.php
6) instaler.css
7) readme
8) upgrade-1.0-to-1.2.php

Y ahora voy a borrarlos a ver si eso generaba alguna contradicción
Logged

BusAmerica

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: galería inactiva "Fatal error"
« Reply #13 on: December 20, 2013, 06:49:22 pm »

Acabo de borrarlos y no ha pasado nada

......
Ahora no se me ocurre nada

Espero se te ocurra alguna posibilidad, pues ahora si que no tengo idea

Saludos
Ale
Logged

Niecher

  • LocalSupporter
  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 191
Re: galería inactiva "Fatal error"
« Reply #14 on: December 20, 2013, 09:41:58 pm »

Solo has reemplazado la carpeta include?

Debes subir por ftp todos los archivos y carpetas que vienen en el paquete de la versión 1.5.24.

Puedes mantener el archivo anycontent (si lo tienes personalizado) y mantener obviamente la carpeta albums, pero el resto de archivos deben ser reemplazados por todos los nuevos archivos de la última versión.

Saludos.

Logged

BusAmerica

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: galería inactiva "Fatal error"
« Reply #15 on: December 20, 2013, 11:03:58 pm »

Hola Niecher

No, he reemplazado todos los archivos del paquete 1.5.24 menos "anycontent" y "albums", quedandome la duda con "include" al cual también reemplacé
La duda con este fichero es por que figura en el descriptibo como para hacerle backup, al igual que "anycontent" y "albums"

Es decir actualicé todo

Por eso ahora el no saber por donde está el problema

Saludos y como siempre, gracias por tu respuesta
Alejandro
Logged

Niecher

  • LocalSupporter
  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 191
Re: galería inactiva "Fatal error"
« Reply #16 on: December 20, 2013, 11:13:56 pm »

Ahora, con la nueva versión y actualizada de nuevo la base de datos con el update,
te sigue dando el error del template que mencionaste antes?

En definitiva, que error persiste y en que situaciones se da el error? Si puedes detallar más todo este punto.

Saludos.

Logged

BusAmerica

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: galería inactiva "Fatal error"
« Reply #17 on: December 20, 2013, 11:47:14 pm »

Asi es tal cual lo describís
Fueron subidos todos los archivos de la versión 1.5.24 y fueron actualizados mediante el scrit de actualización:
http://www.bus-america.com/galeria/update.php

Tras ello persiste el inconveniente desde la actualización, que alternativamente es o:

1°) a veces no abre la galería y tira el siguiente mensaje:
"Template error
Failed to find block 'file_line' (#<!-- BEGIN file_line -->(.*?)<!-- END file_line -->#s) in :
                    <div class="{CSS_CLASS}">
                        <h2>{HEADER_TXT}</h2>
                        <span class="cpg_user_message">{MESSAGE}</span>
                        <br /><br />
                    </div>"
En este caso no interpreto de que se trata

2°) a veces me permite ver la galería, pero al loguearme me tira:
"Error crítico
Se produjo un error al procesar una consulta de base de datos"

Interpreto que en este caso es un problema con la base de datos, pero no tengo idea por donde ir


A esto puedo agregar que otros usuarios pueden ingresar al sitio, pero los moderadores no, menos uno que si puede acceder. Cuando intenté yo entrar desde la cuenta de este moderador he tenido el inconveniente "1º"

Decime si necesitas mas data

Y como siempre gracias!
Logged

Niecher

  • LocalSupporter
  • Coppermine frequent poster
  • ***
  • Country: es
  • Offline Offline
  • Gender: Male
  • Posts: 191
Re: galería inactiva "Fatal error"
« Reply #18 on: December 21, 2013, 12:16:07 am »

Es extraño que unos usuarios puedan loguear y navegar por la galería correctamente y otros usuarios no. En tu caso particular, prueba a limpiar el caché de tu navegador.

No obstante, también me refería que detallaras en cual página te sale el error del template. Si ocurre cuando visitas los ultimos archivos, o cuando visitas la página de busqueda, o cuando visitas la página de configuración de la galería, etc.

Yo he visitado tu galería y no me sale ningún error de template (como invitado) y hasta donde puedo navegar ya que los invitados no pueden ver la página intermedia.
Logged

BusAmerica

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: galería inactiva "Fatal error"
« Reply #19 on: December 21, 2013, 12:40:40 am »

Ciertamente es extraño
Aunque un denominador comun es que los moderadores no podemos en su mayoría

Te cuento que he accedido desde diversas maquinas, pues trabajo en un cyber y desde otras externas a este cyber, por lo que el tema del cache no creo que funcione
Por otro lado a otros moderdores desde otras PCs, en otros paises les pasó lo mismo (2 en Argentina, 1 en Ecuador)

En la configuracion actual si no estàs logueado, no te deja acceder a las imàgenes por lo que el problema que detalle como "1º" y "2º" son al loguearme. Aunque cuando me tira el problema "1º" no me deja ver nada
Es decir con "2º" veo las fotos, ultimos comentarios, etc, en chiquito y cuando quiero acceder a los mismos me pide que me loguee (en la version que tenia antes no era asi, y no he podido entrar a esta version como para deshabilitar esa función)
Como no me deja loguearme me tira
""Error crítico
Se produjo un error al procesar una consulta de base de datos""

Para donde disparamos?

Saludos
Ale
Logged
Pages: [1] 2   Go Up
 

Page created in 0.054 seconds with 19 queries.