Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: File albums/userpics/10003/xxx log shows missing images  (Read 7603 times)

0 Members and 1 Guest are viewing this topic.

Visitor

  • Coppermine regular visitor
  • **
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 55
File albums/userpics/10003/xxx log shows missing images
« on: January 24, 2013, 05:21:57 pm »

Jan 24, 2013 at 02:34 AM - File albums/userpics/10003/normal_photo0090.jpg is missing

Im reading a lot of lines in the log file, can you tell me the cause. All seams to be running just fine. I went to the server and looked inside userpics/10003 and there are imaes and "thumb_photo0090.jpg"

Something from an old version?

I have Coppermine Photo Gallery 1.5.18 (stable)

Only thing changes was I added a capatcha plugin a while ago for ecards
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15415
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #1 on: January 24, 2013, 05:28:42 pm »

thumb_photo0090.jpg
is not
normal_photo0090.jpg

You can re-create intermediate-sized pictures with the admin tools.


I have Coppermine Photo Gallery 1.5.18 (stable)
Please upgrade to the latest stable release, cpg1.5.22.
Logged

Visitor

  • Coppermine regular visitor
  • **
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 55
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #2 on: January 24, 2013, 06:54:31 pm »

Quote
You can re-create intermediate-sized pictures with the admin tools

But why is there an error in the first place?

I have photo0090.jpg and thumb_photo0090.jpg

I do not have it set to show anything inbetween
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15415
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #3 on: January 24, 2013, 07:04:36 pm »

Please upgrade to cpg1.5.22 and check if the error still occurs. There have been a lot of changes since cpg1.5.18.
Logged

Visitor

  • Coppermine regular visitor
  • **
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 55
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #4 on: January 24, 2013, 07:11:55 pm »

Have downloaded, backed up, look at what I may have changed, upgrade later

Thanks
Logged

Visitor

  • Coppermine regular visitor
  • **
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 55
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #5 on: January 24, 2013, 07:57:20 pm »

Ok, I made a change

http://forum.coppermine-gallery.net/index.php/topic,73335.0/topicseen.html

Sometime ago, and was about to upload new, however looking at "theme.php" is just a few lines, unlike the old one that has many lines
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15415
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #6 on: January 24, 2013, 08:11:19 pm »

You don't need to overwrite your theme during the upgrade. Please perform the upgrade and if the error message still occurs, we will check your theme or anything else.
Logged

Visitor

  • Coppermine regular visitor
  • **
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 55
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #7 on: January 24, 2013, 08:28:42 pm »

Ok thanks, reason my theme.php is big, is because I added contect of theme_html_picture :)-

Ok, hope its not going to change anything, will back it up first.. thanks
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15415
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #8 on: January 24, 2013, 08:34:48 pm »

To avoid that your theme will be overwritten during an upgrade, there's a simple but important rule: http://documentation.coppermine-gallery.net/en/theme_create.htm#theme_create_rename
Logged

Visitor

  • Coppermine regular visitor
  • **
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 55
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #9 on: January 24, 2013, 08:50:40 pm »

Ah yes, that would stop any changes there, that is unless there is an important change. Will get this working and make a "default" folder and changes later.

BTW what happens to the capatcha plugin I installed? should I now switch it off, before upgrade? does capatcha come installed now for ecards etc

I got hit badly by a robot spammer, the logs show it was still trying failed image etc, so banned ip address
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15415
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #10 on: January 24, 2013, 08:57:02 pm »

I don't know which plugin you use, or if it's a genuine plugin at all. If it's a plugin, it overwrites Coppermine's default plugin and you don't need to uninstall it.
Logged

Visitor

  • Coppermine regular visitor
  • **
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 55
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #11 on: January 24, 2013, 09:16:08 pm »

Its one from this site somewhere :)- one that was made pending any future changes
Logged

Visitor

  • Coppermine regular visitor
  • **
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 55
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #12 on: January 24, 2013, 09:28:40 pm »

mm, there were things uploaded to root, so not sure now, I know it came from here somewhere
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15415
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #13 on: January 24, 2013, 09:33:23 pm »

It would really help if you'd post more details, e.g. the file/folder names what has been uploaded. However, maybe you used this one?
Logged

Visitor

  • Coppermine regular visitor
  • **
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 55
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #14 on: January 24, 2013, 10:15:25 pm »

Yes, think that was it..

However, Ive just uploaded new overwrite except a file (forgot name will find in a second) read it in doc..

All seams to be ok until I loged out, then as a guest (needs approval) I selected to upload a picture, but there wasnt an album available in the list anymore.

On checking users, I done seam to have a guest anymore, think I had called it "Visitor"
Logged

Visitor

  • Coppermine regular visitor
  • **
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 55
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #15 on: January 24, 2013, 10:17:19 pm »

Ah, under groups its still there, sorry..

So problem now is there dont seam to be an album for a guest anymore
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15415
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #16 on: January 24, 2013, 10:19:07 pm »

Logged

Visitor

  • Coppermine regular visitor
  • **
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 55
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #17 on: January 24, 2013, 10:47:26 pm »

Hell thats all I need is a fault in the code...

Changed code now working
Logged

Visitor

  • Coppermine regular visitor
  • **
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 55
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #18 on: January 24, 2013, 10:54:19 pm »

Well now a guest can upload a photo, however there is no title or description box available.

Comments are not these boxes right, I have comments for guest's off
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15415
Re: File albums/userpics/10003/xxx log shows missing images
« Reply #19 on: January 24, 2013, 11:01:10 pm »

I really suggest to read the docs. When using the flash uploader as guest you cannot enter meta data unless you change a value in the database. Please have a look at the known issues docs (right at the bottom).
Logged
Pages: [1] 2   Go Up
 

Page created in 0.019 seconds with 21 queries.