Advanced search  

News:

cpg1.5.34 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.30 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Upgrade from 1.4.16 to 1.5.20  (Read 2514 times)

0 Members and 1 Guest are viewing this topic.

anglefire

  • Coppermine newbie
  • Country: 00
  • Offline Offline
  • Posts: 12
    • Disco3Club
Upgrade from 1.4.16 to 1.5.20
« on: May 05, 2012, 10:57:17 AM »

I've upgraded the gallery to the latest version and no I cannot login to do anything.

Being what I thought was clever, I turned off the gallery to stop users posting whilst I upgraded- After I'd done that I could still log in as admin.

Carried out the upgrade and ran the installer and now I just get "Gallery is currently offline - check back soon"

We are running phpBB v3.0.6. and bridging all worked before.

I've been through the documents and updated the custom style as directed and also carried out all the updates as directed.

What extra information is required?

Forum is disco3club.co.uk
Logged
Mark
Disco3Club Admin

anglefire

  • Coppermine newbie
  • Country: 00
  • Offline Offline
  • Posts: 12
    • Disco3Club
Re: Upgrade from 1.4.16 to 1.5.20
« Reply #1 on: May 05, 2012, 07:06:16 PM »

I've resent all the files again this time the install routine did the checks and said over 500 files had changed - but they are straight from the ZIP.

Carrying on with the on the assumption that the only thing that has changed is the date, and I get to stage 6. connecting with the MySQL server. Which it fails at giving the error:
Could not create a MySQL connection, please check the MySQL details entered
MySQL error: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

Checked and double checked the user and password and can't see any problems - even reset the password and that makes no difference.
Logged
Mark
Disco3Club Admin

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 13949
Re: Upgrade from 1.4.16 to 1.5.20
« Reply #2 on: May 05, 2012, 07:17:55 PM »

I'm currently not absolutely sure, but I guess you have to disable the bridge before the upgrade if it fails.

Regarding your MySQL issue there's probably something wrong with your database server configuration. First result from Google: http://www.tech-recipes.com/rx/762/solve-cant-connect-to-local-mysql-server-through-socket-tmpmysqlsock/
Logged

anglefire

  • Coppermine newbie
  • Country: 00
  • Offline Offline
  • Posts: 12
    • Disco3Club
Re: Upgrade from 1.4.16 to 1.5.20
« Reply #3 on: May 05, 2012, 10:55:24 PM »

Thanks Andre,

I can't seem to be able to find the my.cnf file.

Wish I hadn't started the upgrade now!

Mark
Logged
Mark
Disco3Club Admin

lurkalot

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 732
  • +Tinyportal Support team. +SMFArcade support team.
Re: Upgrade from 1.4.16 to 1.5.20
« Reply #4 on: May 05, 2012, 11:01:46 PM »

Hi Mark.  It might pay you to send a support ticket to your host, and see it they can resolve it TBH. 
Logged
Running SMF 2.0.7  / Tinyportal 1.0, bridged with Coppermine 1.5.28, plus cpmfetch 2.0.0

anglefire

  • Coppermine newbie
  • Country: 00
  • Offline Offline
  • Posts: 12
    • Disco3Club
Re: Upgrade from 1.4.16 to 1.5.20
« Reply #5 on: May 06, 2012, 12:34:24 AM »

Thanks Mick,

I've done that already, but they are not the quickest!

What is really annoying is that I don't see how I've changed anything! It worked before, but doesn't anymore. I can't see anything in the backup files or the database that changes the way it logs into the database.

Mark
Logged
Mark
Disco3Club Admin

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 13949
Re: Upgrade from 1.4.16 to 1.5.20
« Reply #6 on: May 06, 2012, 02:40:53 PM »

I don't think your current issue is related to the Coppermine upgrade. Try if it works when you restore your backup. Do other scripts work that connect to the same database or database server?
Logged

anglefire

  • Coppermine newbie
  • Country: 00
  • Offline Offline
  • Posts: 12
    • Disco3Club
Re: Upgrade from 1.4.16 to 1.5.20
« Reply #7 on: May 06, 2012, 10:05:34 PM »

Andre,

All sorted. It was my error setting up the config - I'd used Localhost, and it should have been changed to the correct server name.

Thanks for the help though, appreciated/
Logged
Mark
Disco3Club Admin

lurkalot

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 732
  • +Tinyportal Support team. +SMFArcade support team.
Re: Upgrade from 1.4.16 to 1.5.20
« Reply #8 on: May 06, 2012, 11:13:19 PM »

Mark, thanks for coming back with the solution, and marking your thread resolved.  ;)
Logged
Running SMF 2.0.7  / Tinyportal 1.0, bridged with Coppermine 1.5.28, plus cpmfetch 2.0.0
Pages: [1]   Go Up
 

Page created in 0.108 seconds with 19 queries.