Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Cannot redeclare class cpg_udb in /bridge/phpbb3.inc.php  (Read 3504 times)

0 Members and 1 Guest are viewing this topic.

egfg

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
Cannot redeclare class cpg_udb in /bridge/phpbb3.inc.php
« on: April 05, 2012, 09:54:16 am »

link to your site: http://www.egfg.org/photos/
a test user account: Guest
and what you have set in the bridge manager :

   short_name phpbb3
   full_forum_url http://www.egfg.org/phpBB3
   relative_path_to_config_file ../phpBB3/
   use_post_based_groups 0
   cookie_prefix phpbb3_qwroo
   use_standard_groups 1
   recovery_logon_failures 0
   recovery_logon_timestamp 2012-04-05 03:37:10

I've had nothing but trouble upgrading from phpBB2 to phpBB3. I have a new issue with bridging, although the bridge appears to work. When I execute bridge/phpbb3.inc.php I am able to Disable bridging just fine,however, when I Enable bridging for phpBB3, I get the following  error message...

Fatal error: Cannot redeclare class cpg_udb in {hidden puposely -egfg}/bridge/phpbb3.inc.php on line 41

Notes: I have edited phpbb3.inc.php to add    $this->admingroups = array(16); // mod cff3 for Coppermine to phpBB3 bridge.
          I had password trouble with MySQL and phpMyAdmin. I believe they are now in synch and I set them back to what Coppermine had originally.

UPDATE:
I did a bunch of testing tonight, learned some things, still not sure why it does that?!

- I made 2 brand new databases and propagated them with Coppermine database backups. One of them was from 3/17 (before doing the phpBB2 to phpBB3 upgrade). The other was from a backup of today's Coppermine data.

- I reapplied all the source files for Coppermine 1.5.20, then re-edited phpBB3.inc.php for $this->admingroups = array(16); // mod cff3 for Coppermine to phpBB3 bridge.

- I swapped databases through config.inc.php (several times).

- Then I tried all kinds of bridging enables, disables, etc...

Results: On two separate ocassions, the bridgemgr.php script ran completely without failing. I know the first time was when I used the 3/17 restored database. However, I can't repeat the results. Most of the time I get the error message about cpg_udb. Don't know what else I can do? Bridging works, but it just bugs me!
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Logged

egfg

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
Re: Cannot redeclare class cpg_udb in /bridge/phpbb3.inc.php
« Reply #2 on: April 05, 2012, 11:36:11 am »

Resolved. From the link posted above...
Quote
Did you clear everything out, all files except the albums folder, include/config.inc.php, anycontent.php and your custom theme before upgrading? I've seen instances similar where some old files have been left behind.

I renamed my Coppermine main directory and created a new, empty one.
Uploaded a fresh copy of version 1.5.20
Copied in config.inc.php
Edited phpBB3.inc.php for $this->admingroups = array(16);
and Moved my albums directory into the new directory.

Then I went in and tried bridgemgr.php and it worked.
Logged
Pages: [1]   Go Up
 

Page created in 0.014 seconds with 22 queries.