Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Applet Error with IE9  (Read 9503 times)

0 Members and 1 Guest are viewing this topic.

erwinds

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Applet Error with IE9
« on: November 05, 2011, 06:57:11 am »

I have 2 errors in the applet with IE9
Its in bold in debug
Quote
00115    06:28:58.352    wjhk.jupload2.JUploadApplet   [DEBUG]    Action : Bladeren ...
00116    06:28:58.352    wjhk.jupload2.JUploadApplet   [DEBUG]    Before this.uploadPolicy.createFileChooser()
00117    06:28:58.414    wjhk.jupload2.JUploadApplet   [DEBUG]    Starting JUploadFileChooser constructor
00118    06:28:58.414    wjhk.jupload2.JUploadApplet   [DEBUG]    After this.uploadPolicy.createFileChooser()
00119    06:29:00.863    pool-6-thread-1   [ERROR]    [wjhk.jupload2.exception.JUploadIOException:java.io.FileNotFoundException] ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}\::{416651E4-9C3C-11D9-8BDE-F66BAD1E3F3A} (Het systeem kan het

opgegeven pad niet vinden) (An error occured while loading the image for C:\Users\Erwin\Desktop\::{20D04FE0-3AEA-1069-A2D8-08002B30309D}\::{416651E4-9C3C-11D9-8BDE-F66BAD1E3F3A})
00120    06:29:00.863    pool-6-thread-1       wjhk.jupload2.exception.JUploadIOException: An error occured while loading the image for C:\Users\Erwin\Desktop\::{20D04FE0-3AEA-1069-A2D8-08002B30309D}\::{416651E4-9C3C-11D9-8BDE-

F66BAD1E3F3A}
00120    06:29:00.863    pool-6-thread-1          at wjhk.jupload2.filedata.PictureFileData.getImageIcon(PictureFileData.java:892)
00120    06:29:00.863    pool-6-thread-1          at wjhk.jupload2.policies.PictureUploadPolicy.fileViewGetIcon(PictureUploadPolicy.java:771)
00120    06:29:00.863    pool-6-thread-1          at wjhk.jupload2.gui.IconWorker.loadIcon(JUploadFileView.java:159)
00120    06:29:00.863    pool-6-thread-1          at wjhk.jupload2.gui.IconWorker.run(JUploadFileView.java:184)
00120    06:29:00.863    pool-6-thread-1          at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
00120    06:29:00.863    pool-6-thread-1          at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
00120    06:29:00.863    pool-6-thread-1          at java.lang.Thread.run(Unknown Source)
00120    06:29:00.863    pool-6-thread-1       Caused by: java.io.FileNotFoundException: ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}\::{416651E4-9C3C-11D9-8BDE-F66BAD1E3F3A} (Het systeem kan het opgegeven pad niet vinden)
00120    06:29:00.863    pool-6-thread-1          at java.io.RandomAccessFile.open(Native Method)
00120    06:29:00.863    pool-6-thread-1          at java.io.RandomAccessFile.<init>(Unknown Source)
00120    06:29:00.863    pool-6-thread-1          at javax.imageio.stream.FileImageInputStream.<init>(Unknown Source)
00120    06:29:00.863    pool-6-thread-1          at wjhk.jupload2.filedata.PictureFileData.getImageIcon(PictureFileData.java:887)
00120    06:29:00.863    pool-6-thread-1          ... 6 more
00121    06:29:00.863    pool-6-thread-1       Caused by:
00122    06:29:00.863    pool-6-thread-1       java.io.FileNotFoundException: ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}\::{416651E4-9C3C-11D9-8BDE-F66BAD1E3F3A} (Het systeem kan het opgegeven pad niet vinden)
00122    06:29:00.863    pool-6-thread-1          at java.io.RandomAccessFile.open(Native Method)
00122    06:29:00.863    pool-6-thread-1          at java.io.RandomAccessFile.<init>(Unknown Source)
00122    06:29:00.863    pool-6-thread-1          at javax.imageio.stream.FileImageInputStream.<init>(Unknown Source)
00122    06:29:00.863    pool-6-thread-1          at wjhk.jupload2.filedata.PictureFileData.getImageIcon(PictureFileData.java:887)
00122    06:29:00.863    pool-6-thread-1          at wjhk.jupload2.policies.PictureUploadPolicy.fileViewGetIcon(PictureUploadPolicy.java:771)
00122    06:29:00.863    pool-6-thread-1          at wjhk.jupload2.gui.IconWorker.loadIcon(JUploadFileView.java:159)
00122    06:29:00.863    pool-6-thread-1          at wjhk.jupload2.gui.IconWorker.run(JUploadFileView.java:184)
00122    06:29:00.863    pool-6-thread-1          at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
00122    06:29:00.863    pool-6-thread-1          at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
00122    06:29:00.863    pool-6-thread-1          at java.lang.Thread.run(Unknown Source)


00275    06:29:52.546    FileUploadThreadHTTP   [DEBUG]    -------- Response Headers Start --------
00276    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    HTTP/1.1 200 OK
00277    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    Date: Sat, 05 Nov 2011 05:29:52 GMT
00278    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    Server: Apache/2.2.11 (Win32) PHP/5.2.8
00279    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    X-Powered-By: PHP/5.2.8
00280    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    Set-Cookie: f24d9894146b98cc05268080a55c6365=21d0d5eacbfecea73549272013562323; expires=Sat, 19-Nov-2011 05:29:52 GMT; path=/
00281    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    Calling this.cookies.parseCookieHeader, with parameter: f24d9894146b98cc05268080a55c6365=21d0d5eacbfecea73549272013562323; expires=Sat, 19-Nov-2011 05:29:52 GMT; path=/
00282    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    Cookie header parsed.
00283    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    Content-Length: 258
00284    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    Connection: close
00285    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    Content-Type: text/html
00286    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    
00287    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    --------- Response Headers End ---------
00288    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    -------- Response Body Start --------
00289    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    //[DEBUG] The current Coppermine version is 1.4.x<BR>
00289    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    //[DEBUG] jupload_user_may_use_jupload is false<BR>
00289    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    ERROR: U heft niet voldoende rechten voor deze actie.\n\nGelieve eerst in te loggen: <a href="login.php?referer=plugins/jupload/jupload.php">login</a>
00290    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    -------- Response Body End --------
00291    06:29:52.827    FileUploadThreadHTTP   [DEBUG]    HTTP status: 200 OK
00292    06:29:52.827    FileUploadThreadHTTP   [WARN]    Non resumable error occured, exiting...
00293    06:29:56.946    FileUploadThreadHTTP   [ERROR]    [wjhk.jupload2.exception.JUploadExceptionUploadFailed] U heft niet voldoende rechten voor deze actie.
00293    06:29:56.946    FileUploadThreadHTTP   [ERROR]    
00293    06:29:56.946    FileUploadThreadHTTP   [ERROR]    Gelieve eerst in te loggen: <a href="login.php?referer=plugins/jupload/jupload.p
00293    06:29:56.946    FileUploadThreadHTTP   [ERROR]    hp">login</a> (Upload afgebroken met fouten
00293    06:29:56.946    FileUploadThreadHTTP   [ERROR]    
00293    06:29:56.946    FileUploadThreadHTTP   [ERROR]    U heft niet voldoende rechten voor deze actie.
00293    06:29:56.946    FileUploadThreadHTTP   [ERROR]    
00293    06:29:56.946    FileUploadThreadHTTP   [ERROR]    Gelieve eerst in te loggen: <a href="login.php?referer=plugins/jupload/jupload.p
00293    06:29:56.946    FileUploadThreadHTTP   [ERROR]    hp">login</a>)


Logged

etienne_sf

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: Applet Error with IE9
« Reply #1 on: November 26, 2011, 02:11:54 pm »

Strange,

  Lots of user, but only you who add troubles.


Can you check this URL :
http://my_local.lesgauthier.fr/eclipse/jupload/target/site/applet-basic.html

Just tell me if the applet works Ok, there.

Etienne
Logged

erwinds

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Applet Error with IE9
« Reply #2 on: November 26, 2011, 03:32:17 pm »

sorry bad the link dosn't work!!!
Logged

etienne_sf

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: Applet Error with IE9
« Reply #3 on: November 28, 2011, 11:33:22 am »

Right, sorry.

  It was the URL for my test site, local on my computer.


The correct URL is:
http://jupload.sourceforge.net/applet-basic.html
Logged

erwinds

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Applet Error with IE9
« Reply #4 on: November 30, 2011, 10:55:02 am »

link is now ok.
the basic applet is ok but the picture mode is a problem
Logged

etienne_sf

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: Applet Error with IE9
« Reply #5 on: November 30, 2011, 04:38:00 pm »

Hi,

  The problem seems to be the same as the one in the http://forum.coppermine-gallery.net/index.php/topic,73865.0.html thread.

  It looks like an old point I managed. But I could not find it.

Can you try to change the browsingDirectory JUpload configuration parameter to something like "c:\" ?

Etienne

Logged

etienne_sf

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: Applet Error with IE9
« Reply #6 on: December 01, 2011, 09:46:38 am »

Hi,

  I could not find track of this issue. But I'm rather sure it happened ... and was solved.

  I tested with IE 9, on windows 7 64 bits, with IE9 and Java 64 bits, then IE9 and Java 32 bits. It worked Ok. It was with the last applet version.

Two questions:
1) What is your OS : windows 7, Vista, XP  ...  ?
2) Can you post me a JPF file, so that I can test with it? I have none. Perhaps this is the real problem... ?


  Then, can you do another test, based on the demo site of the JUpload applet (embedded in the JUpload Coppermine plugin).

Try this URL, with the 'browsingDirectory' applet parameter, set to "C:\"  (you'll get an error on applet initialization, then to the 'Test with these parameters...' button, at the end of the page, and it should then work Ok).
http://jupload.sourceforge.net/advanced_js_demo.html?postURL=upload_dummy.html&maxChunkSize=500000&uploadPolicy=PictureUploadPolicy&maxFileSize=&nbFilesPerRequest=&appletHeight=300&appletWidth=640&debugLevel=100&lang=&lookAndFeel=&showLogWindow=true&showStatusBar=&allowHttpPersistent=&filenameEncoding=&httpUploadParameterName=&httpUploadParameterType=&readCookieFromNavigator=&retryMaxNumberOf=&retryNbSecondsBetween=&sendMD5Sum=&serverProtocol=HTTP%2F1.1&specificHeaders=&sslVerifyCert=&afterUploadTarget=&afterUploadURL=&allowedFileExtensions=&browsingDirectory=C%3A\&fileFilterName=&formdata=&stringUploadError=&stringUploadSuccess=&urlToSendErrorTo=&fileChooserIconFromFileContent=&fileChooserIconSize=&fileChooserImagePreview=&highQualityPreview=&pictureTransmitMetadata=&maxPicHeight=&maxPicWidth=&realMaxPicHeight=&realMaxPicWidth=&targetPictureFormat=&keepOriginalFileExtensionForConvertedImages=

Please post debug log here, if any error ocurr

Etienne
Logged

erwinds

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Applet Error with IE9
« Reply #7 on: December 01, 2011, 01:10:46 pm »

Hi,

I try this but I have errors
os: win 7
browser: IE9
In debug_log.txt on line 00118 is the error.

Erwin
Logged

etienne_sf

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: Applet Error with IE9
« Reply #8 on: December 03, 2011, 12:38:21 pm »

Hi,

  That's a strange one. I was sure I corrected this one.  >:(

I now test properly if the file can be read, before trying to display its icon, in the file chooser.

It should be ok, but I can't check it, as I don't have the issue.


Can you replace the YourCoppermineInstallationRoot/plugins/jupload/wjhk.jupload.jar file by the file of the same name, in the attached zip file?
If it works properly (it should), I'll create a new release.

Regards
Etienne
Logged

erwinds

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Applet Error with IE9
« Reply #9 on: December 03, 2011, 05:15:11 pm »

hi,

the file chooser is ok now, but now I have an error in "upload" on line 00456
Logged

etienne_sf

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: Applet Error with IE9
« Reply #10 on: December 03, 2011, 05:46:44 pm »

Hi,

  I guess Ga naar de beginpagina means 'go to the login page'.

So the applet didnt' read the user session. This seems quite strange, as I didn't change anything in this part of the a. Did you properly do the whole process: close the browser, go back into it authenticate to your Coppermine site, go to the JUpload page, then execute this upload?

  If yes, I'm really surprised. No problem on authentication was reported, since a very long time.

If yes, questions:
- Are you in bridge mode ?
- Anything special in your configuration stuff, around login/authentication ?
- Can you do the same test, with the previous wjhk.jupload.jar ? (available in the last release)


My test box seems to be broken. As (too) often, I'll try a reboot. I first post this first reply.

Etienne
Logged

erwinds

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Applet Error with IE9
« Reply #11 on: December 04, 2011, 02:00:52 pm »

hi,

If yes, questions:
- Are you in bridge mode ? NO
- Anything special in your configuration stuff, around login/authentication ? NO
- Can you do the same test, with the previous wjhk.jupload.jar ? (available in the last release) It's the same

In firefox it's ok only in IE9 it doesn't work.
Logged

etienne_sf

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: Applet Error with IE9
« Reply #12 on: December 05, 2011, 11:15:49 pm »

Hi,

  I could not access from my test box, from my Windows 7 / IE9 PC.   :-(
My test box is my pro PC, and it contains some specific protection against access from other computer.


So ...  I'm creating a 1.5.x Coppermine demo installation. I should have done that before.
When it's Ok, I'll try again with IE9.

Etienne
Logged

erwinds

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Applet Error with IE9
« Reply #13 on: December 05, 2011, 11:48:43 pm »

hi,

Can you send a message when the demo is done
Logged

etienne_sf

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: Applet Error with IE9
« Reply #14 on: December 10, 2011, 02:11:03 pm »

Hi,

  The demo will be done ... I hope. My mysql database is not activated, in my ISP servers. And it answer : will be ok next day, since several days.


  BTW, I checked between two PC, should have been simple, but was really complex due to various stuff. I had no trouble with IE9 (64 bits), when trying to upload on Coppermine website, under the admin account.
  My opinion is that there is something special in your configuration. Otherwise, I would already have lots of such issues, being raised.

Please notice that I changed one thing, in IE configuration : in the Internet Options / Security, I deactivated the protected mode. I think there is no link ... but it's worth a try.
 (just a try, as I guess that the 'protected' mode is more secure....)

  If you still have the problem, can you provide me a test environment,with a login/password ? If yes, please provide this information on my mail : etiennegauthier at free.fr

Etienne
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 21 queries.