Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Batch Add reverts to 'userpics' - my config says 'uploads'  (Read 14059 times)

0 Members and 1 Guest are viewing this topic.

Charlie-brm

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Batch Add reverts to 'userpics' - my config says 'uploads'
« on: February 04, 2012, 05:01:34 am »

My config file settings have the folders to look in referred to as
The Album directory   albums/
Directory for user files   uploads/

Batch add files dialog shows the following depending on my choice of Browsable Interface:
Browsable Interface Yes - shows albums above a blank dialog box and no folder tree
Browsable Interface No  - shows a hyperlink to userpics  on a smaller box and no folder tree

It's like 'userpics' is hard coded somewhere because none of my settings ever contain it and I've always used Batch Add. I've run Coppermine for 5 years.
This Batch Add problem started when I switched hosting and this host company uses IIS,

Coppermine 1.5.18 Stable
All my pre-existing photos are in my own folder structure under albums/uploads/
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: Batch Add reverts to 'userpics' - my config says 'uploads'
« Reply #1 on: February 04, 2012, 06:33:41 pm »

What's the actual issue? If you use batch-add those setting shouldn't affect anything.
Logged

Charlie-brm

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: Batch Add reverts to 'userpics' - my config says 'uploads'
« Reply #2 on: March 06, 2012, 11:06:57 pm »

Issue is that /userpics is the only folder offered to me in the Batch Add Files dialog and we are "not allowed" to put files there by FTP, so I don't. All that is in /userpics is the warning text file.

The Batch Add Files dialog does not have the facility to get me up a folder level to albums so I could navigate to albums/uploads to show the files I put in new folders using FTP.
Logged

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: Batch Add reverts to 'userpics' - my config says 'uploads'
« Reply #3 on: March 07, 2012, 10:19:56 am »

The batch-add interface hides the following files and directories by default:
Code: [Select]
$hiddenfolders = array('.', '..', '.svn', 'edit', 'Thumbs.db', '.DS_Store', '__MACOSX', '.htaccess', rtrim($CONFIG['userpics'],'/'));
So if your current setting for "Directory for user files" is "uploads/", that folder will be hidden as well. If just "userpics" is displayed, there's probably no other directory, except the hidden directories. Just create some directories with your FTP application and they should be displayed in the minibrowser. If not, please attach screenshots of both "batch add files" dialogs (with and without the browsable interface) and also a screenshot showing the content of your albums directory in your FTP application.
Logged
Pages: [1]   Go Up
 

Page created in 0.014 seconds with 21 queries.