Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Problem beim Installieren (TYPE vs ENGINE)  (Read 4824 times)

0 Members and 1 Guest are viewing this topic.

wrchto

  • Coppermine newbie
  • Country: at
  • Offline Offline
  • Gender: Male
  • Posts: 4
    • Photography by Thomas Hauser
Problem beim Installieren (TYPE vs ENGINE)
« on: July 29, 2011, 09:06:34 am »

Grüß Euch!

Nachdem ich neu bin, erstmal ein "Hallo" an alle.
Ich habe leider bei der Installation das Problem, dass mit folgendem Fehler abgebrochen wird:

mySQL Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM COMMENT='Used to store sessions'' at line 7 on query ' CREATE TABLE IF NOT EXISTS cpg14x_sessions ( session_id varchar(40) NOT NULL default '', user_id int(11) default '0', time int(11) default NULL, remember int(1) default '0', PRIMARY KEY (session_id) ) TYPE=MyISAM COMMENT='Used to store sessions'' Lt. Internet verwendeten ältere Versionen von MySQL das Schlüsselwort TYPE statt ENGINE (Beispiel: TYPE = MYISAM). MySQL 5.0 sollte das abwärtskompatibel unterstützen, es wird jedoch die Verwendung von ENGINE empfohlen.

Wenn ich direkt in die Datenbank gehe, und den Befehl dort händisch absetze, erhalte ich denselben Fehler. Wenn ich jedoch TYPE durch ENGINE ersetze, dann kann ich die Tabelle anlegen.

Was kann ich Eurer Meinung nach tun?

LG
Thomas
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15425
Re: Problem beim Installieren (TYPE vs ENGINE)
« Reply #1 on: July 29, 2011, 09:12:34 am »

Zunächst solltest du cpg1.5.x installieren anstatt das in die Jahre gekommene, nicht mehr supportete cpg1.4.x. Dort sollte der Fehler auch nicht mehr auftauchen.
Logged

wrchto

  • Coppermine newbie
  • Country: at
  • Offline Offline
  • Gender: Male
  • Posts: 4
    • Photography by Thomas Hauser
Re: Problem beim Installieren (TYPE vs ENGINE)
« Reply #2 on: July 29, 2011, 09:29:06 am »

Ach so, ich hab eigentlich bewusst 1.4.27 gewählt, weil das bei den Downloads als "stable" bezeichnet ist (letztes modify von 2010) und bei 1.5.x nichts dabei steht. Daher hat 1.5.x für mich den Status von Beta erweckt.
Ich werde es mal mit dem neueren Paket probieren.

Danke
Thomas
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15425
Re: Problem beim Installieren (TYPE vs ENGINE)
« Reply #3 on: July 29, 2011, 09:47:57 am »

Ich werde es entsprechend verschieben. Danke für den Hinweis.
Logged
Pages: [1]   Go Up
 

Page created in 0.014 seconds with 20 queries.