Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: 1 2 3 [4] 5   Go Down

Author Topic: Social Sharing Plugin (Facebook Like/FB Share/FB Comments/Twitter/VZ zeigen)  (Read 76989 times)

0 Members and 1 Guest are viewing this topic.

alanz01

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 20
  • http://www.alanzeleznikar.com/photography
    • Alan R Zeleznikar Photography

Hi,

I am trying to get this to work but I am getting an error from Facebook when I click on the "Like" icon.

Quote
The app ID specified within the "fb:app_id" meta tag is not allowed on this domain. You must setup the Connect Base Domains for your app to be a prefix of http://www.alanzeleznikar.com/photography/displayimage-8-264.html?pid=264.

In the plug-in configuration screen I have my Facebook User ID included in the Fecbook USer ID page adminstrators entry. The next configuration item says "AppId of a Facebook App in whose context the page belongs. Facebook asks to set either this or an Admin Facebook User IDs as part of the OpenGraph tags." I interpreted that as meaning if I have my user ID in the field above this one I don't need anything for this field.

What am I doing wrong?

Thanks

http://www.alanzeleznikar.com/photography
Logged
CPG 1.5.12 / Curve Theme / modified color scheme
Plugins (in order):
 - External Tracker 2.6
 - Social Sharing 1.5
 - First Visit Hint 1.0
 - Add Meta Description 1.5
 - SEF URLs
 - Image Preloader 1.4

TeknoSounds

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 83
    • TeknoSounds

I'm not certain about using just an admin ID, but you could simply create an app in the FB Developers area.  It's pretty simple to do, then can use that appID.

TeknoSounds

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 83
    • TeknoSounds

Hey 1ab,

It appears FB updated their comment code again in the past couple of days.  Broke the CSS I had going and the ability for it to email me when comments were made :( 
Looks like gotta figure out things again *sigh*

alanz01

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 20
  • http://www.alanzeleznikar.com/photography
    • Alan R Zeleznikar Photography

OK, I created a placeholder Facebook app to get an app ID, entered it into the appropriate field on the configuraiton page. If I click "Like" I get an error from Facebook but it looks like the "Like" is passed through to my Facebook page. So I guess it works but not as elegantly as it could, maybe...

http://www.alanzeleznikar.com/photography
Logged
CPG 1.5.12 / Curve Theme / modified color scheme
Plugins (in order):
 - External Tracker 2.6
 - Social Sharing 1.5
 - First Visit Hint 1.0
 - Add Meta Description 1.5
 - SEF URLs
 - Image Preloader 1.4

TeknoSounds

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 83
    • TeknoSounds

Need to add Google +1 now.
Also I think I could tweek the email script to add comments to the DB as well so Last Comments still works and all.  Will have to work on that.

but, 1ab's account is now listed as guest? Guess he deleted it or something? :(

Bleh.

Αndré

  • Administrator
  • Coppermine addict
  • *****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15428

but, 1ab's account is now listed as guest? Guess he deleted it or something? :(
I don't know what happened. Afaik users cannot delete their accounts themselves. Hopefully it wasn't deleted by some of our anti-spam-mechanisms :o

I just sent him an email.
« Last Edit: July 21, 2011, 09:29:41 am by Αndré »
Logged

baba12345

  • Coppermine newbie
  • Offline Offline
  • Posts: 13

Hi,

when I press Like button, I get error, when I click on error I get this message.

Quote
The app ID specified within the "fb:app_id" meta tag is not allowed on this domain. You must setup the Connect Base Domains for your app to be a prefix of http://balochnature.com/displayimage.php?pid=380.

I have created a facebook appid and I inserted appid and my facebook id in the settings.

Logged

mykee

  • Contributor
  • Coppermine frequent poster
  • ***
  • Country: hu
  • Offline Offline
  • Gender: Male
  • Posts: 140
    • One moment from Hungary

I have problem with this plugin. Worked in a few days, but at today not send title and description to Facebook. FB get standard title tag and link, and no get meta settings. Plus thumbnail on FB not same like picture... Like OpenGraph not working or FB not read OG tags...
What's my problem?
Please check it, here is my link for a sample picture: http://foto.acegem.hu/displayimage.php?album=lastup&cat=0&pid=911
« Last Edit: November 07, 2011, 12:18:45 pm by mykee »
Logged
My gallery and demo for AnythingSlider, Photocols and CollagePlus plugin: http://foto.acegem.hu/index.php

mykee

  • Contributor
  • Coppermine frequent poster
  • ***
  • Country: hu
  • Offline Offline
  • Gender: Male
  • Posts: 140
    • One moment from Hungary
Logged
My gallery and demo for AnythingSlider, Photocols and CollagePlus plugin: http://foto.acegem.hu/index.php

mykee

  • Contributor
  • Coppermine frequent poster
  • ***
  • Country: hu
  • Offline Offline
  • Gender: Male
  • Posts: 140
    • One moment from Hungary

A plus information more: if "Include detailed OpenGraph metatags for restricted content?" option is enabled, then correct thumbnail will show on post. But if this off, then will show a picture thumbnail what before actual image.
I hope help to you for debug.
Logged
My gallery and demo for AnythingSlider, Photocols and CollagePlus plugin: http://foto.acegem.hu/index.php

mykee

  • Contributor
  • Coppermine frequent poster
  • ***
  • Country: hu
  • Offline Offline
  • Gender: Male
  • Posts: 140
    • One moment from Hungary

Ok, I don't understand a thing:
- If I select to default theme from any original theme, or NoteBored theme, then FB public will work correctly.
- If I select my generated theme (fotosarokA and FotosarokB), then meta tags there, but FB not published correctly.
I try replace theme.php, template.html or style.css in my themes, but nothing happened. Where is my problem??? My code is valid, labels in template.html is correct, and theme.php with empty content not solved my problem. But this plugin will work only original themes...
Need modify this plugin, or...?

OK, here is my solution:
In my theme.php was a line:
define('THEME_HAS_PROGRESS_GRAPHICS', 1);

If this line removed, then share working correctly!!! I haven't progress graphics in my templates.
Sorry my posts, but if anyone have same problem, need search in template files!
« Last Edit: November 07, 2011, 10:31:34 pm by mykee »
Logged
My gallery and demo for AnythingSlider, Photocols and CollagePlus plugin: http://foto.acegem.hu/index.php

mykee

  • Contributor
  • Coppermine frequent poster
  • ***
  • Country: hu
  • Offline Offline
  • Gender: Male
  • Posts: 140
    • One moment from Hungary

I'll give up.  :-\ At yesterday final publish pictures from my site correctly. Today not. Same problem: if original or NoteBored template setting to default, publish is ok, but mine templates not. But nothing changed from yesterday. If publish will correct, then I see an Error from facebook: my URL is blocked.  :o
I'll give up.
Logged
My gallery and demo for AnythingSlider, Photocols and CollagePlus plugin: http://foto.acegem.hu/index.php

mykee

  • Contributor
  • Coppermine frequent poster
  • ***
  • Country: hu
  • Offline Offline
  • Gender: Male
  • Posts: 140
    • One moment from Hungary

And next bug (or something): I like a picture at friday, now tuesday, but I not see my like under picture. Lost my like or other problem?
Like again, and get Error with this comment:
Quote
The content you're trying to share includes a link that's been blocked for being spammy or unsafe:<br /><br />Body of an error/warning message. Title is: Sorry, this post contains a blocked URL<br /><br />For more information, visit the <a href="http://www.facebook.com/help/">Help Center</a>. If you think you're seeing this by mistake, please <a href="/help/contact.php?show_form=block_appeal">let us know</a>.
I think facebook cached my page, because this picture was liked with correct labels, and re-like was ok, but if like older (not liked) picture, I get problem again.

If delete UserID for admin, then work correctly again. I don't understand what's happened. ID is mine.
« Last Edit: November 08, 2011, 11:18:37 am by mykee »
Logged
My gallery and demo for AnythingSlider, Photocols and CollagePlus plugin: http://foto.acegem.hu/index.php

mr.bena

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 117

Hi I use Social Sharing plugin " cpg1.5.x_plugin_social-sharing_v1.5.zip ". It is very great but below the comment box, facebook shows message like this--

"Warning: this comments plugin is operating in compatibility mode, but has no posts yet. Consider specifying an explicit 'href' as suggested in the comments plugin documentation to take advantage of all plugin features."

I have seen some coppermine user, who use this plugin without having this message below their facebook comment box. Please give me some suggestion to remove this message.

Ben.
Logged

flapane

  • Contributor
  • Coppermine frequent poster
  • ***
  • Country: it
  • Offline Offline
  • Gender: Male
  • Posts: 249
    • Flavio's page

Any way to avoid this w3c error? I wonder if Facebook is still using non-compliant html tags as of today.

Line 9, Column 16: there is no attribute "property"

source:
$socialmeta .= '<meta property="og:site_name" content="'.$CONFIG['gallery_name'].'" />'.$newline;

flapane

  • Contributor
  • Coppermine frequent poster
  • ***
  • Country: it
  • Offline Offline
  • Gender: Male
  • Posts: 249
    • Flavio's page

An integration to your plugin: it allows to show the last Disqus comments in the gallery.
Hope it helps http://forum.coppermine-gallery.net/index.php/topic,75871.0.html

mitko

  • Coppermine frequent poster
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 112
    • World of Lighthouses

I use this plugin for FB commenting. Recently got the message from FB:
Your app, Lightphotos.net comments, needs to be updated for the February 2013 Breaking Changes.
Once your app is compliant, set the migration setting to "Enabled" in the Advanced section of the App Dashboard.
These changes will be permanently enabled for all apps in 1 day on 6 feb 2013.
Details here:
https://developers.facebook.com/roadmap/#february-2013
What needs to be done from the plugin side?

kylemj

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25

I seem to be stuck with this error messages under facebook comments

Quote
Warning: this comments plugin is operating in compatibility mode, but has no posts yet. Consider specifying an explicit 'href' as suggested in the comments plugin documentation to take advantage of all plugin features.
Logged

kylemj

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25

I do not fully understand programming but after a few days of trying to get the href message it seems to have gone

in codebase.php

Code: [Select]
$links = '<span id="plugin_social-sharing"'.$CONFIG['plugin_social-sharing_span_attr'].'>';
if($CONFIG['plugin_social-sharing_fblikeb_js'] || $CONFIG['plugin_social-sharing_fbcomments']) {
$links .= '<div id="fb-root">';
//  $links .= '<script type="text/javascript" src="http://static.ak.fbcdn.net/connect/en_US/core.debug.js"></script>';
$links .= '<script type="text/javascript" src="http://connect.facebook.net/'.$lang_social_sharing['fblangcode'].'/all.js"></script>';
$links .= '<script type="text/javascript">FB.init({'.($CONFIG['plugin_social-sharing_fb_appid'] != '' ? 'appId : \''.$CONFIG['plugin_social-sharing_fb_appid'].'\', ' : '').' status : true, cookie: true, xfbml : true });</script>';
$links .= '</div>';

and replace
Code: [Select]
$links = '<span id="plugin_social-sharing"'.$CONFIG['plugin_social-sharing_span_attr'].'>';
if($CONFIG['plugin_social-sharing_fblikeb_js'] || $CONFIG['plugin_social-sharing_fbcomments']) {
$links .= '<div id="fb-root">';
//  $links .= '<script type="text/javascript" src="http://static.ak.fbcdn.net/connect/en_US/core.debug.js"></script>';
$links .= '<script type="text/javascript" src="//connect.facebook.net/en_US/all.js#xfbml=1"></script>';
$links .= '<script type="text/javascript">FB.init({'.($CONFIG['plugin_social-sharing_fb_appid'] != '' ? 'appId : \''.$CONFIG['plugin_social-sharing_fb_appid'].'\', ' : '').' status : true, cookie: true, xfbml : true });</script>';
$links .= '</div>';

The only line was changed was
from http://connect.facebook.net/'.$lang_social_sharing['fblangcode'].'/all.js

to //connect.facebook.net/en_US/all.js#xfbml=1
Logged

kylemj

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25

No i got that comment bit sorted how to i change the title on facebook. It displays the file name. It looks like there is a section in codebase.php but tried changing some of the text but can't figure it out
Logged
Pages: 1 2 3 [4] 5   Go Up
 

Page created in 0.028 seconds with 21 queries.