Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: E-Mail Versand funktioniert nicht  (Read 4176 times)

0 Members and 1 Guest are viewing this topic.

Matthias002

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
    • Gallery
E-Mail Versand funktioniert nicht
« on: December 15, 2010, 12:09:04 pm »

Hallo,

das ist meine letzte Frage damit die Coppermine Gallery zu 100% bei mir funktioniert.
Ich hatte zum Abschluss getestet, wie die Benutzerregistrierung funktioniert, dabei ist mir leider aufgefallen, das keinerlei E-MAil versand werden können.

Unter dem admin Menüpunkt Email-Einstellungen, habe ich nichts eingetragen damit Sendmail funktionieren sollte, aber es geht leider nicht.

Code: [Select]
/include/mailer.inc.php

    * CPG Notice line 1695: Konnte Mail-Funktion nicht etablieren.

/include/logger.inc.php

    * Warning line 63: fopen(logs/mail.log.php) [function.fopen]: failed to open stream: Permission denied
    * Warning line 64: fwrite(): supplied argument is not a valid stream resource
    * Warning line 65: fwrite(): supplied argument is not a valid stream resource
    * Warning line 66: fclose(): supplied argument is not a valid stream resource

Kennt jemand das Problem und kann mir helfen?

MFG

Matthias
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: E-Mail Versand funktioniert nicht
« Reply #1 on: December 15, 2010, 12:24:26 pm »

Falls das die Galerie ist um die es sich handelt, aktiviere bitte das Kontaktformular und den Debug-Modus.
Logged

Matthias002

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
    • Gallery
Re: E-Mail Versand funktioniert nicht
« Reply #2 on: December 15, 2010, 12:27:57 pm »

Ok, ich habe beides eingeschaltet.

mfg

matthias
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: E-Mail Versand funktioniert nicht
« Reply #3 on: December 15, 2010, 12:44:53 pm »

Quote
Error
Failed to send email. Please try again later.

File: /is/htdocs/wp1014951_8I3EAGDIHA/www/gallery/contact.php - Line: 211

Wenn ich nach der Fehlermeldung "Could not instantiate mail function." google, kommt dort als Antwort, dass bei die kein sendmail installiert ist. Frag bei deinem Provider wie du E-Mails versenden kannst.
Logged

Matthias002

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
    • Gallery
Re: E-Mail Versand funktioniert nicht
« Reply #4 on: December 15, 2010, 01:18:50 pm »

Ich habe gerade beim Provider angerufen, er hat gemeint das meine Sendmaileinstellungen im Account alle richtig sind. (Sie Funktionieren mit meinen anderen Homepages).
Ich soll mal den Pfad von Sendmail vergleichen, ob er in der Coppermine Gallery richtig hinterlegt ist.

Ich weiß aber leider nicht wo er in der Gallery zu sehen ist, um ihn zu vergleichen.

MFg

Matthias
Logged

Αndré

  • Administrator
  • Coppermine addict
  • ****
  • Country: de
  • Offline Offline
  • Gender: Male
  • Posts: 15369
Re: E-Mail Versand funktioniert nicht
« Reply #5 on: December 15, 2010, 01:44:20 pm »

Ich habe mir gerade nochmal den Quelltext von include/mailer.inc.php angesehen. Wenn du keine SMTP-Daten eingibst, wird die PHP-eigene Funktion mail() benutzt um E-Mails zu versenden. Sendmail wird also nicht direkt aufgerufen, weshalb der Pfad meiner Meinung nach auch nicht falsch sein kann (sorry für die Falschinformation). Kannst du denn zur Not auch E-Mails per SMTP verschicken, falls es mit der mail()-Funktion erstmal nicht funktioniert?
Logged

Matthias002

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 14
    • Gallery
Re: E-Mail Versand funktioniert nicht
« Reply #6 on: December 15, 2010, 01:49:04 pm »

ich habe es jetzt hinbekommen, das die Mails per smtp verschickt werden können.

Vielen Dank für deine Hilfe.

Mfg

matthias
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 21 queries.