Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: La versión 1.4.x quedará sin soporte en breve  (Read 2914 times)

0 Members and 1 Guest are viewing this topic.

jmatute

  • Moderator
  • Coppermine frequent poster
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 453
La versión 1.4.x quedará sin soporte en breve
« on: September 06, 2010, 12:23:55 pm »

Después de muchas lunas de servicio ha llegado la hora de decir adiós a Coppermine 1.4.x. Con la nueva línea 1.5.x en marcha tenemos la sensación de que tenemos el mejor paquete, cargado de funcionalidad y de características de seguridad que se puede tener. Y un grupo de soporte pequeño como el nuestro sólo puede ocuparse de mantener la última versión. Por tanto hemos decidido con mucha antelación avisarte de que mandamos la línea de la 1.4.x a dormir el sueño de los justos.

¿Cuándo?

La triste fecha será el 1 de diciembre de 2010. A partir de entonces vamos a impedir crear nuevas hebras en todos los foros de soporte 1.4.x.

¿Qué debemos hacer los propietarios de sitios web?

Eso depende de tí. Coppermine 1.4.x no dejará de funcionar después de la fecha fatídica. Pero si encuentras cualquier tipo de problemas por desgracia la solución correrá por tu cuenta. Además no habrá actualizaciones de seguridad disponibles así que tú verás qué riesgo quieres correr si se descubren nuevas vulnerabilidades.

La actualización es fácil y hay muy pocas razones para no actualizar a la línea 1.5.x.

¿Qué debo hacer si soy desarrollador de un plugin o un tema?

Si has creado un plugin o un tema, lo primero es darte las gracias por tu arduo trabajo y tu contribución a la comunidad Coppermine. Pero te instamos a que continúes tu esfuerzo y que actualices tu creación para que sea compatible con 1.5.x. En muchos casos los cambios de código son pocos y fáciles, mientras que otros pueden requerir un poco más de tiempo.

Incluso si no eres es el autor de una pieza en particular pero tienes conocimientos te invitamos a ayudar en la migración a la nueva versión. Todas las contribuciones son muy apreciadas ya sean de un nuevo plugin o tema, una actualización de alguno de los existentes, un nuevo fichero de idioma o cualquier cosa que sea útil a la comunidad.

¿Qué pasa con los mods?

No hay nada que te impida crear mods, pero con un nuevo motor de plugins es preferible pensarse dos veces si merece la pena la implementación de tu idea como una modificación del código. En el 99% de los casos un mod puede ser sustituido por un plugin. Cuando no sea posible estamos dispuestos a aceptar sugerencias para crear un nuevo hook para para permitir que tu modificación se pueda hacer en un plugin. Si necesitas ayuda, pregunta en el foro, por favor, y haremos todo lo posible para ayudarle.

Hemos disfrutado mucho tiempo con la 1.4.x y esperamos que tú también. Deseamos a toda la comunidad los mismas satisfacciones con sus sitios web en versión 1.5.x.

Versión original en inglés aquí

[edit: jmatute 2010-11-11]Corregidos un error ortográfico y otro de traducción[/edit: jmatute]
« Last Edit: November 11, 2010, 05:14:23 am by jmatute »
Logged
Pages: [1]   Go Up
 

Page created in 0.013 seconds with 22 queries.