Advanced search  

News:

cpg1.5.46 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter recently discovered vulnerabilities. It is important that all users who run version cpg1.5.44 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: member galleries after bridging  (Read 2802 times)

0 Members and 1 Guest are viewing this topic.

heavensportal

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 240
    • The Fantasy Attic
member galleries after bridging
« on: August 21, 2010, 11:34:31 pm »

hopefully there is something i can do to fix this, but ...

after I bridged the gallery to smf 1.0+ I noticed that all the member galleries are joined. some members have 1-4 other members galleries inside their own.

I just wanted to know what I could do, I did get the images to register with the right member but I can't seem to seperate the member galleries.

do i need to delete them and have them recreate the galleries, then transfer their art to the new ones?

i did not post a link because the gallery is fine other than the member albums. thanks
Logged

Phill Luckhurst

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4482
    • Windsurf.me
Re: member galleries after bridging
« Reply #1 on: August 22, 2010, 12:09:22 am »

I'm assuming that you already had members before bridging? If so it will be a lot of work editing user ID's in the database to get it working as you wish. This is why we do not recommend bridging when you already have members. If you have just a few then you should be able to work it out. If you have many then be prepared for a lot of late nights and headscratching resulting in premature baldness.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

heavensportal

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 240
    • The Fantasy Attic
Re: member galleries after bridging
« Reply #2 on: August 23, 2010, 04:26:49 am »

ty, yess i found that out...what it was is that the board was phpbb and many members but they had me change to smf and had the members register anew.

The gallery I just moved from the phpbb directory to the smf one and changed to urls within to register its new home...leaving the database files in their original database--deleting all the phpbb tables.

1. should i put the gallery database into the smf database or is it just fine as is?

yes I had to go through all the images on the database and assign the new userid

as for the member galleries, that is a different story, fortunately there were only a small amount of lost casualties the majority of the images stayed put. I had to move the images to a holding area category with individual albums created holding the images...then deleted the member gallery totally.

after doing all that I then instructed them to recreate their member albums/sub albums and upload 1 image, then myself and another admin moved them home once more.

This is how we finally got the un-nestled member albums...having 3 in one user album was quite a big deal.

I posted what I did in case there is another with the same  thing happening...they might be able to do it too.

thanks
Logged
Pages: [1]   Go Up
 

Page created in 0.013 seconds with 20 queries.